Please select Into the mobile phone version | Continue to access the computer ver.
Air Encoder Error (0x800020)
4540 33 2016-5-24 22:19:54
jsdondelinger
Beginner
United States
Offline

I've only had my Phantom 4 for about a week and then suddenly during mid flight only a couple hundred feet away the video signal disappears! The status at the top of the screen reads No Image Transmission Signal.  Then I get the error message Air Encoder Error (0x800020).  I've tried rebooting all three devices multiple times with no luck of bringing the image signal back and all firmware is current.  I chatted with the online tech support and once I showed them the error message they said that I will have to send it in for repair! Has anybody else encountered this same issue?  Since tech support doesn't know what might have caused this I'm worried that it could happen again!
2016-5-24 22:19:54
Use props
mgtkilledkenny
Intern Pilot
United Kingdom
Offline

No not seen this.. I'm assuming RTH kicked in ok and the craft is safe. ?
2016-5-24 23:56:42
Use props
DJI-Paladin
DJI team
Hong Kong
Offline

Hello jsdondelinger, it is possibly a hardware issue. But you can try to re-flash the firmware via DJI Assistant 2.
2016-5-25 00:39:31
Use props
jsdondelinger
Beginner
United States
Offline

mgtkilledkenny@ Posted at 2016-5-25 00:56
No not seen this.. I'm assuming RTH kicked in ok and the craft is safe. ?


Yes the RTH kicked in perfectly!
2016-5-25 09:35:07
Use props
jsdondelinger
Beginner
United States
Offline

DJI-Paladin Posted at 2016-5-25 01:39
Hello jsdondelinger, it is possibly a hardware issue. But you can try to re-flash the firmware via D ...

I tried to re-flash with assistant 2, but it would fail each time I tried! And tech support told me not to waist my time with it. Sounds like they are aware of this issue!
2016-5-25 09:40:24
Use props
DJI-Paladin
DJI team
Hong Kong
Offline

jsdondelinger Posted at 2016-5-26 01:40
I tried to re-flash with assistant 2, but it would fail each time I tried! And tech support told m ...

Sorry for your issue.I’d suggest you to send it to our service center for diagnosis.We'll do our best to fix it.
2016-5-25 17:44:26
Use props
jsdondelinger
Beginner
United States
Offline

DJI-Paladin Posted at 2016-5-25 18:44
Sorry for your issue.I’d suggest you to send it to our service center for diagnosis.We'll do our  ...

I'm still waiting for my RMA confirmation email reply! You say that you will do your best to fix it, but what happens if you can't? I've only had it for a week so therefor it is under warranty!
2016-5-25 19:10:21
Use props
paw2583
Beginner
United Kingdom
Offline

I got same problem during flight.it and almost very bad.waiting for respond how Dji will repair my Phantom 4.lose video signal at 50m was flying around tree.today report was send out to Dji from my Phantom4.update crashing at65%
What resolution Dji got for costumers refund or replace miss sold not working product
update.jpg
image.png
2016-6-22 13:34:40
Use props
paw2583
Beginner
United Kingdom
Offline

paw2583 Posted at 2016-6-22 22:34
I got same problem during flight.it and almost very bad.waiting for respond how Dji will repair my P ...

Error code for update is 0002
2016-6-22 13:37:04
Use props
dal.little
Beginner
Flight distance : 20288
Offline

Hi Pau2583
I too am having the same issues.
I get the same screens as you in both the DJI Go app and the Assistant 2 app. I thought an update of firmware would solve the issue but updating fails.

Have you resolved your issues?
Thanks
Dal
British Columbia, Canada
dal.little@gmail.com
2016-8-5 12:17:04
Use props
wbear05
Beginner
Offline

Phantom 4:
Having the same issue. "Air Encoder Error" and "No Image Transmission Signal". The Gimbal status is also in a state of "Gimbal Disconnected". I haven't dropped it, crashed it, etc. It's been in the case when not in use. The ribbon cable looks good. I attempted to upgrade and downgrade the firmware, the RC did both no issues, but I couldn't get the P4 downgrade at all. It failed every time.
SIDE NOTE: This happened after I swapped my MicroSD card for a larger capacity card. Coincidence? Perhaps. Still not happy!
A bit frustrating and discouraging that this happened only two weeks after purchase. I'm sending back for a full refund and I will purchase another one at a later time. I would love to know what happened but I may just let it go. It was the first drone that I've owned, but I have prior experience. Hope to see some results from this soon!
2016-8-7 06:12:55
Use props
miles.marriott2
Beginner
Australia
Offline

I had the exact same problem. Thanks for mentioning the SD card. My troubles only started when I installed a 64gb card. I replaced the original one and it's fixed.
2016-8-9 23:13:01
Use props
swansea_van_man
Beginner
United Kingdom
Offline

Ive just had the same problem and error code 0x800020 when trying to update firmware. No matter what I did it wouldn't clear. No camera view ... nothing. Then I took out the SD card, put it back in and the code seems to have cleared and update done. I didn't have time to fly the Phantom but so far so good. Hope my experience helps guys.
2016-8-11 11:22:28
Use props
wbear05
Beginner
United States
Offline

swansea_van_man Posted at 2016-8-11 13:22
Ive just had the same problem and error code 0x800020 when trying to update firmware. No matter what ...

Even when i replaced the SD card, and then put the original back in, I still got the same errors. And It's strange it was off and on. The cooling fan would rev up, and the error would appear. Then it would go away, then come back again.
Long story short, I send it back and got my full refund for a defective product. It's been a couple weeks now so i'm going wait 1-2 months for all the updates they push, then purchase another one. I loved it otherwise!!!
2016-8-21 14:06:21
Use props
maxvanfleet6
Beginner
Offline

Same issues here and to boot my Galaxy s7 restarts anytime I attempt to open the app (I've reinstalled restarted etc) or if I try to switch from usb charging to file transfer as some sites suggest.  Won't update either connect to the computer or the phone app always stops at 64% and gives the error code: 0002 Same messages on the app as pictured previously as well as a few more but they come and go.   my original phantom .. thrilled with .... this new one ... I could feed to the pigs and not miss a step.   

Something that completely irritated me was a DJI response from a previous post (I reset the computer hoping that would help) where the person suggested we buy a new mobile device.... Are you kidding me.  How could your product not be tested on such a common phone???

/Rantoff
2016-9-3 07:31:10
Use props
fansd473ae4e
Beginner
Offline

swansea_van_man Posted at 2016-8-12 03:22
Ive just had the same problem and error code 0x800020 when trying to update firmware. No matter what ...

I had the same identical experience including taking out my memory card. After removing the card it all went away. Will fly tomorrow.
2016-11-6 18:45:47
Use props
fansd473ae4e
Beginner
Offline

Same problem happen to me. After removing the SD card 64 GB it all went away. Will fly tomorrow.
2016-11-6 18:48:34
Use props
Thulinm
Hobbyist
Australia
Offline

Same here. Swapped memory card and all good again.  Mavic. See how it goes after formatting the card creating issues. Been using it for a while without any issues.
2017-1-28 22:33:51
Use props
Chief RM
Hobbyist
Flight distance : 41515
United States
Offline

I had the same along with "gimbal disconnected" and had to send for repair. All toll about two weeks from time of shipping to getting it back. I live in Texas so UPS ground may take longer/shorter depending on where you live. They a great job on my P4.
2017-1-29 08:48:55
Use props
WindSoul
Student Pilot
Canada
Offline

wbear05 Posted at 2016-8-7 06:12
Phantom 4:
Having the same issue. "Air Encoder Error" and "No Image Transmission Signal". The Gimbal status is also in a state of "Gimbal Disconnected". I haven't dropped it, crashed it, etc. It's been in the case when not in use. The ribbon cable looks good. I attempted to upgrade and downgrade the firmware, the RC did both no issues, but I couldn't get the P4 downgrade at all. It failed every time.
SIDE NOTE: This happened after I swapped my MicroSD card for a larger capacity card. Coincidence? Perhaps. Still not happy!

never had the issue. however, the two error messages might say that the video encoder encountered a fault and therefore there was no video to transmit. why would the gimbal disconnect, beats me.
the video encoder generates one video stream of 8MB/s which needs to write continuously on the card. so if the card is indisposed, you may encounter a fault, although should not be an encoder but a write fault.
i would try to use the original sd card. or try again with the new card, only reformat the card in the drone. the cards i use currently are kingston, samsung and the original lexar. however, kingston and samsung are 10 times faster, may thats why i never had problems.
also check this thread: http://mavicpilots.com/threads/a ... -possible-fix.3123/
2017-1-29 15:37:57
Use props
Hogie
Beginner
United States
Offline

Exact problem i am having now. Wish someone would find an answer to the issue.
2017-2-20 21:32:03
Use props
Rudders
Beginner
Flight distance : 212799
Jersey
Offline

Guys, I am getting the same issues, but after a lot of testing the current situation is this:

P4 Firmware version 01.02.0602
RC Firmware 1.8.0
App Version 4.0.3 (Go4)

Ok, what happened.

1. About 5 or 6 weeks ago, Firmware upgrade to version 01.02.0602, appeared to stall part way through, left it to finish, battery then flashed the centre two lights (updating battery firmware), that battery has been dodgy ever since.
It shows "Battery damaged" shortly after take off, and no longer displays battery info. If landed and rebooted sometimes its ok again, but cannot be trusted. I have two other batteries all of which came in a kit on Christmas eve so just 2 months old. Those other batteries are so far absolutely fine. Had a couple of minor glitches but otherwise has been flown 4 to 6 times a week for a good 5 weeks.

2. Recently a prompt showing firmware update popped up, let it do it's usual update and then getting a disconnect intermittently ever since.
On boot up currently the P4 takes about 5 to 10 mins to finish several fan spin ups with the SD/Connection light flashing either green or "red red, green green"
The Go 4 app will show that my quad is a P3 Pro until the final fan spin up which then runs constantly, and if it actually finishes the SD/Connection light turns constant green. (doesn't always finish and needs a couple more power cycles)
If I then restart Go4 it will connect, not always and doesn't always give the video signal. If I don't use my tab or phone and just the RC to connect and try a basic flight, it will not connect to the RC unless the SD/Conn light has turned constant green. And with the P4 doing this fan spin up and down for 5 to 10 mins that indicates to me a FIRMWARE issue.

3. Intermittantly I get "No SD Card" error, "Latest Firmware Abnormal" and "Aircraft Encoder Error (0x800020)"

4. After loads of testing over this weekend, I have discounted SD cards as an issue by using several different cards including one from a fully functional P4.
I have also confirmed EXACTLY the same errors appeared when using a Samsung TAB S2 8 (Noting other posts stating could be a usb com port issue requiring a setting tweak in developer mode), well, as I said, EXACTLY the same issues on my LG G5, and a pals Ipad Mini 4 that he uses with his P4

5. Today I tried recalibrating the IMU's, on finishing and resulting reboot, the Go4 app connected very quickly so something happened to the positive, then a prompt appeared that firmware was not consistent and the little slider button appeared, I slid it to the right to accept and the blue flashing banner to the left showed "Updating Phantom 4 01.02.0602"....well hang on a minute that's what it already is!!!???.......so let that finish, and restarted, all good and fully functional...........until the next restart.

6. Now it wants to do the firmware update again, and will not connect...so exactly the same.

7. Have already "restored to factory defaults" using the Assistant 2", and also note there is no longer an option to roll back to a previous firmware version, the only one listed is "..0602"

So currently have a "bricked" P4 and 1 out of 3 batteries in an unstrustworthy condition.

My thoughts from an IT perspective is that either there is some dodgy code in the firmware, or my quad and maybe others out there have a fried or otherwise compromised firmware chip.

Last weekend I was flying a rescue mission within 3 meters forward and behind in a reveen 60 meters below take off point off a cliff and over the sea.......this weekend it wont even get out of the house!!!
2017-2-26 13:37:29
Use props
PedroRodrigues
Beginner
Brazil
Offline

Hi there!

I'm having exactly the same issue (Phantom 4) as RUDDERS.

Does anybody fixed it?

Thank you!
2017-3-3 10:53:39
Use props
Rudders
Beginner
Flight distance : 212799
Jersey
Offline

Mine is going back to Holland to be looked at.....if they sort out the RMA that is!!!!
2017-3-6 12:21:09
Use props
Ken Hada
Beginner
United States
Offline

I got the same error code when starting the craft without a sd card insterted. Once a put a sd card in I got my camera back. But know the camera goes on and off. every time the fan on the aircraft turns on the the video signal drops.
2017-5-19 07:15:29
Use props
Rudders
Beginner
Flight distance : 212799
United Kingdom
Offline

Mine did get repaired by RMA back to Holland. It took just short of three weeks all in. I reckon it was firmware failure, DJI quoted it as the gimble???

Having other issues since the moment I took it out of the box and DJI have not responded to any of my emails:

1. All four landing gear mounting points have cracks where they screw to the body
2. There is a loose screw or plastic part rattling around in the body (hope its not a screw...it could find itself shorting something out.
4. Gimble now drops the camera to the ground when powered off so it is now prone to getting the filter scratched.
5. After ONE afternoon of flying, more cracks to the legs and another on the aircraft body where the leg touches it. Smacks of overtightened screws to me.

Hope you guys get yours sorted.....and with better quality control than mine had!!!
2017-5-19 12:43:51
Use props
DJI-Jamie
DJI team
Flight distance : 34239
Canada
Offline

Rudders Posted at 2017-5-19 12:43
Mine did get repaired by RMA back to Holland. It took just short of three weeks all in. I reckon it was firmware failure, DJI quoted it as the gimble???

Having other issues since the moment I took it out of the box and DJI have not responded to any of my emails:

Could you please provide your previous case number so I can look into it?
2017-5-19 14:04:07
Use props
DJI-Jamie
DJI team
Flight distance : 34239
Canada
Offline

Ken Hada Posted at 2017-5-19 07:15
I got the same error code when starting the craft without a sd card insterted. Once a put a sd card in I got my camera back. But know the camera goes on and off. every time the fan on the aircraft turns on the the video signal drops.

Is this regarding a Phantom or a Mavic? If it's regarding the latter, it would be best to have your own Mavic thread on this issue. It should include your current firmware information and any other information you may have regarding when this started to occur for you.
2017-5-19 14:06:16
Use props
Rudders
Beginner
Flight distance : 212799
United Kingdom
Offline

Hi Jamie and thanks for the reply, this is for the Phantom 4, my RMA ref: CAS-485111-X1Q3J5

On the subject of starting my own thread, everything I have tried to post has not been published??

Regards

Marc
2017-5-20 04:19:58
Use props
Rudders
Beginner
Flight distance : 212799
United Kingdom
Offline

Hey Jamie, I resent my complaint emails with smaller images of the cracked mounting points, I then received a prompt response and a log number (my files must have been too large for your email system)

Ref they gave is: 548776

Regards
2017-5-20 04:28:24
Use props
METHODICALMAN1
Beginner
United States
Offline

Ok Im having the same problem, same problem and error code 0x800020. I have only had maybe 4 or 5 flights after my purchase .  A LOT  of money to have experienced this PROBLEM this early with the DJI phantom 4.
2017-5-23 18:19:03
Use props
Rudders
Beginner
Flight distance : 212799
United Kingdom
Offline

DJI-Jamie Posted at 2017-5-19 14:06
Is this regarding a Phantom or a Mavic? If it's regarding the latter, it would be best to have your own Mavic thread on this issue. It should include your current firmware information and any other information you may have regarding when this started to occur for you.

Jamie, further to the last, Customer Service acknowledged my emails about a week ago, and since that, nothing else.

The cracks around the landing gear mounting points are getting bigger, and one on the body is "growing" also. It has been gently landed, usually in grass or on soft beach sand, so the cracks are not being stressed. I guess the obviously over-tightened screws are taking effect.

The quad still has gimble issues where it drops to the ground when powered off, it also does not calibrate and needs the adjustment set to something more than + 2.

There is still either a screw or plastic part rattling around inside the body, sometimes getting stuck god knows where.

I know you are busy....probably even more so after this latest update...nothing like shooting yourselves in the foot once again.

Please make a move on my problems.....currently all created by your repair center.
1 day ago
Use props
Rudders
Beginner
Flight distance : 212799
United Kingdom
Offline

1 day ago
Use props
Chicomnc
Beginner
Mexico
Offline

Hello friends.
I have the same problem caused by the memory card change. The gimbal is disconnected, error message 0x800020, No Image Transmission Signal. Then I get the error message Air Encoder Error (0x800020).
Can someone tell me what the solution is?
Thank you
9 hours ago
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next