Please select Into the mobile phone version | Continue to access the computer ver.
A3 Pro ESC Error | S1000+ with LB2
403 10 2017-1-9 08:26:16
vonganzoben.de
Beginner
Germany
Offline

Since i upgraded my S1000+, LB2 from the A2 to the A3 Pro i have an issue with the ESCs.
The DJI Assistant is telling me that i need to contact DJI Support.

In the DJI Go App it´s telling me "ESC-Error".
When i do the motor test, only 3 Motors will rotate, when i do the calibration all Motors spin up and work. They get also initialised without errors. No beep, after boot.

Whats wrong here?

2017-1-9 08:26:16
Use props
SkySight Aerial
Intern Pilot
United Kingdom
Offline

You need to set the S1000 ESC's as non DJI intelligent ESC now, it was different in the last version. For belt and braces, I calibrated the ESC's although I am not certain if that is necessary.
I suggest you set the 'brake' to 60 plus as otherwise it takes an age to stop in P mode.
I have tested mine and I have to say the results are very promising.
2017-1-9 09:48:05
Use props
vonganzoben.de
Beginner
Germany
Offline

SkySight Aerial Posted at 2017-1-9 09:48
You need to set the S1000 ESC's as non DJI intelligent ESC now, it was different in the last version. For belt and braces, I calibrated the ESC's although I am not certain if that is necessary.
I suggest you set the 'brake' to 60 plus as otherwise it takes an age to stop in P mode.
I have tested mine and I have to say the results are very promising.

Still the same.
When doing the calibration there´s written that i need to unplug the ESC-Cable, i unplug it, it starts beeping, plug it back in - motor spinning - finish.

Motortest no reaction.
2017-1-9 10:18:32
Use props
vonganzoben.de
Beginner
Germany
Offline

Update: I replaced the ESC-Cables with longer ones (around 60 cm), because of the mounting position of the A3 Flight Controller in the Tutorial Video, because the original ESC-Cables were way to short. Now i just turned the A3 Flight Controller 180 degrees against flight direction, so the original cables fit - and tadaaa: No ESC-Failure. All Motors start spinning one after another.

Maybe the longer ESC-Cables but some interferences on the BUS.
2017-1-10 03:27:39
Use props
DJI-Jamie
DJI team
Flight distance : 34239
United States
Online

vonganzoben.de Posted at 2017-1-10 03:27
Update: I replaced the ESC-Cables with longer ones (around 60 cm), because of the mounting position of the A3 Flight Controller in the Tutorial Video, because the original ESC-Cables were way to short. Now i just turned the A3 Flight Controller 180 degrees against flight direction, so the original cables fit - and tadaaa: No ESC-Failure. All Motors start spinning one after another.

Maybe the longer ESC-Cables but some interferences on the BUS.

Good to hear that you were able to get yourself up and running. What you're describing could have been the case, but let us know if the error comes back.
2017-1-10 16:01:41
Use props
vonganzoben.de
Beginner
Germany
Offline

DJI-Jamie Posted at 2017-1-10 16:01
Good to hear that you were able to get yourself up and running. What you're describing could have been the case, but let us know if the error comes back.

Hi Jamie,

the longer ESC-Cables could  be part of the problem. They other problem was, that in the DJI Assistant there is a default power setting of 5% for the motor test.

That was the main problem. After increasing this to 15% everything started spinning fine. But the Assistant won´t save this value, so you need to enter it every time you run a motor test.

DJI Germany added this to their knowledgebase.
2017-1-19 01:02:56
Use props
DJI-Jamie
DJI team
Flight distance : 34239
United States
Online

vonganzoben.de Posted at 2017-1-19 01:02
Hi Jamie,

the longer ESC-Cables could  be part of the problem. They other problem was, that in the DJI Assistant there is a default power setting of 5% for the motor test.

Have you tried the latest v1.0.9-2 Assistant 2 software to see if the parameters saves properly? That's a pretty recent software update.
2017-1-19 11:04:45
Use props
ducpeter
Intern Pilot
Germany
Offline

that's true, this assistant 2 its working perfect and very clearly arranged
2017-1-19 12:16:57
Use props
edwoodza
Beginner
Flight distance : 107215
South Africa
Offline

Same here. changing ESC to non DJI worked and changing to 15% also worked.
since its not DJI ESC setting are there any specific settings we need to set to ensure it all works correctly esc wise.

also latest assistant 2 software works well.
just one thing to note if you have older version and you do firmware update the old assistant software will not work. install the new one and all good (that was half a day of my life wasted to discover that)
2017-1-25 22:45:18
Use props
David G.
Beginner
United States
Offline

I hate the fact that I need to spend hours searching the forum because the DJI industrial software and firmware is not setup to work. Even though it is marketed as the industrial standard, it is lacking. I just fried a motor connector on the S1000 following the screen prompts to unplug and re-plug the connector as part of the calibration process. Had I known to first try increasing the test power, I would have done that first.

There is nothing on the prompt to differentiate between the ESC signal connector or the ESC power connector.
2017-3-20 10:55:26
Use props
edwoodza
Beginner
Flight distance : 107215
South Africa
Offline

yeah DJI documentation is not the greatest and whats in the docs is not often correct either.
Support emails are usless too
2017-3-31 01:49:24
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next