Please select Into the mobile phone version | Continue to access the computer ver.
Using ZENMUSE X3
297 10 2017-3-13 17:51:38
LICENSED PILOT
Intern Pilot
Flight distance : 110064
United States
Offline

What FW upgrade do I need to do to get an X3 to connect to the Inspire 1 Pro?
X3.JPG
2017-3-13 17:51:38
Use props
Henry M.Y.
Intern Pilot
Flight distance : 1635240
Hong Kong
Offline

What version of FW your Inspire 1 Pro currently has?

For the X3 to be connected to your Inspire 1 Pro, the Inspire 1 FW version 01.10.01.40(X3) (released on 15 Dec 2016), and version 1.9.1.30(X3) (released on 7 Jul 2016) are available on this DJI Inspire 1 downloads page for you to choose and install. If your Inspire 1 Pro currently has FW version 1.9.1.30 or later, you may install either of the aforementioned X3 FW. If your Inspire 1 Pro currently has FW version earlier than FW 1.9.1.30, you may consider FIRSTLY upgrading the Inspire 1 Pro FW to version 1.9.1.30 or later, with remote controller off, AND THEN upgrading the remote controller to the latest FW version 1.7.60 BEFORE upgrading the X3 connected to your Inspire 1 Pro with either of the aforementioned X3 FW. Always turn off remote controller when upgrading the Inspire 1 Pro (regardless of upgrading with X3 or X5).

You may just ignore the Inspire 1 FW version 1.3.0.0 (released on 4 Aug 2015) because the earliest release of Inspire 1 Pro was in late Sep 2015.

Henry
2017-3-14 05:30:41
Use props
LICENSED PILOT
Intern Pilot
Flight distance : 110064
United States
Offline

Henry M.Y. Posted at 2017-3-14 05:30
What version of FW your Inspire 1 Pro currently has?

For the X3 to be connected to your Inspire 1 Pro, the Inspire 1 FW version 01.10.01.40(X3) (released on 15 Dec 2016), and version 1.9.1.30(X3) (released on 7 Jul 2016) are available on this DJI Inspire 1 downloads page for you to choose and install. If your Inspire 1 Pro currently has FW version 1.9.1.30 or later, you may install either of the aforementioned X3 FW. If your Inspire 1 Pro currently has FW version earlier than FW 1.9.1.30, you may consider FIRSTLY upgrading the Inspire 1 Pro FW to version 1.9.1.30 or later, with remote controller off, AND THEN upgrading the remote controller to the latest FW version 1.7.60 BEFORE upgrading the X3 connected to your Inspire 1 Pro with either of the aforementioned X3 FW. Always turn off remote controller when upgrading the Inspire 1 Pro (regardless of upgrading with X3 or X5).

Thank you Henry. I followed your instructions and  installed FW 01.10.01.40.
The Version screen looks like this:
      
controller update.PNG
2017-3-14 08:04:11
Use props
DJI-Jamie
DJI team
Flight distance : 34239
United States
Offline

LICENSED PILOT Posted at 2017-3-14 08:04
Thank you Henry. I followed your instructions and  installed FW 01.10.01.40.
The Version screen looks like this:


It may seem a bit pedantic, but just wanted to clarify that v1.10.1.40 is available for both the Inspire 1 (X3) and the Inspire 1 Pro (X5) download packages. Both cameras currently display v1.10.1.40 as the camera version as well when connected to the Go app. You can use either camera to upgrade the aircraft as long as you use the corresponding .Bin file for the camera being used. If you need to update the other camera as well, use the corresponding .Bin file, and only the camera would get updated since the craft is already up to date.

Are you still getting the N/A in the areas you highlighted in the initial post even after updating the X3? I'm assuming that the pictures you provided were using the X3, please let me know if I'm incorrect.
2017-3-14 10:44:43
Use props
Henry M.Y.
Intern Pilot
Flight distance : 1635240
Hong Kong
Offline

LICENSED PILOT Posted at 2017-3-14 08:04
Thank you Henry. I followed your instructions and  installed FW 01.10.01.40.
The Version screen looks like this:

It seems a little bit strange to me - your flight controller serial number was not shown in DJI GO App after the upgrades. Have you reviewed the FW upgrade log file (inside a hidden folder in the micro SD card) to confirm all devices that required upgrading had indeed been upgraded?

Henry
2017-3-15 05:16:16
Use props
LICENSED PILOT
Intern Pilot
Flight distance : 110064
United States
Offline

DJI-Jamie Posted at 2017-3-14 10:44
It may seem a bit pedantic, but just wanted to clarify that v1.10.1.40 is available for both the Inspire 1 (X3) and the Inspire 1 Pro (X5) download packages. Both cameras currently display v1.10.1.40 as the camera version as well when connected to the Go app. You can use either camera to upgrade the aircraft as long as you use the corresponding .Bin file for the camera being used. If you need to update the other camera as well, use the corresponding .Bin file, and only the camera would get updated since the craft is already up to date.

Are you still getting the N/A in the areas you highlighted in the initial post even after updating the X3? I'm assuming that the pictures you provided were using the X3, please let me know if I'm incorrect.

No NA readings, everything works as it should.
2017-3-16 14:09:02
Use props
DJI-Jamie
DJI team
Flight distance : 34239
United States
Offline

LICENSED PILOT Posted at 2017-3-16 14:09
No NA readings, everything works as it should.

Good to hear!
2017-3-16 14:46:37
Use props
Upthedowns
Hobbyist
Flight distance : 86072
United Kingdom
Offline

DJI-Jamie Posted at 2017-3-14 10:44
It may seem a bit pedantic, but just wanted to clarify that v1.10.1.40 is available for both the Inspire 1 (X3) and the Inspire 1 Pro (X5) download packages. Both cameras currently display v1.10.1.40 as the camera version as well when connected to the Go app. You can use either camera to upgrade the aircraft as long as you use the corresponding .Bin file for the camera being used. If you need to update the other camera as well, use the corresponding .Bin file, and only the camera would get updated since the craft is already up to date.

Are you still getting the N/A in the areas you highlighted in the initial post even after updating the X3? I'm assuming that the pictures you provided were using the X3, please let me know if I'm incorrect.

Jamie, just for clarification.  I have an I1V2 (X3) and an IP (X5).  Each is running latest firmware (01.10.01.40) each of which was loaded through its respective camera.

Am I free now to swap cameras freely between the two airframes and everything will work?
2017-3-20 00:17:18
Use props
Henry M.Y.
Intern Pilot
Flight distance : 1635240
Hong Kong
Offline

Upthedowns Posted at 2017-3-20 00:17
Jamie, just for clarification.  I have an I1V2 (X3) and an IP (X5).  Each is running latest firmware (01.10.01.40) each of which was loaded through its respective camera.

Am I free now to swap cameras freely between the two airframes and everything will work?

You will be fine swapping cameras freely between the 2 aircrafts provided that you have installed the landing gear riser kit to the I1V2 aircraft.

Henry
2017-3-20 06:16:54
Use props
DJI-Jamie
DJI team
Flight distance : 34239
United States
Offline

Upthedowns Posted at 2017-3-20 00:17
Jamie, just for clarification.  I have an I1V2 (X3) and an IP (X5).  Each is running latest firmware (01.10.01.40) each of which was loaded through its respective camera.

Am I free now to swap cameras freely between the two airframes and everything will work?

Yes, you're good to go!
2017-3-20 09:29:18
Use props
Upthedowns
Hobbyist
Flight distance : 86072
United Kingdom
Offline

Thanks guys.  I assumed that had to be the answer but with complex kit like this it's nice to be sure.
2017-3-21 12:44:33
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next