Please select Into the mobile phone version | Continue to access the computer ver.
Takeoff/Hover issues
175 5 2017-3-20 14:34:57
fansf7fb2cec
Beginner
United States
Offline

Hello,

I received my Mavic Pro a couple weeks ago and have only had a chance to fly it a couple times even though I've tried multiple times. The majority of the time when I take off, it immediately descends and asks to land. I can throttle up and ascend but if I let go it will immediately start to descend. If I throttle up and move away from my takeoff point, RTH will initiate. It doesn't matter how many times I cancel the landing, it just keeps popping up. I've searched online and this doesn't seem to be a common problem.

Some observations:

- I've only tried to take off from my driveway and from a park a few miles away.
- it has never allowed a proper takeoff or even hover from my driveway, the two successful flights were from the park, but I have the problem sometimes there as well
- I've been close to my vehicle so maybe that is interferring?

Warnings:

- Aircraft close to Home Point. "go home" shifts to "landing" (again this happens literally right after takeoff)
- I also get Strong Wireless Intererence warnings at both locations some of the time

I calibrated the controller and compass straight out of the box and this has been a continual problem. This is my first drone so perhaps I have a setting activated that shouldn't be? Any help would be greatly appreciated. Thanks.
2017-3-20 14:34:57
Use props
Jenee 2
Student Pilot
Flight distance : 17966
Australia
Offline

Is your battery fully charged for both the controller and Mavic? Have you looked at the settings in DJI GO app for the battery to see where it is set for warning and critical.
It seems that something is triggering the need to land or RTH.
2017-3-20 20:06:40
Use props
rnrnrn
Hobbyist
Flight distance : 6138
Germany
Offline

This is a bit strange. Do double check what zone you're flying in - maybe too close to an airport and/or the no fly zones are wrongly assessed by DJI in your area? Whatever device you're flying with as the screen - do switch over to flight mode on it to minimize interference from the device - I have a Samsung S7 and if I don't switch it over to flight mode I do get interference warnings (anyhow - you don't want to receive a call when flying anyhow).

See if this helps ;-)
2017-3-20 21:47:15
Use props
Jason Lane
Intern Pilot
Flight distance : 71391
Philippines
Offline

I recently saw somebody post on Facebook (I think) with what sounds like the same issue. Was that you?

I suggested that perhaps the RTH button on the remote is jammed or defective.

I supposed you could try flying in WiFI mode, without the remote, and see what happens?
2017-3-20 23:52:18
Use props
DJI Mindy
Moderator
China
Offline

Please sync your flight records from DJI GO app and let me know your DJI account email and the exact date this occurred.
I'll help to review the flight records.
4 days ago
Use props
fansf7fb2cec
Beginner
United States
Offline

Ok, today I calibrated everything again at the park. I also clicked and wiggled the RTH button a bunch of times on the controller to make sure it wasn't stuck (it didn't feel like it). Surprise, surprise it took off with no problems!
When I got home I set it in my driveway and again, it took off and hovered with no issues.

So, I'm not sure if it was redoing the calibrations or if the RTH button really was stuck on the controller, but thank you Jason for the suggestion!
4 days ago
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next