Please select Into the mobile phone version | Continue to access the computer ver.
HELP: Spark WiFi never shows up
24692 24 2017-6-15
Uploading and Loding Picture ...(0/1)
o(^-^)o
Nixx
New
Flight distance : 17352 ft
United States
Offline

I just got my Spark FlyMore combo, charged the batteries fully and powered the unit on.  I get solid red lights in front, blinking yellow on the back.  I'm trying to activate and the Spark's WiFi never shows up in my list of networks.  I can turn on the remote and it's WiFi shows up just fine, but I cant activate through that.  Am I not powering up correctly to get into WiFi setup (Cick then click and hold).  Do i need to perform some kind of hardware reset?  I've powered off and on a dozen times trying to get it to work.  Help!
2017-6-15
Use props
fansa2a50cc9
lvl.2
United States
Offline

Watch the Activation tutorial they posted, you have to de-link the spark from the remote for it's wifi network to come up.  Hold the button for 6 second, you should hear 2 beeps.
2017-6-15
Use props
Nixx
New
Flight distance : 17352 ft
United States
Offline

Solved!
With the Spark powered on I had to hold down the power button for 6 seconds to set it back into WiFi control mode.  It Will beep once at 3 seconds, and twice at 6 seconds.  After that the Wifi was discoverable again.  I hope this helps someone else.
2017-6-15
Use props
Nixx
New
Flight distance : 17352 ft
United States
Offline

fansa2a50cc9 Posted at 2017-6-15 11:55
Watch the Activation tutorial they posted, you have to de-link the spark from the remote for it's wifi network to come up.  Hold the button for 6 second, you should hear 2 beeps.

Thank you, i found this myself and it must have been right as you replied.  I didn't see that anywhere in the quick-start, and there is no troubleshooting in the manuals.
2017-6-15
Use props
jpap
Second Officer
Flight distance : 1780679 ft
Greece
Offline

Hey, we were having similar wifi issues. It looks that no android phone (Galaxy A5, Galaxy S7, Galaxy S7 edge) were able to see Spark's wifi network. Two iPhone connected without problems.
In fact, using an iPhone and GO 4 App, we changed Wifi band from 5.8G to 2.4G and then all androids were able to see and connect to Spark's SSID . Go figure!
The problem is that Spark's owner has an Galaxy S7 edge, and every time he turns on the Spark it goes to 5.8G band and he can't connect...  
2017-6-15
Use props
fans7dd18b97
lvl.1
United States
Offline

Thanks had the same issue and now works perfectly
2017-6-15
Use props
Wachtmeister
lvl.1
  • >>>
Switzerland
Offline

jpap Posted at 2017-6-15 12:34
Hey, we were having similar wifi issues. It looks that no android phone (Galaxy A5, Galaxy S7, Galaxy S7 edge) were able to see Spark's wifi network. Two iPhone connected without problems.
In fact, using an iPhone and GO 4 App, we changed Wifi band from 5.8G to 2.4G and then all androids were able to see and connect to Spark's SSID . Go figure!
The problem is that Spark's owner has an Galaxy S7 edge, and every time he turns on the Spark it goes to 5.8G band and he can't connect...

How exactly did you manage to do this? I'm slowly going nuts here, trying to connect my Spark to the Samsung Galaxy S7 Edge. As soon as the Spark's wifi is hidden, the phone won't find it any more. The only solution so far is to reset Spark's wifi (hold button for 9s / 3 beeps) every single time at startup. [Everything seems to run smoothly when using an iPad mini..].
2017-6-17
Use props
daveio
lvl.2
Flight distance : 1890 ft
United Kingdom
Offline

I've worked out what's been causing this and posted details and a workaround here.
2017-6-17
Use props
Wachtmeister
lvl.1
  • >>>
Switzerland
Offline

daveio Posted at 2017-6-17 06:13
I've worked out what's been causing this and posted details and a workaround here.

Thanks, good overview! So what you're basically saying: It works well with Apple devices and it's shaky to crappy at best with Android?
2017-6-17
Use props
daveio
lvl.2
Flight distance : 1890 ft
United Kingdom
Offline

Wachtmeister Posted at 2017-6-17 06:29
Thanks, good overview! So what you're basically saying: It works well with Apple devices and it's shaky to crappy at best with Android?

I don't have any Apple hardware to test with, so I can't verify compatibility with the Asia-only bit of 5GHz spectrum (channel 149+) the Spark will happily set itself up in. And if I'm right, you'll only run into this problem in the first place if the 2.4GHz band is congested.
2017-6-17
Use props
daveio
lvl.2
Flight distance : 1890 ft
United Kingdom
Offline

daveio Posted at 2017-6-17 08:53
I don't have any Apple hardware to test with, so I can't verify compatibility with the Asia-only bit of 5GHz spectrum (channel 149+) the Spark will happily set itself up in. And if I'm right, you'll only run into this problem in the first place if the 2.4GHz band is congested.

Certainly when it can find itself a channel both it and your device is happy with - I turned off my radios on 2.4GHz channel 6 to allow it to see channel 6 as quiet and use it - the experience on Android was solid, smooth, and problem-free.
2017-6-17
Use props
fans9cb8bf7b
lvl.1
Flight distance : 11946 ft
Philippines
Offline

I have the same issue using Xiaomi Mi3 but with Lenovo A7000 Plus it always connect seamlessly, probably they have different WIFI hardware specs? Weird thing is that my Xiaomi Mi3 doesn't have problem connecting with other wifi networks, it only happens with Spark.
2017-6-21
Use props
fans9cb8bf7b
lvl.1
Flight distance : 11946 ft
Philippines
Offline

daveio Posted at 2017-6-17 08:59
Certainly when it can find itself a channel both it and your device is happy with - I turned off my radios on 2.4GHz channel 6 to allow it to see channel 6 as quiet and use it - the experience on Android was solid, smooth, and problem-free.

How do you turn off radio on specific wifi channel in your phone?
2017-6-22
Use props
daveio
lvl.2
Flight distance : 1890 ft
United Kingdom
Offline

You don't, and you don't want to. I have three wireless APs in my home, the 2.4GHz radios of which use channels 1, 6, and 11. I disabled the AP on channel 6 to quieten it up.
2017-6-24
Use props
Jebb
lvl.1
Flight distance : 11946 ft
Philippines
Offline

daveio Posted at 2017-6-24 13:23
You don't, and you don't want to. I have three wireless APs in my home, the 2.4GHz radios of which use channels 1, 6, and 11. I disabled the AP on channel 6 to quieten it up.

Alright I got your point, thanks. Anyway, doing that might not eliminate the issue when you are in other place with wifi networks that you don't have access to turn off those channels right?
2017-6-24
Use props
daveio
lvl.2
Flight distance : 1890 ft
United Kingdom
Offline

Correct. The fix is something DJI need to implement - specifically, only allowing the Spark to use channels 36-48 on 5GHz (along with 1-12 on 2.4GHz) for its automatic quiet channel search.
2017-6-26
Use props
nils.heidorn
lvl.4
Flight distance : 183533 ft
Germany
Offline

Confirmed, i can workaround if using "WiFixManager.apk" and thus switching the region to "CN". But of course only works on rooted S7 Edge, NOT on my Moverios...
Stupid...

Nils

P.S. a lot of *very* fishy downloadsites for it, i used this download, also no guarantees but worked for me without Malware i could detect:
https://m.allfreeapk.com/wifix-manager,329476/download.html

2017-6-26
Use props
vilmarjunior
lvl.2
Flight distance : 121135 ft

Brazil
Offline

#Quick Reply Here#Good afternoon. In my case I have the Spark in control. Plus his control is just flashing the red lights. It is no use doing the procedures of pressing the 3 buttons simultaneously. The radio does not appear on the wifi to be connected on the phone nor bind with the drone. What can it be. I'm finding it to be a problem with the control's wifi transmitter. Will be?
2018-11-20
Use props
Mike Powney
lvl.1
Flight distance : 1801 ft
United Kingdom
Offline

Please    help     I had    no issues      couldn't fly due to the weather for 3 weeks   ...but now   it   won't connect at all    can't find   spark wifi on its   own   can connect to remote ok...I have a combo    when I press   batt button    for   9 secs   or longer   I get no beeps....      dji say it has to go back    can't see what has happened  whilst it's   Benn packed away... please    help as going away   soon and want to take with me .....mike
2019-1-3
Use props
fans86daa594
lvl.1
Luxembourg
Offline

Hi i get no beep neither when i hold power for 3s, 6s or 9 seconds. So i cannot pair becquse my phone does not see the wifi.

Help please.
2019-1-17
Use props
gmozo
Second Officer
United States
Offline

did you go through the instructions correctly ?
2019-1-19
Use props
gmozo
Second Officer
United States
Offline

did you go through the instructions correctly ?
2019-1-19
Use props
SpartSter
lvl.1
Canada
Offline

Whn I connect Dji Spark to my wifi, after few seconds my cell phone gives a pop up message "Internet unavailable with Spark"? But I can connect to spark and open dji go 4 app and connect to my sji spark camera but there is no GPS.
2019-7-28
Use props
StorePlayApk
lvl.1

India
Offline

https://storeplayapk.com/intro-maker-mod-apk
https://storeplayapk.com/funimate-pro-mod-apk
https://storeplayapk.com/picsay-pro-apk
https://storeplayapk.com/blue-kinemaster-pro-mod-apk
https://storeplayapk.com/octopus-mod-apk
https://storeplayapk.com
https://statusvideo.app
https://idlemod.com
2-2 09:58
Use props
StorePlayApk
lvl.1

India
Offline

Intro Maker Mod Apk
Funimate Pro Mod Apk
Blue Kinemaster Pro Mod Apk
PicSay Pro Apk
Octopus Mod Apk Premium
StorePlay Apk
StatusVideoApp
IdleMod
2-2 10:01
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules