Please select Into the mobile phone version | Continue to access the computer ver.
So disappointed! RC connection with Spark only fly 100meters and...
11481 32 2017-6-18
Uploading and Loding Picture ...(0/1)
o(^-^)o
MAVICDLNM
Second Officer
Flight distance : 8298442 ft
  • >>>
Hong Kong
Offline

For people who bought the solo Spark version no need to rush and get the RC.  It does not perform as it said, 2KM?!! thats a perfect joke!  I fly yesterday in a place I fly Mavic tons of time and easily get over 1-2km distance.  Guess what I got from Spark with RC??  100meters disconnected and triggered RTH.  Absolutely JOKE, that remind me when the time I fly my Parrot Bebop.  The video feed within 100meters is distribed and delay as well.  Nothing anything I expected from DJI, really disappointed.  

The main reason I think is the NEWLY wifi connection from your phone device with the RC, which rarely used such type of connection since P3P.  I have call up DJI support and they said the USB cable connect to phone device is not supported.  I tried with the cable came with Mavic and connect to my iphone and does not connect.  But the same I tried with my Android base BT300 it does showed connected but once press Let's fly the app just quit itself.  This is one major problem whether this RC is good to buy or another rubbish created.  If DJI not solve this then is a shame to see such good product go to be major failure of DJI this year.  

Be honestly the gesture control work like a charm!  Very much enjoy it, but won't help if you can't control Spark freely with RC.  I am using iPhone 7 plus with all the latest firmware and go4 version.  Let see how DJI really face it.
2017-6-18
Use props
GCBrent
lvl.4
Flight distance : 66286 ft
Australia
Offline

Have you tried changing the wifi channel?
2017-6-18
Use props
MAVICDLNM
Second Officer
Flight distance : 8298442 ft
  • >>>
Hong Kong
Offline

GCBrent Posted at 2017-6-18 21:30
Have you tried changing the wifi channel?

yes did like the other treat posted, the 5.8Ghz is burned in and can’t change to 2.4Ghz no matter what I do.
2017-6-18
Use props
Scott7161
lvl.4
  • >>>
United States
Offline

You're gunna need to turn the phone into airplane mode and then open the wifi and connect to the phone or tablet only.  Either that or use an old Phantom 4 connector and plug your Spark remote into the RC.  I was getting only about 200 meters until I switched on airplane mode on my phone.  It made a big difference.  Good luck.  PS:  I haven't actually tried connecting my phone to the remote via USB but I saw a guy do it in a youtube video and he got great results.
2017-6-18
Use props
Scott7161
lvl.4
  • >>>
United States
Offline

MAVICDLNM Posted at 2017-6-18 21:35
yes did like the other treat posted, the 5.8Ghz is burned in and can’t change to 2.4Ghz no matter what I do.

Okay, now I can say with experience that connecting your Spark controller via micro USB -> Apple iPad or iPhone and leaving your device in airplane mode works.  I needed to plug the micro USB cable in after the remote was on for it to recognize it but it works.  Try it!  Also if you want to stick with linking your remote to your mobile device, try disabling bluetooth.  I have an Apple Watch and I'm pretty sure that my bluetooth connection was messing with the Sparks RC signal.  Good luck.  
2017-6-18
Use props
MAVICDLNM
Second Officer
Flight distance : 8298442 ft
  • >>>
Hong Kong
Offline

Scott7161 Posted at 2017-6-18 22:41
Okay, now I can say with experience that connecting your Spark controller via micro USB -> Apple iPad or iPhone and leaving your device in airplane mode works.  I needed to plug the micro USB cable in after the remote was on for it to recognize it but it works.  Try it!  Also if you want to stick with linking your remote to your mobile device, try disabling bluetooth.  I have an Apple Watch and I'm pretty sure that my bluetooth connection was messing with the Sparks RC signal.  Good luck.

Thanks, so I have to go electronically NUDE in order to play Spark with RC?  This is just great experience.
2017-6-18
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Offline

MAVICDLNM Posted at 2017-6-18 21:35
yes did like the other treat posted, the 5.8Ghz is burned in and can’t change to 2.4Ghz no matter what I do.

Sorry to hear about your experience, actually speaking, you could switch 5.8Ghz to 2.4Ghz manually via APP, please remember to select the best channel as well and confirm the settings, then connect the Spark WiFi again after its rebooting.
2017-6-19
Use props
MAVICDLNM
Second Officer
Flight distance : 8298442 ft
  • >>>
Hong Kong
Offline

DJI Natalia Posted at 2017-6-19 03:59
Sorry to hear about your experience, actually speaking, you could switch 5.8Ghz to 2.4Ghz manually via APP, please remember to select the best channel as well and confirm the settings, then connect the Spark WiFi again after its rebooting.

As I said I did switch to 2.4Ghz and channel, but after restart it just change back to 5.8Ghz....  
2017-6-19
Use props
MAVICDLNM
Second Officer
Flight distance : 8298442 ft
  • >>>
Hong Kong
Offline

Scott7161 Posted at 2017-6-18 22:41
Okay, now I can say with experience that connecting your Spark controller via micro USB -> Apple iPad or iPhone and leaving your device in airplane mode works.  I needed to plug the micro USB cable in after the remote was on for it to recognize it but it works.  Try it!  Also if you want to stick with linking your remote to your mobile device, try disabling bluetooth.  I have an Apple Watch and I'm pretty sure that my bluetooth connection was messing with the Sparks RC signal.  Good luck.

Thanks, and I finally got it work!  I found out it has nothing to do with airplanes mode or Apple watch.  But your tips about the plug in sequence is the key.

I needed to plug the micro USB cable in after the remote was on for it to recognize it but it works.  Try it!  
2017-6-19
Use props
PandaFlyingcat
Second Officer
Flight distance : 2014111 ft
China
Offline

MAVICDLNM Posted at 2017-6-18 23:29
Thanks, so I have to go electronically NUDE in order to play Spark with RC?  This is just great experience.

stop whining and tell us whether it worked!

come on buddy. i have also best results with my p4 when i turn my phone to airplane mode and have no other people with phones around/fly alone. if you fly, you fly, dont need get messages from your friends or check facebooks every 10 seconds right?
if i make a nice video i am happy when i not get disturbed by phone all time.

and if you really cant accept the poor range, send your spark to me. i will test it for you. 1-2 years (to make sure i didnt forget anything hehe)
2017-6-19
Use props
The Sparky
lvl.1
Switzerland
Offline

I can't even register!
2017-6-19
Use props
Hummingbird.UAV
Captain
Flight distance : 7141677 ft
  • >>>
Canada
Offline

I have tried a micro USB / apple cable.  It worked very nicely .  Image on the mini iPad was much cleaner than when I used the wifi connection.  Had to plug the cable in after everything was powered up to get it to connect.
2017-6-19
Use props
fans1a9af154
lvl.2
Flight distance : 57287 ft
Australia
Offline

Do you get better battery life using the USB cable?
2017-6-21
Use props
aviscomi
lvl.4

United States
Offline

fans1a9af154 Posted at 2017-6-21 00:57
Do you get better battery life using the USB cable?

The battery savings on the RC using the USB/OTG cable would be extremely minimal at best.  The WIFI on the RC is still active and being used for the connection to the Spark.
2017-6-21
Use props
fans1a9af154
lvl.2
Flight distance : 57287 ft
Australia
Offline

aviscomi Posted at 2017-6-21 01:55
The battery savings on the RC using the USB/OTG cable would be extremely minimal at best.  The WIFI on the RC is still active and being used for the connection to the Spark.

Ok thanks.
2017-6-21
Use props
mr_martin
lvl.1
Finland
Offline

The switching off of other antennas (airplane mode) to get improved wifi connection range with drone sound as if the other antennas 'steal' energy...
2017-6-21
Use props
miroki
lvl.2
Flight distance : 4432 ft
United States
Offline

Turn off Bluetooth on ur phone
2017-6-21
Use props
Bradders
Second Officer
Flight distance : 862283 ft
United Kingdom
Offline

I was a little disappointed about the range also, it maybe worth getting a set of these ? http://amzn.to/2ttglBe
2017-6-21
Use props
ronny4
lvl.1
Flight distance : 1457133 ft
Switzerland
Offline

Bradders Posted at 2017-6-21 06:21
I was a little disappointed about the range also, it maybe worth getting a set of these ? http://amzn.to/2ttglBe

I have them on the Mavic, huge difference,
For spark I do not get the RC connection to pair will try again tomorrow...
2017-6-21
Use props
Tviscomi
Captain
Flight distance : 106699 ft
  • >>>
United States
Offline

ronny4 Posted at 2017-6-21 13:50
I have them on the Mavic, huge difference,
For spark I do not get the RC connection to pair will try again tomorrow...

Huge difference?
2017-6-21
Use props
Visualkaos
Second Officer
Flight distance : 755988 ft
  • >>>
United States
Offline


I tried those on the phantom before and I couldn't tell a difference.  Some swear by them however I had no luck with them.  
2017-6-21
Use props
MAVICDLNM
Second Officer
Flight distance : 8298442 ft
  • >>>
Hong Kong
Offline


I had exactly the same pair and perform even worse on my Mavic.  But the similar wind surfers work good on my P4 and P3P.  It probably the occusync work differently.  But I guess it might slightly improve Spark RC hopefully by 10-15% max.
2017-6-21
Use props
ronny4
lvl.1
Flight distance : 1457133 ft
Switzerland
Offline


Stronger much stable connection
2017-6-22
Use props
fans622a41dc
lvl.2
United States
Offline

I have the same problem. Video and controller cut out after about 50 m, line of sight and no obstacles.
Nothing seems to help.
2017-6-26
Use props
rickysuperdog
First Officer
Flight distance : 929429 ft
Hong Kong
Offline

Even Bebop2 with SK2 has much more stable Wifi connection than Spark.  I think DJI should do something in next firmware update, otherwise all disappointed user will ban this product.
2017-6-26
Use props
Dragonfly47
lvl.2
Flight distance : 9465 ft
United States
Offline

2017-6-27
Use props
Deven
lvl.1
United States
Offline

Hummingbird.UAV Posted at 2017-6-19 20:41
I have tried a micro USB / apple cable.  It worked very nicely .  Image on the mini iPad was much cleaner than when I used the wifi connection.  Had to plug the cable in after everything was powered up to get it to connect.

I have tired what you tried but on my iPhone out it said accessory not supported would you mind link the cable that you got.
2017-6-29
Use props
Deven
lvl.1
United States
Offline

Hummingbird.UAV Posted at 2017-6-19 20:41
I have tried a micro USB / apple cable.  It worked very nicely .  Image on the mini iPad was much cleaner than when I used the wifi connection.  Had to plug the cable in after everything was powered up to get it to connect.

I have tired what you tried but on my iPhone out it said accessory not supported would you mind link the cable that you got.
2017-6-29
Use props
Deven
lvl.1
United States
Offline

Hummingbird.UAV Posted at 2017-6-19 20:41
I have tried a micro USB / apple cable.  It worked very nicely .  Image on the mini iPad was much cleaner than when I used the wifi connection.  Had to plug the cable in after everything was powered up to get it to connect.

I have tired what you tried but on my iPhone out it said accessory not supported would you mind link the cable that you got.
2017-6-29
Use props
Tviscomi
Captain
Flight distance : 106699 ft
  • >>>
United States
Offline

Deven Posted at 2017-6-29 22:47
I have tired what you tried but on my iPhone out it said accessory not supported would you mind link the cable that you got.

Even though you get the message "accessory not supported" the cable should still function.  I get the same message, that's Apple's way of saying "use our $20 cable instead of a $5 cable".  Here's what I use.
https://www.amazon.com/gp/produc ... 3_s00?ie=UTF8&psc=1
2017-6-30
Use props
Brad Kim
New
Flight distance : 6325 ft
South Korea
Offline

fans622a41dc Posted at 2017-6-26 20:48
I have the same problem. Video and controller cut out after about 50 m, line of sight and no obstacles.
Nothing seems to help.

Have you tried airplane mode?

I had the same issue of video connection with RC.
I tried airplane mode and wifi on, video connection has been fine.
and then I tried airplane mode off, video signal has been cut off.

I will try to  connect with micro USB tomorrow to see if it is better connection,
I'll post the result.

enjoy flying!
2017-7-3
Use props
Toutia
lvl.1
Netherlands
Offline

Try to remove your micro SD.
this resolved a similar linking problem for me
I had a new Samsung evo 64 card installed when removed all problems vanished completely. Afterwards tried installing an old Samsung 64 pro no problems at all.
Back to the evo back in disorder.
So even when your not using your camera an sd card can break your linking
Thanks to Herman from dronekenner.nl who kept me going with quote "3 pieces of high tech communicating whit each other just a minor blink can obstruct the process"
Hope this works for you all....
2017-7-14
Use props
premium
lvl.1
Flight distance : 2300 ft
Indonesia
Offline

Scott7161 Posted at 2017-6-18 22:19
You're gunna need to turn the phone into airplane mode and then open the wifi and connect to the phone or tablet only.  Either that or use an old Phantom 4 connector and plug your Spark remote into the RC.  I was getting only about 200 meters until I switched on airplane mode on my phone.  It made a big difference.  Good luck.  PS:  I haven't actually tried connecting my phone to the remote via USB but I saw a guy do it in a youtube video and he got great results.

I'll try your suggestion soon. let's see
2017-8-20
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules