Please select Into the mobile phone version | Continue to access the computer ver.
Mavic automatically climbs and will not descend
2285 27 2017-6-24
Uploading and Loding Picture ...(0/1)
o(^-^)o
fans6af17e06
lvl.1
United States
Offline

I've been very happy with my Mavic, but lately it has begun climbing autonomously and will only descend some of the time.  Thankfully, eventually it has always responded to controller commands and has landed prior to battery exhaustion.
I have tried switching into sport mode to disable sensors but this does not seem to help.

I have also tried resetting via Assistant 2 and calibrating the IMU and compass but the error persists.

Suggestions?

2017-6-24
Use props
Jenee 2
Captain
Flight distance : 7852129 ft
Australia
Offline

Are you seeing any warnings while flying?
2017-6-24
Use props
DroneFlying
Captain
Flight distance : 10774613 ft
United States
Offline

Suggestions?

Retrieve the DAT file from a flight where it did that using these instructions, then upload the file to DropBox and post a link to it in this thread and someone will take a look to try to figure out why it's doing that.
2017-6-25
Use props
Anoniem
First Officer
Flight distance : 70043 ft
Netherlands
Offline

remote control calibration?
2017-6-25
Use props
fans6af17e06
lvl.1
United States
Offline

It's not really a warning, by usually when it starts malfunctioning the box comes up on the display that says "landing" and tap to cancel.  However I can't cancel it.

I have tried to retrieve the DAT files but for some reason they aren't visible.  It is probably just an error on my part.  I'm planning to work on that.

I tried calibrating the controller also, but no luck.
2017-7-5
Use props
fansa48b05cc
lvl.1
Flight distance : 8379 ft
United States
Offline

fans6af17e06 Posted at 2017-7-5 15:20
It's not really a warning, by usually when it starts malfunctioning the box comes up on the display that says "landing" and tap to cancel.  However I can't cancel it.

I have tried to retrieve the DAT files but for some reason they aren't visible.  It is probably just an error on my part.  I'm planning to work on that.

Same problem happened to me. I could not stop the ascent unless triggering an automatic landing. I exchanged mine, new unit does not have the same problem.
Other people have advised to disable VPS to avoid this problem, but you will be disabling a key feature of the drone
2017-7-5
Use props
fans6af17e06
lvl.1
United States
Offline

You're the first person that I've heard having the same issue, I was beginning to think I was the only one.

Did you find out what the ultimate problem was?

I've been in contact with DJI support and they request that I send it back, but I have a wedding to shoot in a week and a half and I don't think there's even a remote chance that I will get it back that soon.
2017-7-6
Use props
fans6af17e06
lvl.1
United States
Offline

Here is a link to the .dat file.

https://www.dropbox.com/s/i87v3b65rudzu9o/FLY168.DAT?dl=0
2017-7-6
Use props
Six6Sics #666
lvl.4
Flight distance : 164236 ft
Australia
Offline

I had a similar issue yesterday, auto take off, hover then begin flight, I stopped at about 6mtr height and hovered, MP seemed "shaky and unstable" which didn't seem normal.

I auto landed and reset controller and MP.

Auto take off again, hover and this time MP slowly ascended to 60+ mtrs with zero stick input, I finally pressed auto landing button and it slowly came down about 10mtrs before climbing again....

I wrestled it down 10mtrs at a time until it finally landed.....

Its never done that before.
2017-7-6
Use props
fans6af17e06
lvl.1
United States
Offline

That's exactly what mine does basically every flight.

Has anyone been able to correct this?
2017-7-6
Use props
Jelly
lvl.2
Flight distance : 827444 ft

United States
Offline

I have the same problem.  Trying to descend and it goes into auto land.  Controller says landing.  It thinks it is right above the ground even though it could be over 100ft off the ground.  I disable VPS and bring it down that way.  Started out of the blue.  I suspect it is a software issue as there are a LOT of people reporting this same thing all of a sudden.  
2017-7-6
Use props
fansa48b05cc
lvl.1
Flight distance : 8379 ft
United States
Offline

fans6af17e06 Posted at 2017-7-6 14:00
You're the first person that I've heard having the same issue, I was beginning to think I was the only one.

Did you find out what the ultimate problem was?

I don't know what the ultimate cause was, but people suggested it was faulty downward sensors used for VPS.
There is plenty of info on this happening to others on mavicpilots.com
2017-7-6
Use props
Six6Sics #666
lvl.4
Flight distance : 164236 ft
Australia
Offline

got a link fansa48b05cc  ??
2017-7-6
Use props
Sticks
lvl.3

United States
Offline

What firm ware is everyone running that has this issue?
2017-7-6
Use props
Six6Sics #666
lvl.4
Flight distance : 164236 ft
Australia
Offline

.900 for me
2017-7-6
Use props
fans6af17e06
lvl.1
United States
Offline

I don't know numbers, but I'm running the most current firmware.  The error occurred with at least the previous version as well, if not the last two.
2017-7-6
Use props
fans6af17e06
lvl.1
United States
Offline

Has anyone been able to confirm that it is in fact the downward vision sensors?  I tried one flight today with them disabled and the error didn't occur.  I'm hesitant to say that was the problem after only one flight though.

Are any DJI reps watching this thread?  Can anything be done?
2017-7-7
Use props
DroneFlying
Captain
Flight distance : 10774613 ft
United States
Offline

fans6af17e06 Posted at 2017-7-6 14:36
Here is a link to the .dat file.

https://www.dropbox.com/s/i87v3b65rudzu9o/FLY168.DAT?dl=0

Unfortunately that isn't the correct file. It appears to have been generated from turning the Mavic on and off but doesn't include any time in flight.
2017-7-7
Use props
Jelly
lvl.2
Flight distance : 827444 ft

United States
Offline

I'm on .900 as well.  All of a sudden after .900 a lot of Mavics downward sensors have up and died if it is not software.  
2017-7-7
Use props
fans6af17e06
lvl.1
United States
Offline

Gotcha.  I'll see if I can get the correct file.  Thanks for taking a look at it.
2017-7-8
Use props
Six6Sics #666
lvl.4
Flight distance : 164236 ft
Australia
Offline

I was able to get some flight time yesterday, and after a full refresh of software/hardware, compass/IMU & app, all seems OK again....

Spent a solid 30 mins in the air with no fault or error.

Not sure what happened, hopefully it doesn't ever again.
2017-7-8
Use props
Vtcats
lvl.1
Flight distance : 190692 ft
United States
Offline

Six6Sics #666 Posted at 2017-7-8 15:48
I was able to get some flight time yesterday, and after a full refresh of software/hardware, compass/IMU & app, all seems OK again....

Spent a solid 30 mins in the air with no fault or error.

Could you elaborate?
Hooked up MP to computer and refreshed software, did same for controller, as well as recalibrate compass and IMU?
I've never had this issue until changing to 900 and haven't seen any new comments with this issue so am trying to decide if I want to:
1) disable downward vision sensors
Or 2) roll back to 800
Or 3) attempt to try your method
Or any other suggestions.
But regardless it's not too comforting to think I'm taking a big chance now trying it when it was difficult to get it back down in one piece
2017-7-10
Use props
fans16667301
lvl.1
Flight distance : 32110 ft
United States
Offline

Remote for my mavic keeps charging my samsung s7 while flying. drops battery 40-50%
2017-7-10
Use props
fans6af17e06
lvl.1
United States
Offline

I recalibrated my downward vision sensors a couple days ago.  The error has still occurred once, but after a good hour+ of flying it seems drastically reduced.
2017-7-10
Use props
Vtcats
lvl.1
Flight distance : 190692 ft
United States
Offline

Vtcats Posted at 2017-7-10 04:54
Could you elaborate?
Hooked up MP to computer and refreshed software, did same for controller, as well as recalibrate compass and IMU?
I've never had this issue until changing to 900 and haven't seen any new comments with this issue so am trying to decide if I want to:

I decided to downgrade back to 800 where I previously had no issues. I flew around using up the majority of 3 batteries and no issues on 800.
2017-7-10
Use props
fans287ae16d
New
Flight distance : 16312 ft
Israel
Offline

I downgrade back to 800 and  the error has still occurred
upgrade to 900  and  the error has still occurred
It's started after first upgrade to 900
2017-7-16
Use props
DroneFlying
Captain
Flight distance : 10774613 ft
United States
Offline

fans287ae16d Posted at 2017-7-16 11:21
I downgrade back to 800 and  the error has still occurred
upgrade to 900  and  the error has still occurred
It's started after first upgrade to 900

Some things to check are:
  • Make sure your bottom sensors don't have some sort of obstruction (e.g., dirt or debris).
  • Remove anything attached to your Mavic (tracking device, landing gear extension, etc.)
  • Try calibrating your remote control.


Instead of or in addition to those things if you upload a DAT file from a flight where this occurred someone can look at it. At least one of these cases was apparently caused by a bad VPS sensor and the Mavic had to be returned / exchanged. The instructions for retrieving a DAT file are here, and once you've retrieved it you'll need to upload it to DropBox (or something similar) and provide a link to it in this thread. The correct file will have a timestamp that corresponds to the flight where it occurred and will probably be at least tens of megabytes in size.
2017-7-16
Use props
TheGemster18
lvl.3
Flight distance : 359413 ft
United States
Offline

My spark is doing something similar, I was flying the other night around two or three hundred feet from my home point everything was perfect calibrated no eras 16 satellites in view, the Drone was fine I was at 130 ft I decided to initiate a return to home it went up to its return to home altitude of 198 ft and then remained at that altitude no matter what I did it would not return down to the ground it would not descend I even canceled the return to home and manually pulled down on the left stick in mode 2 and it still would not descend! Thankfully I was able to your to the left onto my neighbor's lawn the battery got exhausted and fell from the sky onto its back in the lawn I cleaned it up recalibrated and everything seems to be back to normal the only variable I can think of was it was dark out but if it was something to do with the bottom Vision sensor I disabled it by putting it into sport mode and it still did not descend so I am at a loss if anyone else has any information that
2018-12-14
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules