Please select Into the mobile phone version | Continue to access the computer ver.
M600 Battery Cell Error or Broken
756 1 2017-7-2
Uploading and Loding Picture ...(0/1)
o(^-^)o
QBuKFmg3hDlT
lvl.1
United States
Offline

HI
We have a Matrice 600 with 2 sets of x6 batteries. We have been flying on one set only but when we swapped to the other set we got a Battery Cell broken error, cycle charging the batteries didnt help. After some investigation we isolated the faulty battery and got it swapped out with a new unit. Unfortunately after installing it and running the drone again the problem is back and the App reports Battery Cell Broken or Battery Cell Error, there is some message about running batteries down to 5% after landing, thats not really proctical all the time.
We dont know if its the replacement battery that has failed or a different unit. Whats the fix for this and why is it happening repeatedly?
Thanks
2017-7-2
Use props
KrisUAV
lvl.4
Flight distance : 73406 ft

Japan
Offline

Hi,
I have been flying the M600 for over a year now.
Never really had any problems with my batteries, but I have heard from other users that they were having issues like yours.
Are all 6 batteries charged to the the same percentage? do any of the batteries have anything lodged into the small area where the metal brackets are?
When I received my batteries, I numbered them 1~6 with colored stickers, on all 4 sets that I have.
That way if there are any problems with them, hopefully I would know which set and what number was wrong.
2017-7-4
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules