Please select Into the mobile phone version | Continue to access the computer ver.
No yaw?
1120 17 2017-7-26
Uploading and Loding Picture ...(0/1)
o(^-^)o
paraviz02
lvl.4

United States
Offline

Hello!

I just received all of my gear back from DJI today (after not having 100% of my equipment since June 12th of 2017) and fired it up for a "welcome home" flight ...

And well ...

I have no control over yaw at all. No matter what stick configuration mode I use, I have zero control over yaw.

Has this happened to anyone else? How can I fix this?

All other flight functions are working normal, thank goodness. Aside from initially having garbled video and no view of the gimbal camera, everything aside from the yaw is now working expected. Luckily, I was able to land after taking off ...

I have calibrated and re-calibrated everything. I have reset everything to defaults. I have switched stick modes multiple times. Nothing gives me yaw.

What's the deal? I'm now almost in my second hour of troubleshooting and firmware updating. And still, can't legitimately fly.

I want to cry! (Or scream. Lol.)
2017-7-26
Use props
paraviz02
lvl.4

United States
Offline

An addition to this ...

First, when we received the Inspire 2 along with one of the remotes we sent with it to DJI, the remote was not synchronized with our Inspire 2 upon return. That was a bit odd.

Second, we tried another one of our remotes and that had the exact same result. We have zero control of yaw on our aircraft.

I really don't understand how that can even be physically possible. I can control the aircraft in every other direction, so what I'm thinking is that the problem couldn't be anything else except for software-related. What did you do to my aircraft, DJI?

;-(
2017-7-26
Use props
paraviz02
lvl.4

United States
Offline

Not sure if I mentioned this, but I have updated firmware with everything. Still no yaw.

How does his happen coming back from DJI? I even sent my paired remote, that wasn't paired upon return.

And now I can't control my aircraft.
2017-7-26
Use props
paraviz02
lvl.4

United States
Offline

Now that I'm thinking about it -- how did this get by the QA at DJI's repair facility in Cerritos?
2017-7-26
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

This issue may be caused by setting a higher value for Gimbal Yaw Smoothness in Follow Mode under Advanced Settings.
Please decrease the value and check whether the issue persists, or tap ''Reset Settings'' to solve the issue.
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

Ok I will give that a try.

Mindy, is there a way to completely reset all settings (for both Inspire 2 as well as X4S and remote) to factory defaults?

I noticed when receiving the Inspire 2 back, the DJI GO 4 app acted as if I had never registered it prior to yesterday. Is that normal when receiving a unit back from repair?

On the bright side, all gimbal and camera function works great. I just can't fly now. :-)
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

Actually let me ask - regarding the setting you asked me to decrease. Is that for the gimbal yaw or for the actual yaw movement of the aircraft? Because it is the actual aircraft itself that I cannot turn left or right. The gimbal yaw works fine.

Anyway I will try both suggestions. Thanks!
2017-7-27
Use props
ronin rs211
Second Officer
  • >>>
United States
Offline

paraviz02 Posted at 2017-7-27 05:26
Actually let me ask - regarding the setting you asked me to decrease. Is that for the gimbal yaw or for the actual yaw movement of the aircraft? Because it is the actual aircraft itself that I cannot turn left or right. The gimbal yaw works fine.

Anyway I will try both suggestions. Thanks!

It is the "camera gimbal yaw" that needs to be set lower...
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

ronin rs211 Posted at 2017-7-27 05:56
It is the "camera gimbal yaw" that needs to be set lower...

Thanks Ronin - going to try this here in a bit.

Just did a test flight without gimbal camera, and the Inspire 2 flew perfectly.  Put the gimbal camera on, and no more yaw left or right for the aircraft.  Very odd.

I'll check this one out too ... I need to get to work here, but as soon as I get a break, I'm going to give it a go.

Thanks for the advice!
2017-7-27
Use props
allanart
First Officer
Flight distance : 1050577 ft
  • >>>
United Kingdom
Offline

paraviz02 Posted at 2017-7-27 07:47
Thanks Ronin - going to try this here in a bit.

Just did a test flight without gimbal camera, and the Inspire 2 flew perfectly.  Put the gimbal camera on, and no more yaw left or right for the aircraft.  Very odd.

If Gimbal Yaw Smoothness is set too high the aircraft wont yaw. Set Gimbal Yaw Smoothness to something like 35 (or Reset all gimbal settings).
Regards
Allan
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

An update to this ...

"Gimbal Yaw Smoothness" is set for 15 ... Available values are 0-30.  "Max Gimbal Yaw Speed" is set to 33, with available values between 1-100.  (Not sure what this is, but "Gimbal Yaw EXP" is set to 50, with available values between 0-100.)

I've tried it at different settings, and still, aircraft will not rotate left or right when the gimbal camera is attached.  Tried "Reset Settings" to no avail.

Any other suggestions?  This only happens when the camera is attached.
2017-7-27
Use props
ronin rs211
Second Officer
  • >>>
United States
Offline

Set it to zero. with the camera attached
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

ronin rs211 Posted at 2017-7-27 08:57
Set it to zero. with the camera attached

Cool.  Will try this here as soon as I get a break from work.

Also, I'm guessing this would be for the Gimbal Yaw Smoothness, correct?
2017-7-27
Use props
Electro-Nick
Second Officer
Flight distance : 5989180 ft
United Kingdom
Offline

Not gimbal yaw smoothness,that's the wrong setting, you want the setting for 'gimbal yaw smoothness in follow mode' set it below 40. You'll find the aircraft works fine in atti mode, or when you set the camera to free mode, but not when in p, sport or when the camera is in follow mode. The fact the aircraft works fine without the camera says it's the ..in follow mode' setting you need to adjust.
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

Electro-Nick Posted at 2017-7-27 10:24
Not gimbal yaw smoothness,that's the wrong setting, you want the setting for 'gimbal yaw smoothness in follow mode' set it below 40. You'll find the aircraft works fine in atti mode, or when you set the camera to free mode, but not when in p, sport or when the camera is in follow mode. The fact the aircraft works fine without the camera says it's the ..in follow mode' setting you need to adjust.

I see ... Where would I find that setting in DJI GO 4?

Call me a newbie ... Which I most definitely am!

Thank you for the clarification.
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

Electro-Nick Posted at 2017-7-27 10:24
Not gimbal yaw smoothness,that's the wrong setting, you want the setting for 'gimbal yaw smoothness in follow mode' set it below 40. You'll find the aircraft works fine in atti mode, or when you set the camera to free mode, but not when in p, sport or when the camera is in follow mode. The fact the aircraft works fine without the camera says it's the ..in follow mode' setting you need to adjust.

Ohh never mind, found it.  That was definitely it ...
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

Does anyone know what these settings should be as default?  I switched it down from 100 to 25 and that seems a little more "comfortable", but it is most definitely not the same as before I had sent it in for repairs.  Really, I think it should spin a little quicker than that.  Would it be bad to go to 0?

Or better yet, does anyone know a way to get everything rest to 100% factory defaults?  There are a few "reset" options in DJI GO 4, but nothing (it seems) for a 100% complete reset for all systems and devices.

Very frustrating and confusing ... But I feel very relieved to know it was as simple as a setting!

Thanks again for all of your input!
2017-7-27
Use props
paraviz02
lvl.4

United States
Offline

Sheesh, I sure do wish there was a detailed guide to all of the settings of this beast.

I mean, most of the settings are obvious.  But some things, and how those relate to other things ... Well, I never would have thought to find that under "Sensitivity" in the aircraft's advanced settings.  I figured something like that would be either in the RC or camera settings.

Anyway, I am so happy to know this is not a hardware issue!  Just pure ignorance on my part.  ;-)
2017-7-27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules