Please select Into the mobile phone version | Continue to access the computer ver.
P4P Battery Error
470 1 2017-8-1
Uploading and Loding Picture ...(0/1)
o(^-^)o
Data Drone
lvl.1
Flight distance : 300646 ft
Australia
Offline

Hi,

I recently bought a P4P and from the start I get a battery error about 4 miniutes after take off.  While flying and viewing the go 4 app's battery menu, all battery cells show as empty and info windows show as "N/A".  However, when the drone is on and not in flight, the battery menu shows cell and voltage info.

I contacted DJI support 6 days ago and I still haven't received an answer or case from them Request # 656691.  This is upseting to me as its a expensive brand new drone and out of the box it's not working correctly and I can't even get support form DJI.


I tried the following myself and the problem still hasen't been fixed:

1) Checked batter connection in drone's battery slot.
2) Updated drone and remote to latest firmware before first flight.
3) Updated both batteries to drones new firmware (via drone).
4) Tried to downgrade firmware on drone and batteries via go 4 app and dji assistent (on computer) but there is no option to downgrade.

Can someone please help me with this?
2017-8-1
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Sorry for the unpleasant experience with our product. Do you have other batteries to test? If this issue occurs constantly, the drone and the battery will both need to be sent in for thorough evaluation to locate the problem.
We apologize for the inconvenience caused, I will contact email team to check your email.
2017-8-2
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules