Please select Into the mobile phone version | Continue to access the computer ver.
Spark C\controller 2.4GHz not working
2481 24 2017-8-6
Uploading and Loding Picture ...(0/1)
o(^-^)o
krisjanis2000
lvl.2
Flight distance : 74820 ft
Latvia
Offline

Hello. I am having a problem with Controller's frequency. I can easly connect to my Spark directly via 2.4GHz but when I am using my controller, as soon as I change WiFi to 2.4GHz my phone can't find the network anymore.
Does anybody know a solution or has the same probem?

P.S. My PC always finds the WiFi, doesn't matter if it's 2.4 or 5.8 GHz.

2017-8-6
Use props
Lian82
Second Officer
Flight distance : 796775 ft
Italy
Offline

Can not you connect RC with DJI Spark? Is this what you say?
2017-8-6
Use props
krisjanis2000
lvl.2
Flight distance : 74820 ft
Latvia
Offline

I can't find Controller's wifi on phone when i change to 2.4GHz.
2017-8-6
Use props
fans56cfd429
lvl.2
Flight distance : 69633 ft
Germany
Offline

Hello

The same here in EU Germany.
Standard Connection Spark to Phone (S7) directly is 2,4GHz after pressing Spark Button until 3 beeps. Two beeps should be enough, but we always need the "reset" with 3 beeps.
Connection from RC to Spark is standard 5,8GHz, RC Wifi can be found easily by the phone.
If I switch to  2,4GHz and choosing channel, I cannot find the RC Wifi anymore => Bug, because direct connection with 2,4GHz is working.
But you can use OTG cable now and you see the Spark is connected to RC bei 2,4GHz, so this connection switch to 2,4GHz works.
Strange behavior and buggy.

Thanks
2017-8-6
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

May I know what mobile device are you using? Please try to reset the controller's WiFi by pressing and holding the power button after powering on.
2017-8-6
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

fans56cfd429 Posted at 2017-8-6 01:40
Hello

The same here in EU Germany.

The connection between the Spark RC and the mobile device via OTG cable has not been fully tested, and I would suggest that you use it with caution.
2017-8-6
Use props
Lian82
Second Officer
Flight distance : 796775 ft
Italy
Offline

DJI Thor Posted at 2017-8-6 23:14
The connection between the Spark RC and the mobile device via OTG cable has not been fully tested, and I would suggest that you use it with caution.

Is the mode that works best. App is the same for all the latest dji drones. I think it recognizes the controller automatically. However yesterday I had this problem turned off and turned on ... Wi-Fi is back.
2017-8-6
Use props
fansdd190fdf
lvl.2
Flight distance : 339528 ft
United Kingdom
Offline

Hi i can confirm i have this exact same problem. I purchased a new transmitter from dji last week to get longer range on my spark. But all i can get is 150m of range in 5.8ghz. When i go into app and change to 2.4 select a channel any channel it says changing it restarts network green light on transmitter comes on but the ssid does not appear again on the phone to reconnect. You scan and rescan but will nto appear unless you restart transmitter. Then when it restarts its back on 5.8ghz.  please help
2017-8-22
Use props
fans640ace12
New

United States
Offline

I am having this same issue. Anyone have any ideas the issue yet?
2017-10-20
Use props
tim4flight
lvl.3
Flight distance : 539518 ft
  • >>>
United Kingdom
Offline

Yep same here. But only when using with Android (shield tablet). Changing from first WiFi 'RC-Tablet' paring (5.8GHz) to 2.4GHz I loose the visibility of the RC WiFi in the search menu. Only way to rectify in order to use 2.4GHz frequency is to pair it up with the OTG cable.

Now, on the other hand I also have iphone 6s plus in WiFi mode-RC. When changing this from 5.8GHz to 2.4GHz it does not loose visibility of the WiFi RC SSID and it successfully refreshes to use 2.4GHz after the restart required prompt. So, does this mean some sort of bug being apparent in the Android setup?     
2017-10-21
Use props
Bright Spark
First Officer
Flight distance : 22129 ft
United Kingdom
Offline

Long standing issue to do with 5.8 channels not being allowed on android.
Most ios I believe are ok.
To use android, otg is the only way at present.
Many other threads on it.
2017-10-21
Use props
tim4flight
lvl.3
Flight distance : 539518 ft
  • >>>
United Kingdom
Offline

Bright Spark Posted at 2017-10-21 12:11
Long standing issue to do with 5.8 channels not being allowed on android.
Most ios I believe are ok.
To use android, otg is the only way at present.

I wasn't aware this was a major issue! It's a shame this has not been fixed already. The irony is that DJI only supports WiFi and not the OTG route. Yet, the latter option is the only way for Android to connect to 2.4GHz?!!
2017-10-21
Use props
Bright Spark
First Officer
Flight distance : 22129 ft
United Kingdom
Offline

I believe that is so.
2017-10-21
Use props
tim4flight
lvl.3
Flight distance : 539518 ft
  • >>>
United Kingdom
Offline

tim4flight Posted at 2017-10-21 11:57
Yep same here. But only when using with Android (shield tablet). Changing from first WiFi 'RC-Tablet' paring (5.8GHz) to 2.4GHz I loose the visibility of the RC WiFi in the search menu. Only way to rectify in order to use 2.4GHz frequency is to pair it up with the OTG cable.

Now, on the other hand I also have iphone 6s plus in WiFi mode-RC. When changing this from 5.8GHz to 2.4GHz it does not loose visibility of the WiFi RC SSID and it successfully refreshes to use 2.4GHz after the restart required prompt. So, does this mean some sort of bug being apparent in the Android setup?

I've done more reading on the forum relating to this issue today and I believe the root-cause of certain Android devices not being able to select  (or refresh to) 2.4GHz after channel switching from 5.8GHz is all down to what is know as Dynamic Frequency Selection (DFS) in the 5GHz band. See link here (brilliant section put together by Daveio) :https://forum.dji.com/thread-100550-1-1.html

Synopsis: When you first do a WiFi connection with the device in question to RC, the default frequency is 2.4GHz. The other free (available) frequency is the 5.8GHz which the controller links with the aircraft. Both RC and Spark have the capability to broadcast DFS to one another.

In summary, when you toggle from 5GHZ to 2.4 GHZ on the DJI Go app and hit refresh, what effectively happens is that the controller has disconnected the 5.8GHz and  switched to the 2.4GHz band to communicate to the aircraft. The other free frequency band (5.8GHz) is now made available by the  RC to be used with the mobile device. The problem now is that it is broadcasting in the 5GHz DFS frequency range  which most Android devices cannot scan. Hence this is why it disappears from your SSID broadcast list.  Only way now to connect mobile to your RC is with the OTG cable.

I made a reference that my iphone was unaffected when I implemented this frequency switch. The reason being is that iphone - in particular the 6s has the capability of scanning in the DFS range (802.11 ac). I verified this when I lost connection to my Android shield and attempted to scan the WiFi signal on my iphone - and lo and behold it was broadcasting on the apple device.

So, if you want 2.4GHz frequency to be use with an Android device with wireless connectivity to the RC you need a device that currently supports 802.11 ac!
2017-10-22
Use props
HavLaz
lvl.1
Israel
Offline

Tim4flight, you are wrong, i own xiaomi mi note 3 witch does support
"WLAN        Wi-Fi 802.11 a/b/g/n/ac, dual-band, WiFi Direct, hotspot"

And i have this problam olso.
2018-10-16
Use props
Kamarinchev
lvl.2
Flight distance : 1175 ft

Offline


I am having this same issue. Could someone from DJI support confirm that they working on that problem ?
2019-9-4
Use props
S-e-ven
Captain
Flight distance : 5102894 ft
Offline

Kamarinchev Posted at 9-4 04:31
I am having this same issue. Could someone from DJI support confirm that they working on that problem ?

Are you using an android phone ?
Are you flying in CE areas?
Are you NOT using a OTG cable between phone and RC?

Nope, DJI can not work on this problem!

That is Android!

2019-9-4
Use props
Kamarinchev
lvl.2
Flight distance : 1175 ft

Offline

S-e-ven Posted at 9-4 05:11
Are you using an android phone ?
Are you flying in CE areas?
Are you NOT using a OTG cable between phone and RC?

1   Yes, I am using an android phone and I have a problem with 2.4GHz connection between the phone and  Spark RC Controller, I haven't a problem with 2.4Ghz if I connect the android phone directly to the Spark and no problem at all with 5.8GHz both cases.

2   Yes, I am flying in Europa - blue color " Authorization Zone " but I haven't a problem when using my iPad with Spark RC Controller on 2.4Ghz in this area, the problem is only on android devices like my Redmi Note 3 Pro and  I have the same problem with my girlfriend Samsung Galaxy S9.

3   No, I am not using OTG cable between phone and RC in these cases.
2019-9-4
Use props
Kamarinchev
lvl.2
Flight distance : 1175 ft

Offline

As soon as I change WiFi to channel 1,6 or 11 to take 2.4GHz from the Wi-Fi menu ( Custom settings ) - my phone can't find the network anymore and I have to hold the power button for 9 seconds to reset the Wi-Fi and go back on 5.8GHz.

I tried today to connect Spark RC with Android Phone via OTG cable and results are: When I change WiFi from default 5.8Ghz to 2.4GHz from the Wi-Fi menu ( Custom settings ) everything is fine with OTG cable. But when I unplugged OTG cable I lost the Spark RC network again. In my case, I can use the 2.4GHz Spark RC controller on an android device only with OTG cable.



2019-9-5
Use props
S-e-ven
Captain
Flight distance : 5102894 ft
Offline

Kamarinchev Posted at 9-5 00:14
As soon as I change WiFi to channel 1,6 or 11 to take 2.4GHz from the Wi-Fi menu ( Custom settings ) - my phone can't find the network anymore and I have to hold the power button for 9 seconds to reset the Wi-Fi and go back on 5.8GHz.

I tried today to connect Spark RC with Android Phone via OTG cable and results are: When I change WiFi from default 5.8Ghz to 2.4GHz from the Wi-Fi menu ( Custom settings ) everything is fine with OTG cable. But when I unplugged OTG cable I lost the Spark RC network again. In my case, I can use the 2.4GHz Spark RC controller on an android device only with OTG cable.

The Problem is android in CE areas!
Androids aren't using 5.8 Ghz in CE territory!
So use the OTG and be happy
2019-9-5
Use props
Nidge
First Officer

Offline

Kamarinchev Posted at 9-5 00:14
As soon as I change WiFi to channel 1,6 or 11 to take 2.4GHz from the Wi-Fi menu ( Custom settings ) - my phone can't find the network anymore and I have to hold the power button for 9 seconds to reset the Wi-Fi and go back on 5.8GHz.

I tried today to connect Spark RC with Android Phone via OTG cable and results are: When I change WiFi from default 5.8Ghz to 2.4GHz from the Wi-Fi menu ( Custom settings ) everything is fine with OTG cable. But when I unplugged OTG cable I lost the Spark RC network again. In my case, I can use the 2.4GHz Spark RC controller on an android device only with OTG cable.

In Europe the 5.8GHz WiFi allocation are channels 32 to 48 for indoor use only (5.160GHz to 5.260GHz). For indoor use using dynamic frequency and power control (DFS, TPC) the channel range is 50 to 68 (5.250GHz to 5.340GHz), and outdoor use with DFS/TPC are channels 96 to 142 (5.480GHz to 5.720GHz).

Unfortunately, even though the hardware in the Spark supports these allocations, DJI in their infinite wisdom have failed to enable them, probably because the Spark would not pass FCC certification if they were made available in the USA.

The channels DJI have allocated to the Spark are not available for WiFi in Europe but instead are intended for short range devices such as analog video transmitters.

Android devices sold in Europe have these higher channels blocked but for some strange reason they are available on iOS devices up until the iPhone X - I believe.

What DJI should have done is implement the same GPS sensing routine, the one that governs the power output, to also make available the appropriate 5GHz channels based upon geographical location. Parrot were able to do this with their Anafi.

Regards

Nidge.
2019-9-5
Use props
S-e-ven
Captain
Flight distance : 5102894 ft
Offline

Nidge Posted at 9-5 01:11
In Europe the 5.8GHz WiFi allocation are channels 32 to 48 for indoor use only (5.160GHz to 5.260GHz). For indoor use using dynamic frequency and power control (DFS, TPC) the channel range is 50 to 68 (5.250GHz to 5.340GHz), and outdoor use with DFS/TPC are channels 96 to 142 (5.480GHz to 5.720GHz).

Unfortunately, even though the hardware in the Spark supports these allocations, DJI in their infinite wisdom have failed to enable them, probably because the Spark would not pass FCC certification if they were made available in the USA.

Last time I flew my Anafi, there was still no other way, as to connect the device with a cable to the RC.
But perhaps I have not found the rc to device wifi option, yet.
The 5.8 in CE with droids is just only a problem, in case people not using a cable to the RC.

And that is, in my opinion, the only reason that droids are for about a year now officially supported for otg use with the Spark.
And iOS devices not!

I would not even think about flying without a otg cable
2019-9-5
Use props
Nidge
First Officer

Offline

S-e-ven Posted at 9-5 05:20
Last time I flew my Anafi, there was still no other way, as to connect the device with a cable to the RC.
But perhaps I have not found the rc to device wifi option, yet.
The 5.8 in CE with droids is just only a problem, in case people not using a cable to the RC.

I confused myself a little on my last post.

To correct myself:

The Anafi, while using a cable for the mobile device to controller cable, has the European 5.8GHz WiFi channels as an option for the controller to Anafi link. In the case of the Spark the only 5.8GHz channels available, for both mobile device and controller connections,  are those allocated for such use in FCC regions. I think where the ambiguity arises is that even though those higher channels are available in CE regions strictly they’re supposed to be used for simplex communications as opposed to the full duplex connection that WiFi uses. However, as is certainly the case in the UK, our regulator, OFCOM, has had its resources stretched to near breaking point that any form of tangible enforcement is near to non-existent. I speak as having firsthand experience of their ineffectiveness.

Regards

Nidge.

2019-9-5
Use props
S-e-ven
Captain
Flight distance : 5102894 ft
Offline

Aside that I think I have read somewhere, that the 5.8 Ghz Band wifi outdoor using, in Europe, is permitted:   
I am relatively sure, the Anafi is using the same band/channels.
And the usage is legal, as long there is the restricted power and a "build in" control, in case these channels are used by official "Users" (Radar, I think), and then the channel is changed fully automated to a unused channel.

Spark and anafi can do that, as long you not "order" it on one specific channel!

The thing with this confusion if legal or not comes from the fact, that these 5.8 Ghz Band is called "using for  for short range devices"

Just this is not a "no distance" between sender and receiver:

"A short-range device (SRD), described by ECC Recommendation 70-03, is a radio-frequency transmitter device  used in telecommunication for the transmission of information, which  has low capability of causing harmful interference to other radio equipment."

As long you not interfere with other radio equipments, it is fine

Or is anyone here thinking, that these drones would have gone through all the regulation processes, in special in Europe, if there would be anything not in the laws?



This problem is a android one!
I'd say, droid says "better save, then sorry"
iOS, however says: "oh, there is one 5G channel, so I can use it"

I suggest to every android user:
USE a Otg-cable at all times!
And let the bird and the RC decide, which is the best band/channel!

2019-9-5
Use props
S-e-ven
Captain
Flight distance : 5102894 ft
Offline

Nidge Posted at 9-5 06:07
I confused myself a little on my last post.

To correct myself:

Outsch, of course you/I can fly the Anafi without the remote.
I even did set it up, SSID and password, in one device.
But never used and forgot about it.
Appology!
2019-9-8
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules