Please select Into the mobile phone version | Continue to access the computer ver.
Setting from 5.8ghz to2.4 without OTG
3169 31 2017-8-10
Uploading and Loding Picture ...(0/1)
o(^-^)o
realstreetuk
Second Officer
Flight distance : 7966 ft
  • >>>
United Kingdom
Offline

Hi
I can not get to use 2.4ghz on my spark unless i use the OTG connection?
If i go into 2.4ghz and select a channel it disconnects and will not connect to 2.4ghz,  but if i do the same thing with OTG it works .Can anyone tell me how to do it?
Im using samsung S6 and all firmware up to date..
thanks
2017-8-10
Use props
hallmark007
Captain
Flight distance : 6342851 ft
  • >>>
Ireland
Offline

Once you select channel and it disconnects and reconnects it should be set at 2.4ghz. What device are you using.
2017-8-10
Use props
realstreetuk
Second Officer
Flight distance : 7966 ft
  • >>>
United Kingdom
Offline

hallmark007 Posted at 2017-8-10 02:56
Once you select channel and it disconnects and reconnects it should be set at 2.4ghz. What device are you using.

hi
I'm using samsung Galaxy S6
It never connects it finds other networks but not the spark , also in in uk dont know if its a bug for CE users
2017-8-10
Use props
hallmark007
Captain
Flight distance : 6342851 ft
  • >>>
Ireland
Offline

realstreetuk Posted at 2017-8-10 03:33
hi
I'm using samsung Galaxy S6
It never connects it finds other networks but not the spark , also in in uk dont know if its a bug for CE users

I'm using iPhone 7 no problems switching, I'm under CE also, but it's a real pain this is set this way, I find 5.8ghz not very good and it's a real pain continually having to change.

Can you try another device just to eliminate if it's your galaxy S6.
2017-8-10
Use props
realstreetuk
Second Officer
Flight distance : 7966 ft
  • >>>
United Kingdom
Offline

hallmark007 Posted at 2017-8-10 03:49
I'm using iPhone 7 no problems switching, I'm under CE also, but it's a real pain this is set this way, I find 5.8ghz not very good and it's a real pain continually having to change.

Can you try another device just to eliminate if it's your galaxy S6.

Hi
I have tried my nexus 7 and motorola and still the same...
I found if i connect up without OTG and then select 2.4 then a channel then press ok and them connect the cable it will go into 2.4 but have to keep the cable connected but if i disconnect the OTG cable i lose video connection as the wifi dont reconnect but i still have connection to spark as the gimbal moves up and down. so basically the cable just makes me have video connection.
so if DJI ever get rid of the OTG in a firmware update then im stuck with 5.8ghz
2017-8-10
Use props
Spyder
lvl.1
United Kingdom
Offline

Fresh out of the box today Spark, CE mode and also cannot force 2.4g wifi, will try and sort it if not its going back, first DJI product and maybe the last if this is how they arrive with users.
2017-8-10
Use props
Azael
New
Flight distance : 135971 ft
Poland
Offline

I have the same issue with my Spark and Huawei P9. Cannot change to 2.4g wifi because my phone doesn't find the network Works only with OTG and wifi turned off.
2017-8-10
Use props
S-e-ven
Captain
Flight distance : 5831237 ft
Thailand
Offline

To all with problems to find the RC, after changing the Spark to 2.4 Ghz:
Check with a 5 Ghz wifi router, if your phones can see the chanels, the RC is using : 159, 161, 163, 165

Because in case, your phone can't connect to this 4 Channels, you can only connect to the RC on 2.4Ghz
Afaik the RC is using one of its Wifis for the Drone, the other for the phone

2017-8-10
Use props
Spyder
lvl.1
United Kingdom
Offline

I was setting up in my garden - I run both 2.4 and 5.8 networks at home, after selecting 2.4g in the app it says restarting but the phone connects to my home wifi as it can no longer "see" the RC remote - it just dissapears off the face of the earth, all other networks on both bands remain visable.
2017-8-10
Use props
amd
lvl.2
Flight distance : 231335 ft
Republic of Lithuania
Offline

Dont know why, but when i used LG G2 had same problem, now with sony z5 all ok.
2017-8-10
Use props
fans56cfd429
lvl.2
Flight distance : 69633 ft
Germany
Offline

Hello

My current knowledge:
If the RC to Spark connection is set to 5,8, the connection RC to phone is 2,4.
If the RC to Spark is switched to 2,4, the connection RC to phone should be 5,8.
The 5,8 channels used are not allowed in CE regions because of regulations, which Android respects, Apple does not.
That would explain all the behavior.

2017-8-10
Use props
SuperCurro
lvl.3
Flight distance : 625863 ft
Spain
Offline

Please read this thread http://forum.dji.com/forum.php?m ... 47&page=1#pid907095
It seams only apple works well in EU but android no, and also it seams DJI is not going to resolve it, I hope they do something about it.
2017-8-10
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

Could you use 2.4GHz frequency when the device directly connects to the drone (without RC)? Had you tried to reset the controller's WiFi, please try to reset first then change the operating frequency.
You can reset the RC by this way: power on the RC, hold the power button for 9 seconds until you heard the "DDD" sound. Then power on the aircraft, search the WiFi which named "spark-rc-xxxxx", and input the factory password 12341234.
Keep us updated if you can not use the 2.4GHz. Besides, a short video about the changing steps will be highly appreciated.
2017-8-10
Use props
realstreetuk
Second Officer
Flight distance : 7966 ft
  • >>>
United Kingdom
Offline

DJI Thor Posted at 2017-8-10 22:41
Could you use 2.4GHz frequency when the device directly connects to the drone (without RC)? Had you tried to reset the controller's WiFi, please try to reset first then change the operating frequency.
You can reset the RC by this way: power on the RC, hold the power button for 9 seconds until you heard the "DDD" sound. Then power on the aircraft, search the WiFi which named "spark-rc-xxxxx", and input the factory password 12341234.
Keep us updated if you can not use the 2.4GHz. Besides, a short video about the changing steps will be highly appreciated.

I have done what you have asked and still cannot use 2.4Ghz ( i think im operating the spark and RC on 2.4 but no video feed to see where im going)
It connects for a second then disconnects and does not find the spark unless i switch off the spark and RC
and then im back to 5.ghz, so this means if OTG gets removed in a firmware update i can never use 2.4ghz as using the OTG is the only way i can get video feed.
How can get 2.4 video feed as well as rc/ac 2.4?
2017-8-11
Use props
realstreetuk
Second Officer
Flight distance : 7966 ft
  • >>>
United Kingdom
Offline

DJI Thor Posted at 2017-8-10 22:41
Could you use 2.4GHz frequency when the device directly connects to the drone (without RC)? Had you tried to reset the controller's WiFi, please try to reset first then change the operating frequency.
You can reset the RC by this way: power on the RC, hold the power button for 9 seconds until you heard the "DDD" sound. Then power on the aircraft, search the WiFi which named "spark-rc-xxxxx", and input the factory password 12341234.
Keep us updated if you can not use the 2.4GHz. Besides, a short video about the changing steps will be highly appreciated.

Also yes i can get 2.4GHz with just just my device and spark but have to re bind my rc again when i want to use Rc
2017-8-11
Use props
Seidls
lvl.2
Flight distance : 138196 ft
Germany
Offline


Here the same in Germany,  with my android I can't connect after change to 2.4 ghz with apple ios it's possible. I thought that is a well known issue, so many people in several posts talking about that.

DJI please tell us, is it possible to change that with an update in the near future?!

Thank you...
2017-8-12
Use props
Kyokushin
Captain
Flight distance : 296378 ft
Poland
Offline

You may also use WiFiX Manager (require phone root), then change region of phone to US, and then you will be able to use 2.4 without OTG.
If you are using 2.4 for RC-AC connection, then RC-Phone is on 5.8Ghz. Android is blocking some channels in EU on 5.8 Ghz, and after switching it to US these channels are operational.
2017-8-12
Use props
Lian82
Second Officer
Flight distance : 796775 ft
Italy
Offline

yes IOS(in EU) work 2.4ghz mode without OTG.

android?i don't know
2017-8-12
Use props
HomePoint
First Officer
Flight distance : 620177 ft
  • >>>
United Kingdom
Offline

Exactly the same issue for me using my Nvidia Shield or my OnePlus3 (not supported I know, so it doesn't need saying, but doesn't mean it shouldn't be able to connect at 2.4ghz).
2017-8-18
Use props
alan1206
lvl.2
Flight distance : 119934 ft
  • >>>
Hong Kong
Offline

HomePoint Posted at 2017-8-18 13:22
Exactly the same issue for me using my Nvidia Shield or my OnePlus3 (not supported I know, so it doesn't need saying, but doesn't mean it shouldn't be able to connect at 2.4ghz).

This is how i got 2.4GHz.
1. turn on the RC and pair with phone
2. pair spark with RC
3. change the wifi to 2.4GHz and it works..
4. connect OTG.

after switch to 2.4GHz. the connection is more solid compare to 5.8GHz
2017-8-18
Use props
HomePoint
First Officer
Flight distance : 620177 ft
  • >>>
United Kingdom
Offline

alan1206 Posted at 2017-8-18 17:45
This is how i got 2.4GHz.
1. turn on the RC and pair with phone
2. pair spark with RC

Ahhhhh, so when in point 3 the screen goes blank, no connection, you attach the OTG and it connects, thanks for this, worked a treat!  
2017-8-19
Use props
HomePoint
First Officer
Flight distance : 620177 ft
  • >>>
United Kingdom
Offline

UPDATE: Just been out and burned two batteries on 2.4ghz, and it feels solid as a rock, a much better experience.
2017-8-19
Use props
realstreetuk
Second Officer
Flight distance : 7966 ft
  • >>>
United Kingdom
Offline

HomePoint Posted at 2017-8-19 00:36
Ahhhhh, so when in point 3 the screen goes blank, no connection, you attach the OTG and it connects, thanks for this, worked a treat!

Yes thats how i have always connected to 2.4ghz using OTG but if no OTG then cant connect to 2.4 .
This is what i want to fix, connect to 2.4 without OTG?
Its must be device problem as samsung galaxy tab a10 keeps the spark rc wifi and then can connect to 2.4 without OTG, but as with my samsung S6 and nexus 7 the spark rc wifi disappears from my wifi list as soon as i select from 5.8 to 2.4 in dji go 4 app but if i connect the otg then it connects to 2.4
2017-8-19
Use props
xtro
lvl.4
Flight distance : 403451 ft
France
Offline

see this thread : http://forum.dji.com/thread-104427-1-1.html

yes in CE we have no luck, no power and android that does not work in 5.8 , spark is not for CE
2017-8-19
Use props
realstreetuk
Second Officer
Flight distance : 7966 ft
  • >>>
United Kingdom
Offline

Kyokushin Posted at 2017-8-12 12:49
You may also use WiFiX Manager (require phone root), then change region of phone to US, and then you will be able to use 2.4 without OTG.
If you are using 2.4 for RC-AC connection, then RC-Phone is on 5.8Ghz. Android is blocking some channels in EU on 5.8 Ghz, and after switching it to US these channels are operational.

I have rooted my phone and put wifix manager on but still loses the spark rc wifi when enter 2.4ghz and channel.. it disconnects and does not see my spark rc in the wifi list?
2017-8-22
Use props
Kyokushin
Captain
Flight distance : 296378 ft
Poland
Offline

I dont know, its worked in my case. Your phone need to support 5.8 ofcourse.
2017-8-23
Use props
Johan97
Captain
Flight distance : 37201217 ft
  • >>>
Sweden
Offline

fans56cfd429 Posted at 2017-8-10 11:48
Hello

My current knowledge:

Yepp, i think you nailed it in this comment. This is exactly my conclusion to. A bit confused though why i will not get a connection with OTG when RC/Spark is set to 2,4ghz...hmm ay ideas ?
2017-9-15
Use props
Jojo10
lvl.2
Flight distance : 69633 ft
Germany
Offline

Hallo

I do get OTG connection with RC after switching to 2,4, no problem.

2017-9-15
Use props
Johan97
Captain
Flight distance : 37201217 ft
  • >>>
Sweden
Offline

Jojo10 Posted at 2017-9-15 06:45
Hallo

I do get OTG connection with RC after switching to 2,4, no problem.

With Android ?
2017-9-15
Use props
Lian82
Second Officer
Flight distance : 796775 ft
Italy
Offline

if you have an android smartphone, the only way to use 2.4ghz is via OTG.

on iOS also works 2.4ghz wifi.

this is because Android respects some rules .. (europe ??)
2017-9-15
Use props
Sinus
lvl.3
Flight distance : 201270 ft
Germany
Offline

I use a Sony Xperia Z5 and 2,4 ghz. This phone works with 2,4 ghz using wifi and using OTG kable. I never had a Problem using 2,4. But i also have a Tablet (Telekom). If i try to change the Mode to 2.4 using the Tablet, the Tablet did not connect to the Spark. So i don't think its a Android problem, its a problem of the Hardware.
Sinus
2017-9-15
Use props
Jojo10
lvl.2
Flight distance : 69633 ft
Germany
Offline

Yes, Android. Galaxy S7.
2017-9-15
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules