Please select Into the mobile phone version | Continue to access the computer ver.
Beta Testing
802 5 2015-4-3
Uploading and Loding Picture ...(0/1)
o(^-^)o
GeneralToner
Second Officer

United States
Offline

This topic hasn't been posted for a few days and unfortunately we all signed NDAs so we cannot communicate what DJI did or didn't do to the firmware/apps for android/apple.

With the weekend coming there is a group of us that would like to solicit situations for testing from the forums members that either did not join the beta or were unable to risk their Inspire 1.

I'm not going to be longwinded here, just looking for some ideas so that all beta members that are going with this approach can consistently test the same topics/situations in the various locations we all live.  This group has agreed that we are not as interested in the individual 'Bug Rewards' that were listed on the initial posting for beta members, we are going for making the Inspire 1 the best it can be (nice that DJI has allowed the beta).

Some topic areas we have come up with are:
Return To Home
App functionality both android and apple
Gimbal twitch/horizon
Auto takeoff/land
Battery life
Stability - hover with wind, in-flight, etc
GPS/Compass - Extensive review of the dropping GPS mode to ATTI due to compass

The above is very vague as we want people to think and provide all ideas.  We plan to get out over the next few days and test hard so the sooner we get ideas the better.

Thanks all.
James
2015-4-3
Use props
Wildcat Willie
lvl.4

Canada
Offline

I would like to see if there is some cooberation....Under .16 I had no problems with the GPS dropping out to Atti mode...With .17 Every flight would drop out of GPS mode into Atti mode...Sometimes momentarily and sometimes for up to 30 seconds....All flight with version 16 and 17 was with TB47 batteries...When I finally got my TB48s for the first time on three separate flights my bird did not drop out of GPS mode...No problems whatsoever. However, when I used the TB47 again it dropped out....Its to soon to draw any conclusions as it could be coincidence...However, it is worth noting....Is anybody else seeing this... There is nothing wrong with the TB47 as it charges fine and when you check it in the App all cells are good...
2015-4-3
Use props
genettico
lvl.4

United States
Offline

thank you for this. I would suggest to test GPS signal of RC under different environments and under airplane mode, wifi, 3glte to determine what is the best mode to fly with. I have reported and seeing issues of accuracy regarding the RC signal and it's accuracy as it shows on the app while flying and how it gets recorded on the flight record data (two different results)
2015-4-3
Use props
Editart
lvl.3

Sweden
Offline

Well, how about evaluating the main thing it was designed for? Creating video and photo. That should probably be right up there among the first five topics. I know that the gimball is upgradeable, but there is certainly room for improvements.

Compression
Image quality
Sharpness settings
Bitrate
Etc

All the best
M
2015-4-3
Use props
PureSQNut
Second Officer

United States
Offline

James,

For me return to home has always been a smooth operation. Never had any issues. Here is a list of the main concerns that I have experienced in flight while using the Android application-

   1) "Motors Starting" displaying on app while in flight - I have had several occurrences when flying (not necessarily in line of sight, based on distance) where the display will all of a sudden display "motors starting" however it is obvious that I still have full control of my I1 based on active telemetry.

    2) Keys to continuously reproduce this (in my case) fly in either unobstructed LOS flight or partially obstructed LOS (Tree's) and head out past 1000ft from the transmitter. Happens religiously for me and have tried with different tablets and different TX units on 2 separate I1's.

    3) Application stops working- Application frequently stops working and has to be restarted. In most cases its just an annoyance and I restart the app and everything is back the way it was however sometimes when it fires up the HP has changed to the current position of the I1 and elevation has also changed. So if I was at 150ft altitude from original point of launch and original HP it will now display 0ft for altitude and try to lower the landing gear.

    4) Gimbal Twitch when flying on slow but broad slow wide passes on an object. This is while in free mode but not attempting to change position of the gimbal. I typically see this during these broad and slow multi axis and position flight paths where im trying to focus on an object and changing rotation, flight path and altitude simultaneously. (doesn't always happen but this seems to be the occasion when it happens the most)

    5) First take off I1 flight wandering - After compass calibration and confirmed IMU settings within parameter the L1 simply with increasing altitude to 3' - 4' the I1 will wander in a small to large square box pattern. This can happen even after multiple compass calibrations. The interesting thing is if you choose to fly the I1 even after it does this it does not appear to affect the flight (in an open area) and if you return manually to your home position and try to hover the I1 no longer exhibits this issue. The concern is that randomly that box pattern can be as small as 6" and as large as 20'.

     6) GPS drop - on warmer days "above 85F" (we have had a few here in central Cali over the past month) I have experience rapid repeating GPS drop while in flight but only lasts for a second of two and never long enough to change to to Atti mode however in both cases it was while doing low level flying (under 5') and when it happens the I1 wants to loose elevation and drop to the ground and is only saved by going full throttle on the TX to increase elevation. No crashes yet due to this as I have saved it every time. I have not had this occurrence at lower temperatures, possibly coincidental, who knows.

    7) Stability in wind - Overall it has been pretty good however a few weekends ago I was covering my sons Baseball leagues opening ceremonies, we had cross winds of about 5-7mph and and it held its position geographically while in hover no problem but I found myself frequently having to correct the rotational direction of the I1 as it constantly was rotating counter clockwise (with the wind). This happened also three weeks ago at the lake with 7mph - 9mph crosswinds.

    8) Histogram on Android. I have done some existing testing in a photo lab (controlled environment and lighting) and the histogram does not accurately and actively display the change of lighting conditions or effects of shutter speed accurately. Sometimes the adjustments are not displayed on the App histogram until multiple steps have been made, however you can take multiple samples of video or still images and the smaller changes are documented correctly in the recorded images on the SD Card.

    9) The android app as a whole has a lot of bugs in it compared to the IOS app. I borrowed my sons Ipad Mini and went back to several of the locations under as close to the conditions as the original flights (temperature, time of day, flight style, foal point of footage) and found none of the histogram, motor starting, app shut down, change of home point in flight etc.

    10) Offset horizon. I have had this happen a few times but have all been related to turning the I1 on while on surface that is not 100% flat. My fix has been simply, simply turn it off, find a better spot to take off from and restart it and let the gimbal recalibrate. My thought on this is that if the compass has ben calibrated and the onboard Gyro is functioning correctly shouldn't the I1 know its not on a perfectly flat surface and compensate for that? Not a biggie, just land, power cycle and its fixed. Just a small annoyance.

    I need to find the rest of my notes I have been keeping of my flights to get the other quirks and notes I made to reproduce them in further flights. I may still have some flight logs as well but have deleted most of them as it seemed irrelevant as my documentation and testing was for my own personal interest and OCD as that's all I do most days is test software and firmware for products we manufacture.

    Let everybody in the group know I say thank you. Although I  dont have the oppurtunity to partake and help I appreciate the effort you guys are putting in for the better good. Happy to hear that others hold the same thought of "its not about the money, its about making it right" as I have.

    Thanks again
2015-4-3
Use props
PureSQNut
Second Officer

United States
Offline

Did some flying tonight after getting it back from service, calibration of both IMU and compass and still have a noticeable issue of it steering in a counter clockwise direction under heavy acceleration forward. It does it with or without a increase or decrease in elevation or while trying to retain a stable elevation flight path.  Checked the other bird I have access to and it too experienced the same results under the same test conditions and flight path attempts.
2015-4-3
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules