Please select Into the mobile phone version | Continue to access the computer ver.
Phantom acting totally weird..
2058 15 2015-4-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
occhiblughiacci
lvl.4

Indonesia
Offline

well, here we are again... after two month not flying, yesterday i took out my P2 v.2 again.
first discharged all batts and recharged them, checked updates, all ok.
started the P2 and as i got green light i started, but warned from the last events, kept him in hoovering just 2 meter over ground.
lucky i did. 2 minutes in air, the copter started blinking all 4 lights in red and shot down like crazy and smashed on the ground.
you can imagine my mood...
ok, changed battery, cleaned all contacts etc. just in case he read something wrong and repowered him on.
seemed all ok, start etc. 3 minutes hoovering, red lights and boom down on ground again.
did one of you ever have such an experience and what should i do???
as for me, sitting in wheelchair, the P2 is like legs, plese serious help is needed.

thank you
2015-4-9
Use props
Northofthe49th
Captain

Canada
Offline

Occhi,
Sorry to hear about the problems,
Assuming you are powering up the RC first, Wifi Extender second and Phantom third!
Can you describe the "green light" on the Phantom, there should be a whole bunch of greens confirming satellite lock (enough satellites safe to fly)and it is not until then that is even remotely safe!.....Then after Sat lock, Did you do the Compass dance/calibration?
What mode are you flying in..Phantom or NAZA-M?
A little more info and we may be able to help....
Are both S1 and S2 in the up position?

Also, Red light flashing mean low battery or critical low battery! Any way you can confirm the batteries are good through the Phantom Vision Assistant...
2015-4-9
Use props
occhiblughiacci
lvl.4

Indonesia
Offline

hi nht49th,

thx for reply...

1) power up PC first, second P2, coz no WIFI extender..
2) compass calibrated and gps full locked after green lights quick flashing and back to stable green slow flash
3) flying in Phantom mode
4) batteries 09 % checked with Assistant 27 cycles and health 98 %
5) latest upgrade done and flying with Futaba T8 where calibration done and everything ok.
6) red flashing only after 2 minutes hoovering in perfect and 100 % GPS lock
2015-4-9
Use props
Northofthe49th
Captain

Canada
Offline

Well, red flashing as far as I can tell is due to a low battery warning and I am not familiar with the Futaba controller,
Any chance you have the original Phantom remote to try just to rule the Futaba out as a possible cause.
2015-4-9
Use props
occhiblughiacci
lvl.4

Indonesia
Offline

but battery is full..
and we tried with the original remote.. same story..
2015-4-9
Use props
Swerve
lvl.4

United Kingdom
Offline

occhiblughiacci Posted at 2015-4-10 15:34
but battery is full..
and we tried with the original remote.. same story..

In your post above at item 4) you give battery as 09%. Did you mean 90%?

If it is only 09% then it is very low and maybe the cause of your crashes.
2015-4-10
Use props
Northofthe49th
Captain

Canada
Offline

Have you had any kind of crash/hard landing, only thing I can think of is as soon as it gets warm/moving/vibrating something is losing a connection inside or there is something shorting, it is the only thing that makes sense....if you have any add-on's, you could should remove them and try again and not sure if you have ever opened it but if comfortable, it may be worth a try and have a look...

If not comfortable the only other options are to send to DJI or you could try uavdirect.com as posted by Raybro in another thread...
Good luck
2015-4-10
Use props
johnwarr
Captain
Flight distance : 6467 ft
United Kingdom
Offline

A couple of things need a bit more explanation.
"after two month not flying, yesterday i took out my P2 v.2 again.
first discharged all batts and recharged them"
So am I to assume the batteries were stored fully charged ? And how did you discharge them ?

"the copter started blinking all 4 lights in red and shot down like crazy and smashed on the ground."
Are you sure all 4 LED's were flashing ? The front 2 are normally on all the time the engines are running.
2015-4-10
Use props
Northofthe49th
Captain

Canada
Offline

John,
He did state on his first launch all went red blinking, and then tried another battery, unfortunately with his set up not sure if he has any way to see battery percentages while in the quad and it is powered up...who knows, maybe they (batteries) are dropping like a rock, maybe saying full but really empty and losing power due to battery memory problem...
If he knew someone else with a known working Phantom it would be worth trying another battery for sure...
He did say 09% and 98% health...Hope he meant 90% and 98% Healty...

OP..Please clarify!
2015-4-10
Use props
occhiblughiacci
lvl.4

Indonesia
Offline

nono guys.. it was 90 % before and the same after crash.. they where stored @ around 50 % and the assistant give me a 98 % of health..
its my third phantom and i have all this mess since the update in January, the one blocked the Phantom without be able to start, recalled by dji the day after..
all four lights where red, think the rear one blinking..
2015-4-10
Use props
Northofthe49th
Captain

Canada
Offline

Without pictures or video we can only guess if flashing or how many flashes etc...
Check your Phantom Vision screens here against these...
http://forum.dji.com/forum.php?m ... =Please&lang=en
Slow and quick Red are battery errors, Three off and on are not stationary or sensor bios too big..
Try to do another Calibration on the Phantom from the computer, make sure it is on a completely flat table, no metal table/granite or magnetic interference of any kind...
How are you calibrating the compass? It really is critical....I know you said you did it but curious!
Are you sure it is being done correctly, you mention you are in a wheel chair which is probably all metal, could that be causing interference?
Beyond that no clue other than doing a hard reset in which you have to take the cover off anyway, not sure what to suggest other than that..
2015-4-10
Use props
acenothing
Second Officer
Flight distance : 112185 ft
United States
Offline

Wow so many thing to think about.


Just my Opinion BUT
1. WiFi extend is not an issue.  P2 can fly perfectly with that off.
2. The most likely source is ESC failure or less likely motor fault.
3. Then look at the other issues.
2015-4-10
Use props
Northofthe49th
Captain

Canada
Offline

acenothing Posted at 2015-4-11 02:22
Wow so many thing to think about.

Ace, it sure could be an ESC or motor but what ever it is appears to be intermittent, it seems to start fine, take off fine but within a minute or two goes hard down hence my earlier recommendations..but if he does not want to take it apart the other items suggested are a lot easier to double/triple check and do with it plugged in vs. taking apart and the latter may not be an option for him...I still think there is something loose in his bird as how could he do all the calibrations, go through all the gyrations with all the proper lights at the start fine each time and then..wham!
OP, sorry if it seems like a goose chase but software/firmware and calibrations are fairly easy to re-check, beyond that, a hard reset is a wee bit more challenging and diagnosing components is the most difficult for sure.
You did not mention if you get any errors when connected to the Phantom Assistant, so many variables and unfortunately too much guessing at this point...
2015-4-10
Use props
occhiblughiacci
lvl.4

Indonesia
Offline

ok, we did recalibration, from the Assistant. everything ok through the whole process, all battery, imu etc. calibrated the Remote control, cleaned all connections, start, all well, gps ok, everything fine, start well, hoover 1 minute, red lite fast blinking, come down like wild horse.. battery check ok @ 97 %... grrrrrrrrrrrrr maybe change motor and ESC and see whats up.. btw its not visionits P2 v. 2.0
2015-4-10
Use props
Raybro
Second Officer
Flight distance : 11099 ft
United States
Offline

You mentioned using the firmware that DJI said not to use. Did you go back to previous or to the latest? Any airports nearby? Was an advanced IMU calibration done?
2015-4-11
Use props
occhiblughiacci
lvl.4

Indonesia
Offline

went back, no airport and did imu..
2015-4-11
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules