Please select Into the mobile phone version | Continue to access the computer ver.
Phantom 4 Gimbal Unresponsive
935 2 2017-11-16
Uploading and Loding Picture ...(0/1)
o(^-^)o
PowellSkier
lvl.3
United States
Offline

First of all, I would like to thank the DJI support team for replacing my malfunctioning controller a week after I sent in my bad one.

After a succesful test flight with my new controller I was flying my drone to make sure everything was working (and it was) until my battery got low and I landed it on my lawn in the grass. I then retreived the drone and put it away for the night. The next time I tried to fly it, the gimbal would start to go through its warm up routine but stop midway through and go limp. No gimbal motor function at all on all three axis. After switching it off I proceeded to perform the following to try and get it working again:

- Inspected ribbon cable and gimbal assembly for damage. They are in pristine condition.
- All gimbal motors rotate freely.
- Camera image transmission is normal.
- All firmware updates are current.
- Gimbal Calibration in the Go4 app resulted in the calibration dialog freezing and the calibration not finishing, even after 15 minutes. At first, it looked like the gimbal was moving a      little bit, but now the gimbal never moves, except during start-up where it stops halfway through the normal gimbal start-up motions.
     - Update: whenever I try to do a Gimbal calibration it immediately goes to a dialog box that says "Tips: Gimbal calibration is complete. Do not move the aircraft." and hangs                 there. Only after restarting the P4, the controller and the app will make this message go away.

- The Go4 app shows gimbal status as normal with no errors.
- Reset drone to default settings in Assistant 2 program. No change in gimbal function.
- Unable to downgrade firmware since that option is not available in Assistant 2.

Has anyone else encountered these problems with the Phantom 4 gimbal?
What else can I try to fix this?

2017-11-16
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

Had you tried to remove the SD card and restart the drone? Please try, and also try to refresh the firmware via DJI Assistant 2. If it doesn't help, please provide me with a video of this case, which includes the drone's reaction and the version info on the app. Thanks in advance.
2017-11-19
Use props
djiuser_z4oAnrytdS47
lvl.1
Spain
Offline

I am experiencing exactly the same problem, did you find a fix for it?

Thanks
2018-3-24
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules