Please select Into the mobile phone version | Continue to access the computer ver.
Phone WiFi Interferes with Remote Control?
1085 17 2018-1-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
Kevin_d
lvl.4
Flight distance : 4219 ft
United States
Offline

I was just wondering, do people turn off the phone's wifi when they plug into the remote control? Both operate at 2.4 GHz I think. Could one of the causes for unexplained loss of signal issues be the phone's wifi interfering with the RC?

My phone is dedicated to the Mavic and I keep it in airplane mode.
2018-1-8
Use props
Anthony566
First Officer
Flight distance : 2488944 ft
United Kingdom
Offline

I used to put my phone into flight mode so wifi was off to be on the safe side.

2018-1-8
Use props
Bekaru Tree
Captain
Flight distance : 14833015 ft
South Africa
Offline

interesting question - i suffer erractic loss of signal and have tried all dji recommended fixes (reloaded the apps more times than i care to remember, tried replacing the cable, ensured correct environmental conditions, ensure that anntennae is correctly positioned but still suffer these erratic disconnects. Certainly none of the dji recommendations are relavent to my problem and since my phone often works well for extended periods makes me think it is not my phones problem - so what is it, must be something - at least you have offered a new possibility - hope we get some knowlagable opinion on this
2018-1-8
Use props
Bekaru Tree
Captain
Flight distance : 14833015 ft
South Africa
Offline

or the RC interfering with the phones wifi (same same but different)- because for me it is my device that disconnects not my RC
2018-1-8
Use props
Woe
Captain
Flight distance : 4129268 ft
  • >>>
United States
Offline

It is recommended to put phone on airplane mode to avoid interference. Every time I’ve forgotten to turn mine off I’ve got interference. So erratic behavior or loss of drone or crash could be the result. Strongly recommended reading the manual. Other folks good luck may not be yours.
2018-1-8
Use props
cristianc
Second Officer
Flight distance : 1008143 ft
Australia
Offline

Usually you don't want to receive any calls while flying so flight mode is good unless of course you want to do a live stream.
2018-1-8
Use props
Ex Machina
Captain
Flight distance : 1753100 ft
United States
Offline

I think if you are having problems it's not unreasonable to turn off wifi, but I've never had to do so.
2018-1-8
Use props
Jos A
Captain
Netherlands
Offline

I never turn it off, I use litchi and want my google maps on spot in litchi
2018-1-9
Use props
AG0N-Gary
Captain
Flight distance : 700846 ft
United States
Offline

Like Ex-Machina, I don't go to airplane mode on either device.  I've got my phone AND my iPad up and running while flying and have no problem.  I also fly from my house often, where there is a large wired and wireless network.  No problems with interference error messages or loss of control.  Like he said, if you have a problem and want to eliminate your device's wifi, turn it off.  Otherwise, why bother.
2018-1-9
Use props
R&L Aerial
Captain
Flight distance : 298100 ft
  • >>>
United States
Offline

I ALWAYS fly in airplane mode, I also turn off all apps running in the background. I don’t like being interrupted by e-mail notifications, I’ve read about WiFi interferance issues although I’ve never experienced them. I also am on an older firmware/ app version and I don’t want to update....  
2018-1-9
Use props
CycleParadise
Captain
Flight distance : 183488 ft
United States
Offline

I've been flying with my phone in airplane mode. Since I've been doing that, the Go4 app doesn't disconnect any more.
2018-1-9
Use props
damoUK
First Officer
Flight distance : 436155 ft
United Kingdom
Offline

I use both my iPhone and iPad (cellular & wifi) to fly the Mavic, and have never turned off either the cell or wifi on either device and have not knowingly had a problem - though I have never received a call while flying the Mavic, so have no idea what would happen if that were to happen!
2018-1-9
Use props
Bekaru Tree
Captain
Flight distance : 14833015 ft
South Africa
Offline

I flew one battery today ensuring that wifi is off and enjoyed a comparatively glitch free flight. Device did not disconnect and only some little bits of aliasing - lets hope this is a sustainable solution for my setup - will post some follow ups in days to come -
2018-1-9
Use props
Hexacopter
Second Officer

Australia
Offline

CycleParadise Posted at 2018-1-9 12:58
I've been flying with my phone in airplane mode. Since I've been doing that, the Go4 app doesn't disconnect any more.

Best advice that I ever got! Lol, nothing like the ex calling you halfway through a misison

* hex *
2018-1-9
Use props
Ex Machina
Captain
Flight distance : 1753100 ft
United States
Offline

damoUK Posted at 2018-1-9 13:30
I use both my iPhone and iPad (cellular & wifi) to fly the Mavic, and have never turned off either the cell or wifi on either device and have not knowingly had a problem - though I have never received a call while flying the Mavic, so have no idea what would happen if that were to happen!

It's happened to me, I just decline the call and go on my way. Could be distracting at a critical time, though, so best to switch to Do Not Disturb mode before flying (which I always forget to do).
2018-1-10
Use props
CycleParadise
Captain
Flight distance : 183488 ft
United States
Offline

Ex Machina Posted at 2018-1-10 06:54
It's happened to me, I just decline the call and go on my way. Could be distracting at a critical time, though, so best to switch to Do Not Disturb mode before flying (which I always forget to do).

Yeah, I used to switch to Do Not Disturb mode but the darn notifications kept popping up on the screen. I know I could probably fix it so the notifications don't pop up in DND mode, but I'm too lazy for that. It's easier to just switch to airplane mode.
2018-1-10
Use props
Ex Machina
Captain
Flight distance : 1753100 ft
United States
Offline

CycleParadise Posted at 2018-1-10 12:45
Yeah, I used to switch to Do Not Disturb mode but the darn notifications kept popping up on the screen. I know I could probably fix it so the notifications don't pop up in DND mode, but I'm too lazy for that.  It's easier to just switch to airplane mode.

Yeah, ultimately airplane mode is best -- should be easy to remember given the built-in mnemonic, too, but... ¯\_(ツ)_/¯
2018-1-10
Use props
Brian88
lvl.4
Flight distance : 385942 ft
United States
Offline

Wifi signal shouldn't interfere. But I use do not disturb or airplane mode so the screen doesn't get interrupted if an incoming call happens during flight.
2018-1-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules