Please select Into the mobile phone version | Continue to access the computer ver.
Oneplus 5T with the Mavic Air - NO CONNECTION
6294 12 2018-2-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
heightoffield
lvl.4
Flight distance : 2670423 ft
  • >>>
Hungary
Offline

Hey ppl,

Please advise as I'm having a minor heart attack, because my Mavic Air controller does't want to connect to my OnePlus 5T. Latest, Android Oreo, latest Go4 app, latest FW (updated with PC and DJI Assistant). So when I plug in the USB-C RC adaptor cable, the phone vibrates, it charges too, but the GO4 app doesn't do anything. The RC and AC are connected (green light)

Please advise, as every other DJI product was compatible with my phones so far, OP2, OP5, and the OP5T with my P3P, Spark, Osmo Mobile, Osmo+, every DJI product is okay with it, so please do not tell me that my phone is not supported.

Please, help. Thanks in advance.

Best,
sz
2018-2-9
Use props
escore
First Officer
Flight distance : 527408 ft
  • >>>
Finland
Offline

Hi! I'm having Oneplus 5 & Mavic Air.
At first I couldn't connect to rc, but after I unlocked developer setting on op5 it started to work properly.

Just go to settings, tap 5-8 times at build number and it activates the developer mode on your phone.

I hope this helps!

2018-2-9
Use props
heightoffield
lvl.4
Flight distance : 2670423 ft
  • >>>
Hungary
Offline

escore Posted at 2018-2-9 05:22
Hi! I'm having Oneplus 5 & Mavic Air.
At first I couldn't connect to rc, but after I unlocked developer setting on op5 it started to work properly.

I love you! This helped. Saved my life. Thanks!
2018-2-9
Use props
escore
First Officer
Flight distance : 527408 ft
  • >>>
Finland
Offline

heightoffield Posted at 2018-2-9 05:29
I love you! This helped. Saved my life. Thanks!

Haha Good that it helped!
I had no issues with Mavic Pro's rc but somehow Mavic Air's rc needed the developer mode on
2018-2-9
Use props
heightoffield
lvl.4
Flight distance : 2670423 ft
  • >>>
Hungary
Offline

escore Posted at 2018-2-9 05:33
Haha  Good that it helped!
I had no issues with Mavic Pro's rc but somehow Mavic Air's rc needed the developer mode on

Also, what you you think, USB debugging should remain enabled?
2018-2-9
Use props
escore
First Officer
Flight distance : 527408 ft
  • >>>
Finland
Offline

Well, I did leave it that way as it worked
2018-2-9
Use props
rolling56
Captain
Flight distance : 138310 ft
United States
Offline

Please advise as I'm having a minor heart attack, because my Mavic Air controller does't want to connect to my OnePlus 5T. Latest, Android Oreo, latest Go4 app, latest FW (updated with PC and DJI Assistant)

Made me laugh and made my day lol
2018-2-9
Use props
iceman#1
lvl.4
Germany
Offline

Had the same thing here with an OPPO phone (daughter/mother of 1+)
I was short before sending back my drone. Then gave developer options and USB debugging a try. worked fine then. Unfortunately I had a hard time and had to learn the hard way.

Really hope that DJI will put that solution in the manual or at least in FAQ
2018-2-9
Use props
Latawiec
lvl.1
Poland
Offline

I have the same issue but developer mode and USB debugging did not do the trick. Can anyone help out?
2018-2-13
Use props
heightoffield
lvl.4
Flight distance : 2670423 ft
  • >>>
Hungary
Offline

Latawiec Posted at 2018-2-13 11:54
I have the same issue but developer mode and USB debugging did not do the trick. Can anyone help out?

maybe try a phone restart, OTG on, hope this helps
2018-2-13
Use props
Latawiec
lvl.1
Poland
Offline

heightoffield Posted at 2018-2-13 12:28
maybe try a phone restart, OTG on, hope this helps

It works now but i also had to do this:

On Settings menu go to "Developer options" -> "Networking" and set the USB configuration to MIDI.

The problem is that both the above and the OTG switches back off so it seems I have to go through this procedure every time.
2018-2-13
Use props
stavrosppn
lvl.1
Flight distance : 2408 ft
Greece
Offline

Latawiec Posted at 2018-2-13 13:26
It works now but i also had to do this:

On Settings menu go to "Developer options" -> "Networking" and set the USB configuration to MIDI.

This works for me also. Saved my life. Thanks!
2018-2-22
Use props
arooguru
lvl.1
Flight distance : 1850 ft
India
Offline

Latawiec Posted at 2018-2-13 13:26
It works now but i also had to do this:

On Settings menu go to "Developer options" -> "Networking" and set the USB configuration to MIDI.

This totally sorted my 5t connecting issue. You are right I have to go to the settings every time I connect the RC to my phone, then hit that ‘midi’ option and I get an auto launch prompt from dji go4 app.

Thank you... I’m happy I can connect with my fast phone now. Was compromising with an older, slower moto g4
2018-3-24
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules