Please select Into the mobile phone version | Continue to access the computer ver.
Problem with the IMU (indoor)
681 3 2018-2-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
JanPieter
lvl.2

Netherlands
Offline


   
Initial situation:
  
  
DJI Matrice 100 statically positioned in a room indoor switched on.
  
  
Problem:
  
  
Once the DJI-node is launched the quaternion in the message /DJI-SDK/imu returns:
  
x = nan; and consecutively wrong values for the other three variables in the quaternion.
  
  
This behavior does not happen always, sometimes the quaternion is correctly computed and transmitted. The correct behavior occurs without switching on-off the drone or the onboard computer, but just re-launching the node several times.
  
  
Conclusion:
  
  
The unpredictable behavior of the system does not allow us to conclude that the data captured from the Inertia Measurement Unit of the drone, in the current configuration, are always valid.

Is there someone that could help us?


2018-2-13
Use props
DJI-Mark
Moderator

United States
Offline

Did you see any warning notices in the app? Can you provide me a video on what you are seeing? You can send me a personal message.
2018-2-13
Use props
JanPieter
lvl.2

Netherlands
Offline

DJI-Mark Posted at 2018-2-13 10:56
Did you see any warning notices in the app? Can you provide me a video on what you are seeing? You can send me a personal message.

We will be testing again tomorrow. Ill make sure to get the video footage.
And I will send it to you.

Thank you for your fast reply.

Kind regards,
Jan Pieter de Rie
MainBlades Inspections

2018-2-13
Use props
DJI-Mark
Moderator

United States
Offline

JanPieter Posted at 2018-2-13 23:47
We will be testing again tomorrow. Ill make sure to get the video footage.
And I will send it to you.

Feel free to send a personal response. Let me know how it works out.
2018-2-14
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules