Please select Into the mobile phone version | Continue to access the computer ver.
GS Pro App with Mavic Pro
1310 4 2018-2-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
fansbbd9ba2c
lvl.1
Flight distance : 610105 ft
United Kingdom
Offline

Hi All. Can anyone confirm that the Mavic Pro still works with the DJI GS Pro app? - I used it successfully several times last year, but now can't get it to work. It recognises that the Mavic is connected, gets all greens on the 'prepare to fly' checks, but on pressing 'start to fly', it just takes off into a low hover and sits there. No airspace warnings etc , but it does not commence the actual waypoint flight. Pause button on the controller does nothing. Throttle position does nothing. Yaw stick still controls yaw, forward/back stick causes aircraft to climb and descend (but not go forward/back). Roll stick does nothing. Hit pause symbol on the IPad and I get normal control back. If I fly the aircraft with the Go4 app, all is normal. GS pro App version 1.8.0 Aircraft / controller version 01.04.0100. Thanks,


Malcolm
2018-2-28
Use props
fansbbd9ba2c
lvl.1
Flight distance : 610105 ft
United Kingdom
Offline

So - I have now updated the App, the aircraft and controller to the latest versions ........... and nothing changed.  Exactly the same as before.  Now updating the IOS on the Ipad just to complete the set, but not hopeful, as it worked fine before.
2018-2-28
Use props
fansbbd9ba2c
lvl.1
Flight distance : 610105 ft
United Kingdom
Offline

fansbbd9ba2c Posted at 2018-2-28 08:24
So - I have now updated the App, the aircraft and controller to the latest versions ........... and nothing changed.  Exactly the same as before.  Now updating the IOS on the Ipad just to complete the set, but not hopeful, as it worked fine before.

Totally stumped now.  Everything has been updated, including the IOS on the Ipad, but still can't get it to run a waypoint mission.   - Same as before, with all green lights on the preflight check, it just lifts off and stays in a low hover. No warnings or errors shown.  IMU and compass re-calibrated.  Still behaves fine using the Go4 app.

I would totally delete and re-load the GS Pro app, but I can't find any way of backing up my existing missions, other than getting pen and paper out to write all the details down of each waypoint
2018-2-28
Use props
The Farmer
Captain
Flight distance : 165495 ft
United States
Offline

fansbbd9ba2c Posted at 2018-2-28 10:29
Totally stumped now.  Everything has been updated, including the IOS on the Ipad, but still can't get it to run a waypoint mission.   - Same as before, with all green lights on the preflight check, it just lifts off and stays in a low hover. No warnings or errors shown.  IMU and compass re-calibrated.  Still behaves fine using the Go4 app.

I would totally delete and re-load the GS Pro app, but I can't find any way of backing up my existing missions, other than getting pen and paper out to write all the details down of each waypoint

I can confirm it is working on a MMP. I'm a new user and tried the GS Pro App for the first time today for a short test waypoint mission. Everything seemed to work OK. I'm on 2017iPad running IOS11.2.5. Just downloaded the GS Pro App last night from the Apple store... not sure where the find the installed version number. Was going to post this morning but couldn't figure out how to start a mission... have to hit "edit" first which seemed odd. Also, I made sure the DJGo4 app was closed by swiping it off the run shelf because I read somewhere where the two could interfere with each other.
2018-2-28
Use props
fansbbd9ba2c
lvl.1
Flight distance : 610105 ft
United Kingdom
Offline

The Farmer Posted at 2018-2-28 13:11
I can confirm it is working on a MMP. I'm a new user and tried the GS Pro App for the first time today for a short test waypoint mission. Everything seemed to work OK. I'm on 2017iPad running IOS11.2.5. Just downloaded the GS Pro App last night from the Apple store... not sure where the find the installed version number. Was going to post this morning but couldn't figure out how to start a mission... have to hit "edit" first which seemed odd. Also, I made sure the DJGo4 app was closed by swiping it off the run shelf because I read somewhere where the two could interfere with each other.

Thanks for the reply.  Yes it is strange that you have to go in to edit to run a mission - but it has always been like that. I just can't figure out what has changed to stop it working on my machine now, after using it OK for several flights last year.  I have to assume it is related to one of the firmware updates, but given that I have everything up to date now, I'm running out of things to try.
2018-2-28
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules