Please select Into the mobile phone version | Continue to access the computer ver.
CrystalSky problems
1746 3 2018-3-4
Uploading and Loding Picture ...(0/1)
o(^-^)o
Altitude Photos
lvl.4
United Kingdom
Offline

I have so many problems with the CrystalSky monitors, it's hard to know where to begin, but the biggest bug has to be the fact they don't work with the M600. I get zero video feed, which I've been chasing with DJI now for over 3 months with no result, in fact all I've been told is "It seems that the problem is in the DJI Go app of the Crystal Sky. And our senior engineers are working on it". Yet to date there has been no fix still.



I can get video no problem from both of my M600's with an iPad, so this is purely a bug on the monitors, one of numerous bugs I have reported. In fact I wonder why they are still selling a product that clearly doesn't work.





I have tried every step of trouble shooting that DJI have suggested over the last three months, including having one of the M600's replaced. Everything works fine with an iPad, but not their own monitors. Both monitors work on one M600, but neither work on the other, so it's not a screen issue, nor is it an aircraft issue as DJI have replaced one. This is a firmware issue on the CrystalSky, which is full of bugs and not fit for sale in my opinion.
2018-3-4
Use props
castormalin
Second Officer
Flight distance : 638911 ft
France
Offline

Hopefully, DJI will offer some conditions to the early customers for an exchange with the production version, when it will be released   ...
2018-3-4
Use props
DJI-Mark
Moderator

United States
Offline

If you are having a firmware issue, can you link the product to the Assistant 2 software, reset to factory settings and refresh the firmware? Please send me a personal message and include any steps you have tried to resolve this issue.
2018-3-6
Use props
Altitude Photos
lvl.4
United Kingdom
Offline

DJI-Mark Posted at 2018-3-6 08:30
If you are having a firmware issue, can you link the product to the Assistant 2 software, reset to factory settings and refresh the firmware? Please send me a personal message and include any steps you have tried to resolve this issue.

This has been going on for 3 months now. I've done full resets of every component, full updates of every component, I've had equipment replaced by DJI, but still no solution.

All I keep getting is replies like this latest one today:

"Our R&D department is already aware of the situation and has been actively investigating this issue already. I can’t report on the exact date the update itself will hit but they have actively confirmed to me, and I have permission to inform you about it, that they have fixed the issue.

So the next update should bring you the salvation you need in this matter, we ask a tiny bit of patience until the update hits."

Let's just say I'm not holding my breath for the fix, as I've been told it's due any day now for some time.
2018-3-6
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules