Please select Into the mobile phone version | Continue to access the computer ver.
OSMO problem with hight capacity battery HB02-542465
682 3 2018-3-10
Uploading and Loding Picture ...(0/1)
o(^-^)o
fans6a32f49a
lvl.1
United States
Offline

Put in fully charged new hight capacity battery, both lights turn solid green and look normal for a few seconds. But after about 5 seconds the right power light goes red (left light goes off). could not connect to phone. My OSMO works normal with 3 old batteries, including one hight capacity battery. But not for other 3 new hight capacity batteries. I don't think it is a problem with my OSMO since it works fine with the old batteries. Is there any firmware for battery? My OSMO firmware is v1.11.2.70, the newest version.
2018-3-10
Use props
Montfrooij
Captain
Flight distance : 1915335 ft
Netherlands
Offline

Stupid question maybe, but you did remove the plastic cover?
(I left mine on the first time, waited for hours to find out it was not charging....)
2018-3-10
Use props
fans6a32f49a
lvl.1
United States
Offline

Montfrooij Posted at 2018-3-10 13:31
Stupid question maybe, but you did remove the plastic cover?
(I left mine on the first time, waited for hours to find out it was not charging....)

It was fully charged from red to green. When put in OSMO, the green light was on for 5 seconds and then turned red.
2018-3-11
Use props
Montfrooij
Captain
Flight distance : 1915335 ft
Netherlands
Offline

fans6a32f49a Posted at 2018-3-11 06:59
It was fully charged from red to green. When put in OSMO, the green light was on for 5 seconds and then turned red.

Ok, I have no clue why that would happen.
Have you contacted support?
2018-3-11
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules