Please select Into the mobile phone version | Continue to access the computer ver.
Radio Channel Quality - Poor
1931 36 2018-3-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

Having issues with the screen going in and out on my P4.
Noticed that the radio channel quality is poor. (Flickers / and green screen)

Tried switching from my iPad to iPhone 7plus and still getting the same issues.

Seems worse after a recent update but not 100% sure.
I’ve been using my Mavic for a few months.

Any tips or thoughts it could be?

9626415F-D183-40A7-872C-8E176B2FE5D7.png
BA2FD910-133E-442B-85F8-9AA6AC843B2E.png
FDC3F4A5-F757-4E0E-A3B4-37D43822FB89.png
2018-3-13
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

I have tried turning off WiFi on either device also and hasn’t helped any.
2018-3-13
Use props
Aardvark
Captain
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

Which version of iOS are you running on your devices ?
2018-3-13
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

Aardvark Posted at 2018-3-13 15:52
Which version of iOS are you running on your devices ?


Forgot to add that..
iOS 11.2.6

Also tried switching cables also. No issues at all with my Mavic Pro, I know that’s totally different setup.
2018-3-13
Use props
ALABAMA
Captain
Flight distance : 10442687 ft
United States
Offline

Have you tried a different location to see if it's better?
2018-3-13
Use props
Aardvark
Captain
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

vdubbin Posted at 2018-3-13 16:00
Forgot to add that..
iOS 11.2.6

Is DJI Go 4 set for auto channel select, I wonder if a channel has been manually selected, and interference on that channel. Look in 'HD' (Image Transmission Settings) and make sure it's set to 'Auto'. You could also try switching display devices to 'Airplane' mode before use, so that no 2.4GHz signals coming from there.

Edit:- And what Alabama said above, different location ?
2018-3-13
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

It is on Auto, I haven’t changed that but have looked.  I will try a couple more locations.  The 2 I tried i got the same results.  Will try in Airplane mode also.
2018-3-13
Use props
Nabe
lvl.3
Flight distance : 1627031 ft
Japan
Offline

Is not the performance of the device insufficient?
2018-3-13
Use props
Archangel3356
Second Officer
Flight distance : 4655896 ft
United States
Offline

If your anywhere near a wireless router in the house when checking try turning it off. My Asus router and wireless cameras on my property pop up that warning all the time. Shut them off and it goes away. Flys fine around the property even if I don’t shut them though. Have a feeling that warning is overly sensitive anyway. Just a thought.
2018-3-13
Use props
DJI Elektra
Administrator
China
Offline

vdubbin Posted at 2018-3-13 17:01
It is on Auto, I haven’t changed that but have looked.  I will try a couple more locations.  The 2 I tried i got the same results.  Will try in Airplane mode also.

Did you try to change a environment or go to the wide place with good GPS signal? If the problem remains, please tell me the firmware of your drone. Thanks for your support.
2018-3-18
Use props
fans02010415
lvl.3
Canada
Offline

I had the same problem with my P4. I thought it was the latest firmware version for my RC  that was causing the problem. So I reverted back to the previous version before the update.

This solved much of the video problem.

Any comments from DJI reps ?
2018-3-18
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

DJI Elektra Posted at 2018-3-18 02:54
Did you try to change a environment or go to the wide place with good GPS signal? If the problem remains, please tell me the firmware of your drone. Thanks for your support.

I changed location and didnt get the Poor Signal error anymore.

I am still getting the video cutting out green screen covering half the screen at times.
The Poor signal error wasn't probably my problem but when i went to look into why the screen
was going out so often made me think i was having signal issues when i saw the error.

I'll have to do some more testing with a new cable from the controller to my iphone / Ipad and see if it helps at all.

any other things i should check or try?  I posted a screen shot up above of all the current software versions.

paul
2018-3-19
Use props
DJI Elektra
Administrator
China
Offline

vdubbin Posted at 2018-3-19 02:59
I changed location and didnt get the Poor Signal error anymore.

I am still getting the video cutting out green screen covering half the screen at times.

Please ensure that you put your antenna in the right position. Keep us updated, if you have any problem.
2018-3-20
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

DJI Elektra Posted at 2018-3-20 03:16
Please ensure that you put your antenna in the right position. Keep us updated, if you have any problem.

Yeah i always put the antenna correct, based on what i'm flying.  Just seems like the video cuts out more, or alot more than it used to and flying pretty close to the controller also.

I'll have to post some screen recordings of it
2018-3-20
Use props
Kokok
Second Officer
Flight distance : 1700377 ft
Philippines
Offline

Hi,

I am experiencing exactly what you are experiencing.

My p4 did not have any problem. live feed was solid even at distances of 2km and beyond. Now, I get this radio channel quality poor warning, and sometimes a weak image transmission signal despite the aircraft being around 300m from me.

And yes, I also noticed this after updating to the latest firmware.

Im running all (aircraft, rc, iPad mini 4) on their latest firmware version.

Thanks!
2018-3-20
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

Kokok Posted at 2018-3-20 17:42
Hi,

I am experiencing exactly what you are experiencing.

Glad i'm not the only one i guess
2018-3-21
Use props
Black hawk
lvl.2
Canada
Offline

vdubbin Posted at 2018-3-21 02:22
Glad i'm not the only one i guess

After last update i'm having the same video and aircraft lost signal issue's as well, which wasn't a problem before update ??
2018-3-21
Use props
p4ever
First Officer
Flight distance : 681975 ft
Switzerland
Offline

Kokok Posted at 2018-3-20 17:42
Hi,

I am experiencing exactly what you are experiencing.

same here, waste of time with v2.x firmwares
2018-3-21
Use props
Siambuddhas Group
First Officer
Flight distance : 116926 ft
Offline

Really annoying thot...
2018-3-21
Use props
djiuser_9qoa96zTVxhO
lvl.1

Norway
Offline

All issues disappear with downgrade to v1.x firmware, i'm happy again
2018-3-22
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

djiuser_9qoa96zTVxhO Posted at 2018-3-22 00:29
All issues disappear with downgrade to v1.x firmware, i'm happy again

I'm going to have to do this and see if it helps me.  Does it still work ok with the latest IOS update?
2018-3-22
Use props
DJI Elektra
Administrator
China
Offline

vdubbin Posted at 2018-3-20 05:33
Yeah i always put the antenna correct, based on what i'm flying.  Just seems like the video cuts out more, or alot more than it used to and flying pretty close to the controller also.

I'll have to post some screen recordings of it

Did the transmission become poor when the drone is near to you? Please provide us the screenshot of the image transmission setting before flight.
2018-3-22
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

DJI Elektra Posted at 2018-3-22 02:54
Did the transmission become poor when the drone is near to you? Please provide us the screenshot of the image transmission setting before flight.

I'll do some test videos and report back
2018-3-22
Use props
djiuser_9qoa96zTVxhO
lvl.1

Norway
Offline

vdubbin Posted at 2018-3-22 02:49
I'm going to have to do this and see if it helps me.  Does it still work ok with the latest IOS update?

yes... latest ios & djigo
2018-3-22
Use props
hhudson
lvl.1

United States
Offline

I have the same problem. I have the channels on auto, and wifi off. I reinstalled the DJIGo4 app, but it is still the 4.2.6 version and having the same problem. How can I get back to ver. 1? Any help would be appreciated.
2018-3-22
Use props
fansa894547e
New
United States
Offline

I'm having green screen/ weak transmission  issues as well on firmware v2.0.0700 . The firmware version just before this update is the only version I have to downgrade to and it is just a little better if any. I have tried everything others on the page suggested and more . I even tried other iOS devices with older iOS versions , new sad card that meets DJIs criteria, formatted sd card ,reset camera settings , I even tried a 3 red party app to see if the go4.0 was an issue ...same results . The drone mostly starts live feed issues over 250' ( which shouldn't be anything to the p4 ) but sometimes even 20'. At this point I'm almost convinced the issue is the firmware . We can I obtain v1.6 to try ? Most seem to have good luck running this version  and people who had it that could revert claim no more issues after going back . Any help would be appreciated . Thanks
2018-3-23
Use props
fans02010415
lvl.3
Canada
Offline

I am wondering when an update to the firmware for the RC will be put out to correct this issue for the P4.
2018-3-28
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
United States
Offline

fans02010415 Posted at 2018-3-28 07:07
I am wondering when an update to the firmware for the RC will be put out to correct this issue for the P4.

Hopefully soon.. I haven't tried to fly my Phantom lately just because its hard to fly.

I need to do it just to post of a video of what its doing and then try reverting back to the older software to see if it is better.
2018-3-28
Use props
markdaviesmedia
Second Officer
Flight distance : 464961 ft
United States
Offline

Over the winter, I had charged up, kept up with app and firmware updates but yesterday was the first time in a couple months that I actually flew.

After (another!) iOS app update on my iPad, I powered up both the remote and the P4 while I was still in the house. I got compass calibration and radio signal strength warnings but after shutting down and then restarting outside both errors went away.

FWIW & YMMV.

-
2018-3-29
Use props
fans02010415
lvl.3
Canada
Offline

I am wondering how the video quality as seen from your screen was when you were flying.

That’s the problem we’re focussing on in this thread.
2018-3-30
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
Offline

can't downgrade my P4 from 2.0... hoping they come out with a fix
I'm getting green screen and flicker less than 50ft away
2018-4-5
Use props
Geebax
Captain
Australia
Offline

vdubbin Posted at 2018-4-5 16:47
can't downgrade my P4 from 2.0... hoping they come out with a fix
I'm getting green screen and flicker less than 50ft away

There are probably at least three issues here, and if you want to solve it, you need to isolate the correct problem. When you get the Radio Channel Quality Poor message, it does not mean just strength. Look at the number of bars next to the RC icon, they indicate the strength of the signal, and in the third photo, the signal strength appears to be good. Note that you have an error message saying 'Strong Interference Detected', which is more likely the reason for the poor quality radio signal.

Switching from iPad to iPhone wont have any effect on this, try looking at the radio channel display and you will probably find signals on all channels. If so, that is your real problem, you need to get out of the house or even out of the neighborhood. This is because WiFi routersw in every house around you are providing that interference.

The green banding on your device is not necessarily caused by radio interference either. Mostly it is the inability of your phone or tablet to display the video signal, and that is probably a combination of a number of things, first the age of the device, second the bloated Go App code and perhaps some radio interference contribution.


2018-4-5
Use props
Reno Maenhout
lvl.3
Flight distance : 1911063 ft
Netherlands
Offline

Geebax Posted at 2018-4-5 17:40
There are probably at least three issues here, and if you want to solve it, you need to isolate the correct problem. When you get the Radio Channel Quality Poor message, it does not mean just strength. Look at the number of bars next to the RC icon, they indicate the strength of the signal, and in the third photo, the signal strength appears to be good. Note that you have an error message saying 'Strong Interference Detected', which is more likely the reason for the poor quality radio signal.

Switching from iPad to iPhone wont have any effect on this, try looking at the radio channel display and you will probably find signals on all channels. If so, that is your real problem, you need to get out of the house or even out of the neighborhood. This is because WiFi routersw in every house around you are providing that interference.

Realy?
Way are we all have this problem just now?
Same situation same devices, all same as before.
Only different New firmware.  
Please do not tell us we all have  divices  that got to old in a fee days.
People who got back to onder firmware seem to takle the problem.
I do not know how. So please come with an downgrade for as long as this problem is not solved.
I, and others have to earn there living with this instrument.
Please help with downgrade, upgrade, wathever, helpt. Us  soon
2018-4-6
Use props
Geebax
Captain
Australia
Offline

Reno Maenhout Posted at 2018-4-6 11:12
Realy?
Way are we all have this problem just now?
Same situation same devices, all same as before.

Yes really. I don't know why I bother writing these detailed explanations when people like you cannot apply even the simplest diagnostic techniques. If you have green screen and freezing, then it is a problem in the device you are using. First thing is to check if the RC unit is receiving a satisfactory signal strength (as I wrote about earlier). If not, then something is faulty in the transmission path. If the strength is OK, then look at the channel display and see if there are competing devices. If so, there is the most likely cause of the problem. If the channles are relatively clear, then the issue is with your device. Switch off video caching, empty the cache, shut off WiFi and see how it goes.
2018-4-6
Use props
vdubbin
lvl.4
Flight distance : 1031647 ft
Offline

Geebax Posted at 2018-4-6 21:04
Yes really. I don't know why I bother writing these detailed explanations when people like you cannot apply even the simplest diagnostic techniques. If you have green screen and freezing, then it is a problem in the device you are using. First thing is to check if the RC unit is receiving a satisfactory signal strength (as I wrote about earlier). If not, then something is faulty in the transmission path. If the strength is OK, then look at the channel display and see if there are competing devices. If so, there is the most likely cause of the problem. If the channles are relatively clear, then the issue is with your device. Switch off video caching, empty the cache, shut off WiFi and see how it goes.

The first issues i had was me trying to troubleshoot in my house with the "poor signal" error

That is fixed when i leave my house and go to a open area or just my backyard in general.  I thought this was my green screen cutting out issues.
I never had these issues before the update and this often.

I didn't just get the P4 and am having these issues.  They recently just started so its not my devices, not buying that.

I even tried to re-sync the remote to see if that was the issue & tried a couple different cables.

I will try the cache issue and post screen shots or video of the signal display
2018-4-8
Use props
Reno Maenhout
lvl.3
Flight distance : 1911063 ft
Netherlands
Offline

vdubbin Posted at 2018-4-8 07:12
The first issues i had was me trying to troubleshoot in my house with the "poor signal" error

That is fixed when i leave my house and go to a open area or just my backyard in general.  I thought this was my green screen cutting out issues.

I think the same.   no problems befor update. Tryed all Thet is taled. dit not work.
Last thing I did was after someone adviced me (I live in The Netherlands)  to put my Ipad region to US Englisch.  so I did. before I could not put HD to manual. After that I could.  But strance  enough I dit not have to put it to manual. I just had good video till about 2 Km.  

But this did not safe me for long. This morning same isue came back.  I can try Manual tomorow, but why dit it work fine before???? the update?  Firmware update, DJI will never tell us that.  I Just hope they are working overtime to solve this fast. Again some clients coming week. I want to work safe and good.
Thanks
2018-4-20
Use props
p4ever
First Officer
Flight distance : 681975 ft
Switzerland
Offline

vdubbin Posted at 2018-4-5 16:47
can't downgrade my P4 from 2.0... hoping they come out with a fix
I'm getting green screen and flicker less than 50ft away

downgrade with magic program on last stable firmware v1.2.602, every v2 has issues
2018-4-21
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules