Please select Into the mobile phone version | Continue to access the computer ver.
M100 Frame arm worked loose
627 2 2018-3-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
fansb4d236d1
lvl.2
United States
Offline

I have a M100 thats about a year and half old.  Since it was new I have kept a maintence record and performed monthly inspections, anual inspections and time based inspections.  That said in January I removed the top half of the aircraft to check all data and electrical connections.  The top half was reinstalled and lock tight was used on all screws.  2 weeks ago everything was inspected and no issues were found.  Last weekend we were flying a job, and went through several sets of batteries with several normal landings.  Last flight of the job, we landed and I noticed that frame arm M3 had come out of its mounting bracket.  It appears the only thing holding it in was the wires for the motors / ESCs.  I attempted to slide the arm back into place and it would not go back into the mount.  The screws were all tight, in fact I rounded off the the supplied DJI driver / wrench.  Once home I found it necessary to remove the top half of the aircraft and I proceded to romove and reinstall all 4 frame arms.  I applied some lock tight inside the mount / frame interface to hopefully pervent this from happening again.  On the day of the flight it was cold but not freezing temps probably upper 40s to low 50s.  Has anybody ever had a simular issue and how did you address it?
2018-3-13
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Sorry to read on your post, it is lucky that there was no accident caused. Please check the tutorial video of Matrice 100  Setup again to make sure no steps were missed: If the issue persists, any chance to post a picture or video here? Thank you very much.
2018-3-13
Use props
fansb4d236d1
lvl.2
United States
Offline

The aircraft was purchased in the smarter farmer package so it came assembled however during my annual inspection I may have put the shorter top plate screws where the longer ones were supposed to be.  That said I made sure during this repair to get them all in the correct position.  All that said I don't see that putting the wrong size screws in the top plate would have an effect on the frame arms.  Also, I can see how the outer and inner fasteners clamp the frame arms from the side however I'm not sure theirs enough clamping action to hold.  Thank you for your response.  
2018-3-14
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules