Please select Into the mobile phone version | Continue to access the computer ver.
DJI Focus has never worked
661 1 2018-3-16
Uploading and Loding Picture ...(0/1)
o(^-^)o
Rotor360
lvl.3
Flight distance : 4500659 ft
Australia
Offline

So my DJI focus has never really worked.

First unit went back a week after purchase as a DoA (back in 1016 I think).

The replacement unit I tried to get working and it worked for afew moments befor the motor stopped responding so I shelved it.

Just tried again today and the hand remote powered up and the focus motor didn't work as usual.

I tried updating the firmware to V1.6 and now the hand unit wont even power up?

Anyone got any good advice other than throwing this thing away?

I just want to restart the hand controller and start over but the screen is blank, and the LED light is dim white when charging via USB.
2018-3-16
Use props
DJI Elektra
Administrator
China
Offline

Hi, can you shoot a video of the situation? Did you charge it? Please keep us updated, thanks for your support.
2018-3-19
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules