Please select Into the mobile phone version | Continue to access the computer ver.
Updating Dji Spark Firmware Failure
1212 1 2018-3-17
Uploading and Loding Picture ...(0/1)

I haven't used my spark for a couple of months and now that I've come back to it today I was faced with having to update everything including Rc and Spark firmware as well as the flight database. All of such downloaded without a problem but refuse to update. I have tried to update in all forms of configurations - OTB to controller to Spark - Wifi to controller to spark and directly with wifi to the Spark.
None of these methods have been able to work so far. Reading another thread i attempted to delete and redownload the DJI Go 4 app, the same problems haven't changed and the update still fails at 0 or 5%.

Then I read another thread which sent me down the path of attempting to install the DJI Assistant 2 (THIS NEVER WORKED BTW) after spending about 2 hours trying to install this and having to figure out how to make the drivers work for windows, the drone never showed up in the app. I THEN DID THE SAME WITH AN OLDER COMPUTER RUNNING WINDOWS 7 AND IT STILL DID NOT SHOW MY SPARK...

I am absolutely perplexed as to how this hasnt worked, and now i have wasted an entire day trying to update my spark... Any reps from DJI please explain why this is happening, and how to install the dji assistant PROPERLY... (also the fact that there is no instructions directly from dji regarding the assistant app is ludacris, i should not have to seek 3rd party knowledge when trying to simply update my drone.)
Use props
DJI Elektra


Please ensure that you download the one from the spark section. If it fail many times, please contact our support and start a case:
Use props
You need to log in before you can reply Login | Register now

Credit Rules