Please select Into the mobile phone version | Continue to access the computer ver.
Spark Interference and constant connect/disconnect
3242 6 2018-3-23
Uploading and Loding Picture ...(0/1)
o(^-^)o
nutsnbolts
lvl.3
  • >>>
United States
Offline

I have a quick question. I usually sometimes fly my drone outside my house and I get mix results. There are days where (flying at the same spot) I don't have any issues and there are days where my RC and Spark connects and disconnects constantly.

Folks are telling me that it's due to interference and as much as I know that is most likely the case. I guess what I don't understand is the actual "science/technicalities" that causes this and what I mean is how come some days there are more interference than other days? I mean I'm assuming it's the WIFI in the neighborhood but it's not like the WIFI in the neighborhood changes constantly? What's there is there?

Now with that said, is there a surefire way to combat the disconnect/connect when this happen? (i.e. changing channels/band?) or is there a way to tell for sure that it's definitely the WIFI interferences that is going on?

Should I go down the street and try a different location to rule this out?

There are days I just give up since it keeps connecting and disconnecting and there are days it just works. You got me!

2018-3-23
Use props
Ram-UK
First Officer
Flight distance : 414163 ft
United Kingdom
Offline

Connect your AC to the remote and phone/tablet then in the DJI Go app go to Wifi settings and check the frequencies for interference - It's self explanatory.

I usually leave the WiFi frequency settings in auto but you can also manually select a stable freq. with less interference. If this is still causing problem move to an open area where there is no building, power lines, etc.

It's not advisable to fly anywhere near buildup areas as you would expect more interference.
2018-3-24
Use props
Gunship9
Captain
United States
Offline

Check the channel page as Ram said.  WiFi interference can change as my devices aren't always transmitting.  The home network might be affected by people moving around or cars in the garage or not.  Furthermore, I think the new routers are using better computer chips to expand the distance of the signal as needed.  It is the side of your remote's antenna that needs to be facing the drone not the tip.  It is pretty directional.  
2.4ghz doesn't work for me and I am out in the country.  Smart Tractors, wifi cameras in barns, and who knows are all piled on 2.4ghz where I live so I have to use 5.8ghz.  Radio Control model flying isn't really an at your house hobby.  My Spark first pitched a fit about interference when I set it to a high hover and few my plane on 2.4ghz near it for video shots.



2018-3-24
Use props
nutsnbolts
lvl.3
  • >>>
United States
Offline

Ram-UK Posted at 2018-3-24 02:14
Connect your AC to the remote and phone/tablet then in the DJI Go app go to Wifi settings and check the frequencies for interference - It's self explanatory.

I usually leave the WiFi frequency settings in auto but you can also manually select a stable freq. with less interference. If this is still causing problem move to an open area where there is no building, power lines, etc.

I'll check this again, if I read this correctly, you're saying that I should see the frequency that is causing the interference and changing that to another frequency should "technically" correct it. Of course, for the most part, "auto" should be sufficient to put me in the correct stable frequency.
2018-3-24
Use props
nutsnbolts
lvl.3
  • >>>
United States
Offline

Gunship9 Posted at 2018-3-24 05:06
Check the channel page as Ram said.  WiFi interference can change as my devices aren't always transmitting.  The home network might be affected by people moving around or cars in the garage or not.  Furthermore, I think the new routers are using better computer chips to expand the distance of the signal as needed.  It is the side of your remote's antenna that needs to be facing the drone not the tip.  It is pretty directional.  
2.4ghz doesn't work for me and I am out in the country.  Smart Tractors, wifi cameras in barns, and who knows are all piled on 2.4ghz where I live so I have to use 5.8ghz.  Radio Control model flying isn't really an at your house hobby.  My Spark first pitched a fit about interference when I set it to a high hover and few my plane on 2.4ghz near it for video shots.

That's I was aware of the how the antenna should be facing. I guess what gets me is how it's so inconsistent as some days it works great and some days it just won't keep a stable connection.

Now this is on both the latest version of the spark and DJI Go App. I will try switching to a different frequency to see if this helps it.
2018-3-24
Use props
DJI Susan
Administrator

Offline

As Ram mentioned, you can check the interference under WiFi settings. Or change another open place without interference to see whether it works. Please keep us posted on the latest progress, thanks!
2018-3-25
Use props
Kaiku
lvl.3

Offline

HI, having the same issue with my Spark. Any FIX?
2018-3-29
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules