Please select Into the mobile phone version | Continue to access the computer ver.
P4 Remote not taking Firmware update
Uploading and Loding Picture ...(0/1)
o(^-^)o
Fotografom 4
lvl.1
Flight distance : 9872 ft
Offline

Yesterday I used my P4 for the first time in a few months since I got my remote back from DJ for software repair.

I connected to the app and did the upgrades it reccomended for my drone and remote.

I drove to where I was going to fly it and it looked to be working fine in the app (both drone and RC). It showed that the remote still needed a firmware update and immediatelty broke the remote after a few beeps.

I have tried reseeting the drone via the PC & mac apps and it worked fine. The remote is not recognized by the DJI assistant but it is seen by the DJI GO app.

I have tried to do the rset via the DJI go app but it just beeps and then the light turns red.

Any thoughts on what I should do? Maybe I got the device back not in the best shape since I havent flown it since DJI gave it back.



2018-4-15
Use props
DJI Susan
Administrator

Offline

Hi there, could you read the current aircraft and controller version in About page? The P4 RC does not support to upgrade via DJI Assistant 2. You can refer below and try to update:
Turn off the RC, hold the C1, C2, Record button and toggle the ISO dial at the same time, then turn on the RC, and connect it with APP to update from overall status.
2018-4-15
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules