Please select Into the mobile phone version | Continue to access the computer ver.
P3 Pro bad update, continuous beeping after downgrade attempts
513 2 2018-4-20
Uploading and Loding Picture ...(0/1)
o(^-^)o
r00tb33r
lvl.1

United States
Offline

Hey all,

I've got a P3 Pro here that's in a bad pickle.  A friend recently updated this P3 Pro to the latest firmware using the DJI app, but after the firmware update we had RC signal problems, despite many RC pairing attempts with the button on the side of the drone (seemingly successful, according to the app anyway, but still complained of weak signal or disconnected).  Can see the feed from the gimball camera, but won't do anything else, can't take off or fly, flashed yellow LEDs in the back.  Drone was fine before the update and we certainly regret updating it.

So naturally after all that failed I tried downgrading the firmware back.  I downloaded firmware v1.07.6 from http://phantomhelp.com/Mobile/Ph ... al/#FirmwareArchive and placed the .bin file (not the .zip archive!) in the root of the SD card.  I started up the drone and the RC without the SD card, and once initialized I inserted the SD card.  The drone started making quiet chirping noises and 10-15 minutes later had solid RED lights on all four corners, that's a failed firmware update/downgrade from what I understand.  I tried a few more times, including removing the log files from the SD card per suggestion I found online, nothing.

On last attempt it became even worse.  Now as soon as the drone is powered on it's beeping loudly like a smoke detector or a car alarm, and won't stop, no lights on the corners.  I let it sit like that beeping in the garage for 2 hours with the .bin file on the SD card, but no change.  Is it bricked?  Any method of recovery?

Here's what it looks and sounds like:
https://nofile.io/f/e8f8Cf0bpB0/MOV_0202.mp4

Any insight is appreciated.  Thanks in advance!
2018-4-20
Use props
treybein
lvl.4
Flight distance : 15262 ft

Offline

You may have rolled back too far.. Try a more recent firmware version, or the latest version again just to regain control of the P3P..
Good Luck
2018-4-20
Use props
DJI Susan
Administrator

Offline

Currently, the P3P is not available to downgrade, sorry about this. Could you read the current aircraft and controller version in About page? Please format the SD card, make sure both the aircraft and controller have been updated to the latest version, then link RC again to see whether it works.
2018-4-24
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules