Please select Into the mobile phone version | Continue to access the computer ver.
Inspire 2/X4s Encoder Error Problem
597 8 2018-4-30
Uploading and Loding Picture ...(0/1)
o(^-^)o
GadgetRick
lvl.2
United States
Offline

[size=14.6667px]Anyone come up with a solution to this one? I've seen plenty of posts from people but not one person has every posted what the solution was (whether sending it in helped or some software fix). Trying to get my I2 working (X4s). When I first went to start it up in the house, got the error. Messed around, restarting things and got it to work. Took it out the next day, did maiden flight, no problems.

[size=14.6667px]Tried to do my first job with it a few days later and getting the Encoder Error message. Messed around restarting, got it to work for a flight. Couldn't get it to work after that.

[size=14.6667px]Just now, did the following trying to fix it:

[size=14.6667px]Using Assistant 2
[size=14.6667px]-Reset to Factory Defaults and reinstalled latest FW (w/gimbal installed). Powered up, worked. Powered down/up, same problem (Encoder Error).
[size=14.6667px]-Reformatted SD card. Encoder Error
[size=14.6667px]-Reset to Factory Defaults and reinstalled latest FW (without[size=14.6667px] gimbal installed). Encoder Error

[size=14.6667px]I also got a No SD Card Installed error at one point (yes, there was a card installed). Saw a sensor error earlier--only seen this one once.

[size=14.6667px]I see others reporting this problem with the I2 as well as P4 and Mavic. But no real solutions.

[size=14.6667px]Yes, the gimbal is installed.

[size=14.6667px]Yes, I tried 2 different sets of batteries.

[size=14.6667px]It's too late to call Multicopter Warehouse--where I bought it--they've been very helpful in the past.

[size=14.6667px]Knowing DJI's history with software, I'm convinced it's a software issue. I'm hoping it's a sw issue (which can be resolved) as I dread having to send anything in and wait for it.
2018-4-30
Use props
DJI Elektra
Administrator
China
Offline

Rick, please provide a screenshot of the image screen with the error message. Please tell me the firmware of your drone and camera. Thanks for your cooperation.
2018-5-1
Use props
GadgetRick
lvl.2
United States
Offline

DJI Elektra Posted at 2018-5-1 01:03
Rick, please provide a screenshot of the image screen with the error message. Please tell me the firmware of your drone and camera. Thanks for your cooperation.

It is the latest FW versions. Don't know the exact versions as I'd have to go set it all up again to turn it all on. But I've confirmed it's the latest as of last night.

I cannot upload the screenshot as it says it's too big. Error is:

Aircraft Encoder Error(0x100000), please check if gimbal is installed



2018-5-1
Use props
DJI Elektra
Administrator
China
Offline

GadgetRick Posted at 2018-5-1 01:34
It is the latest FW versions. Don't know the exact versions as I'd have to go set it all up again to turn it all on. But I've confirmed it's the latest as of last night.

I cannot upload the screenshot as it says it's too big. Error is:

Sorry for the late response. In your situation, I would recommend you send it back for repair: http://www.dji.com/support Thanks for your support.
2018-5-7
Use props
GadgetRick
lvl.2
United States
Offline

DJI Elektra Posted at 2018-5-7 03:20
Sorry for the late response. In your situation, I would recommend you send it back for repair: http://www.dji.com/support Thanks for your support.

I just did. However, I also found someone who said an IMU calibration fixed their (similar) problem. I wish someone at DJI had suggested that before I sent it in. Now I have to wait for who knows how long before getting it back. You guys need to find a better way to support people who do this for a living. Take a look at Canon, Nikon, etc. They all have a professional services plan. We pay a little extra annually and we get faster/less expensive service and loaners.
2018-5-7
Use props
DJI Elektra
Administrator
China
Offline

GadgetRick Posted at 2018-5-7 05:22
I just did. However, I also found someone who said an IMU calibration fixed their (similar) problem. I wish someone at DJI had suggested that before I sent it in. Now I have to wait for who knows how long before getting it back. You guys need to find a better way to support people who do this for a living. Take a look at Canon, Nikon, etc. They all have a professional services plan. We pay a little extra annually and we get faster/less expensive service and loaners.

Rick, thanks for the info. But IMU is a part to help drone keep steady, I think it can not help you solve the error. I would recommend you wait for the repair assessment.
2018-5-7
Use props
GadgetRick
lvl.2
United States
Offline

So, an update:

They received it the other day, assessed it and are now repairing it. I have to say I'm pleased with how quickly it's happening as I expected a couple of months after reading the horror stories. I'll update again once I get it back.
2018-5-10
Use props
DJI Elektra
Administrator
China
Offline

GadgetRick Posted at 2018-5-10 06:48
So, an update:

They received it the other day, assessed it and are now repairing it. I have to say I'm pleased with how quickly it's happening as I expected a couple of months after reading the horror stories. I'll update again once I get it back.

Glad to hear that. Please keep us updated, thanks.
2018-5-21
Use props
GadgetRick
lvl.2
United States
Offline

Got it back from DJI and it seems to work. Thank goodness!
2018-6-3
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules