Please select Into the mobile phone version | Continue to access the computer ver.
Mavi Air Gimbal Glitch - Yaw / Roll
867 7 2018-5-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
JonnyHammer
Second Officer
Flight distance : 748802 ft
Brazil
Offline

Hello, I flew my Mavic Air today and noticed some weird things on the gimbal:

1) When moving left/right on the yaw it rolls a little bit to the same side (not flying FPV, check the video)

2) After start, camera stays pointing up and the app reports: "gimbal motor overloaded" , I turned on and off many times and this message appeared just sometimes

3) When flying sometimes the gimbal moves by itself pointing up, even hovering to get a shot from a basket court, the gimbal moved up when I tried to point straight down

Everything is calibrated and good to fly, none of this was happening before the latest firmware update, I bought my air less than a month ago, brand new, never fell or crashed



2018-5-29
Use props
saviour
First Officer
Flight distance : 604203 ft
Offline

I think that small roll after a quick yaw rotation is normal, at least I got the same. My guess is the drone has to stabilize. I don't think that's an error.
2018-5-29
Use props
JonnyHammer
Second Officer
Flight distance : 748802 ft
Brazil
Offline

saviour Posted at 2018-5-29 21:07
I think that small roll after a quick yaw rotation is normal, at least I got the same. My guess is the drone has to stabilize. I don't think that's an error.

Thanks Saviour. I used to fly a phantom 3 and the yaw rotation didn't make it roll at all. It's not a big deal, I just wanted to check with other mavic air users if this happens to them as well.

2018-5-30
Use props
JonnyHammer
Second Officer
Flight distance : 748802 ft
Brazil
Offline

Update: Flew again yesterday and everything was fine, no problems in the gimbal and yaw
2018-5-31
Use props
tiagosaraivacg.
lvl.4
Flight distance : 24042 ft
Portugal
Offline

today when flying had this kind of problem too.. was making a straight upward flight with gimbal pointing down. and as I was climbing i started moving gimbal up, but from all sudden the AC just moved yaw to the left without any input from my controler. I instantly landed my MA, anyone with this kind of problem? not first time happening, even had some flights without any problem of that kind. should I be worried?.. neverless the all shot was screwed after that yaw move, and didnt tried it again.
2018-5-31
Use props
JonnyHammer
Second Officer
Flight distance : 748802 ft
Brazil
Offline

tiagosaraivacg. Posted at 2018-5-31 11:45
today when flying had this kind of problem too.. was making a straight upward flight with gimbal pointing down. and as I was climbing i started moving gimbal up, but from all sudden the AC just moved yaw to the left without any input from my controler. I instantly landed my MA, anyone with this kind of problem? not first time happening, even had some flights without any problem of that kind. should I be worried?.. neverless the all shot was screwed after that yaw move, and didnt tried it again.

I think that it can be something related to the initialization of the mavic: If I turn on the battery with the mavic in my hand, the gimbal gets 'crazy' and points up, app reports 'gimbal motor overloaded'.

If I turn on the battery and instantly put it on a flat surface (like the ground, table, etc) the gimbal points forward and act normal during the flight.
2018-5-31
Use props
EdisonW1979
First Officer
Flight distance : 1535679 ft
Canada
Offline

tiagosaraivacg. Posted at 2018-5-31 11:45
today when flying had this kind of problem too.. was making a straight upward flight with gimbal pointing down. and as I was climbing i started moving gimbal up, but from all sudden the AC just moved yaw to the left without any input from my controler. I instantly landed my MA, anyone with this kind of problem? not first time happening, even had some flights without any problem of that kind. should I be worried?.. neverless the all shot was screwed after that yaw move, and didnt tried it again.

This seems to be an issue with the latest MA firmware .0400, see this thread:

https://forum.dji.com/forum.php? ... D534%26typeid%3D534

Some people here will claim there is no issue, but there is, and DJI is aware of it and supposedly working on a fix, but taking their sweet time so far.

I'd suggest you refresh the firmware via DJI Assistant 2, not OTA, and then recalibrate everything... First restore to factory settings via Assistant, then recalibrate VPS using Assistant, then find a PERFECTLY FLAT (like measured to be flat with bubble levels flat) surface to redo your IMU calibration, then go outside and recalibrate your compass and gimbal.

You "should" be ok after this, until DJI fixes the issue.

Good luck!
2018-5-31
Use props
tiagosaraivacg.
lvl.4
Flight distance : 24042 ft
Portugal
Offline

EdisonW1979 Posted at 2018-5-31 17:49
This seems to be an issue with the latest MA firmware .0400, see this thread:

https://forum.dji.com/forum.php?mod=viewthread&tid=147912&extra=page%3D1%26filter%3Dtypeid%26typeid%3D534%26typeid%3D534

thanks for the kind suggestions, tomorrow will try that before fly (if weather helps... been a bit rainy lately). But yeah, I also think it has to do with the last FW. even sometimes I fly it flawless.. it might be hard for Dji tech to discover the problem. since is kinda random. but hope they fix it ofc.
2018-5-31
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules