Please select Into the mobile phone version | Continue to access the computer ver.
Tab S2 to P3 Pro Connection Problem
1311 19 2018-6-18
Uploading and Loding Picture ...(0/1)
o(^-^)o
stuka75
First Officer
Flight distance : 85682 ft
United States
Offline

Setting up a friends P3 with A Tab S2 and get it to connect to the Pro 3 ac. When I hook up the cable between the tx and talbet, it goes to charge on tablet. Cant find setting on the tablet to change charge to data transfre. THe tablet is on Android 7.0. Would appreciate any advice.
Thanks
2018-6-18
Use props
DJI Stephen
Super Moderator

Offline

Hi. Thank you for raising this concern. I understand that you want to set up your friends Phantom 3 with a Samsung Tab S2. Let me help you with this. May I know the model of the Phantom 3 that you have? For me to check the compatibility of the mobile device.
2018-6-18
Use props
stuka75
First Officer
Flight distance : 85682 ft
United States
Offline

DJI Stephen Posted at 2018-6-18 08:00
Hi. Thank you for raising this concern. I understand that you want to set up your friends Phantom 3 with a Samsung Tab S2. Let me help you with this. May I know the model of the Phantom 3 that you have? For me to check the compatibility of the mobile device.

Phantom 3 Pro.
2018-6-18
Use props
stuka75
First Officer
Flight distance : 85682 ft
United States
Offline

Problem solved.
2018-6-19
Use props
Bashy
Captain
Flight distance : 549140 ft
United Kingdom
Offline


Please do let us know how  so you may help others in the future
2018-6-19
Use props
stuka75
First Officer
Flight distance : 85682 ft
United States
Offline

Honestly, Im not sure. There was a setting Called RSBD or something like that. Dont remember if I turned it on , or off. That said, I could never find that setting again, even developer options. After that, I could connect the tablet to the tx. Let you know if I ever find that setting again.
Sorry.
2018-6-20
Use props
Bashy
Captain
Flight distance : 549140 ft
United Kingdom
Offline

stuka75 Posted at 2018-6-20 17:39
Honestly, Im not sure. There was a setting Called RSBD or something like that. Dont remember if I turned it on , or off. That said, I could never find that setting again, even developer options. After that, I could connect the tablet to the tx. Let you know if I ever find that setting again.
Sorry.

ha ha, no worries chap, thanks for replying at least, for me, i rooted my device and put on android 6, also,
another tip, with both devices turn on, then connect the cable and a popup should show asking to connect to the app and other apps if they are installed, do not tick to keep it as default, you always want that box to pop up, because then in the future, if it does not pop up you can rule in connection issues.


If you have already ticked it, just go in to apps, then default apps and find the app and remove the defaults, there is always a setting for the apps to always use the 1st as the default, change that to always ask. I have 2 S2's so had a bit of experience with it, i came to your party a bit too late to help, but glad ya got it sorted!!
2018-6-20
Use props
Mickus
lvl.4
Flight distance : 601677 ft
Offline

To connect tab S2 to pro/a
Turn off wifi
Turn on airplane mode
Open settings
Developer options. If developer otions not shown find build number and tap it 7 times.
In developer options turn on USB debugging
Go to USB configuration
Select RNDIS
wait a few seconds an correct a/c sreen appears.
This sequence works 100%  for me
2018-6-21
Use props
stuka75
First Officer
Flight distance : 85682 ft
United States
Offline

Mickus Posted at 2018-6-21 00:07
To connect tab S2 to pro/a
Turn off wifi
Turn on airplane mode

Thanks. I wondered where that was.
2018-6-21
Use props
Bashy
Captain
Flight distance : 549140 ft
United Kingdom
Offline

Mickus Posted at 2018-6-21 00:07
To connect tab S2 to pro/a
Turn off wifi
Turn on airplane mode


Go to USB configuration
Select RNDIS


Thats interesting, i have never had to do this but then i put Android 6 both of my S2's
2018-6-21
Use props
Air/America
First Officer

United States
Offline

Mickus Posted at 2018-6-21 00:07
To connect tab S2 to pro/a
Turn off wifi
Turn on airplane mode

If I may impose and suggest in this order;

1.Turn on the Samsung Tab S2
2.Turn on the Remote Controller and DJI GO App
3.Turn on the Aircraft
4.Then go onto the tablet and follow Mickus suggestions.

the following is quoted from Mickus' post #8;

To connect tab S2 to pro/a
Turn off wifi
Turn on airplane mode
Open settings
Developer options. If developer otions not shown find build number and tap it 7 times.
In developer options turn on USB debugging
Go to USB configuration
Select RNDIS
wait a few seconds an correct a/c sreen appears.
This sequence works 100%  for me

Great informational Posting by Mickus on this Samsung Tab S2 USB port qwerk.

2018-6-23
Use props
Bashy
Captain
Flight distance : 549140 ft
United Kingdom
Offline

and i have never had to turn off wifi or turn on ap mode either, again, prob cause its on android 6
2018-6-23
Use props
Mickus
lvl.4
Flight distance : 601677 ft
Offline

Air/America Posted at 2018-6-23 09:44
If I may impose and suggest in this order;

1.Turn on the Samsung Tab S2

Thanks but the workaround is not mine. I foundit on this site some months ago, forget who it was but from a frenchman I believe.
2018-6-24
Use props
Air/America
First Officer

United States
Offline

Bashy Posted at 2018-6-23 20:07
and i have never had to turn off wifi or turn on ap mode either, again, prob cause its on android 6

You are probably right about the Android 6. When I first got the Sansumg Tab S2 out of the box, it may have been the Android 6.0.1 (Marshmallow) OS. It seemed like it worked well. Later on, "it upgraded" to the 7.0 (Nougat) OS. After the "upgrade" it seemed like I had to pull out the USB cable and then plug it back in to connect the tablet and RC together?

2018-6-24
Use props
Air/America
First Officer

United States
Offline

Mickus Posted at 2018-6-24 02:25
Thanks but the workaround is not mine. I foundit on this site some months ago, forget who it was but from a frenchman I believe.

Ah, yes. Who invented the wheel? Now we all ride.

2018-6-24
Use props
djiuser_bBVoTTNbj8Wa
lvl.1
Offline

Mickus Posted at 2018-6-21 00:07
To connect tab S2 to pro/a
Turn off wifi
Turn on airplane mode

Fantastic! That works! Thank you!

Only problem is that I have to do it every time I start the controller or the tablet.

Don't know if this is an issue, but I don't get "correct a/c screen".

My S2 has Android 7 on it.
2018-6-29
Use props
Propell2
lvl.1
Flight distance : 111601 ft

Sweden
Offline

this is also a solution on phantom 4 ? tab s2 is giving me a headace
will not conect
2018-7-16
Use props
djiuser_zQZaVoUS4O2d
New

Netherlands
Offline

I have a problem with the connection of my drone.., it always switch to ATTI MODE and always says MOTOR OVER LOAD but when I use my friends phone it was fine and great.., it could be my phone and could be settings. How can I resolve this??
2018-7-16
Use props
Propell2
lvl.1
Flight distance : 111601 ft

Sweden
Offline

Mickus Rules
2018-7-17
Use props
Tankertel
lvl.1

Offline

Air/America Posted at 2018-6-23 09:44
If I may impose and suggest in this order;

1.Turn on the Samsung Tab S2

Help! I have a Samsung Tab S2 running Android 7, I have tried this and it does not work for me, does anybody have any more work rounds?
9-18 02:37
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules