Please select Into the mobile phone version | Continue to access the computer ver.
Motors not starting up! *HELP*
246 1 2018-6-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
fansab0c8407
New
Offline

I have had my original Osmo 4K for nearly 2 years now and it was working perfectly for most of the time!

The Osmo will start and connect to my iPhone and show the image from the camera, and the lights will come on from the handle. The problem is with the motors they don't start up and get the gimbal to sit right, it just sits limp. When you double click the trigger to centre it the whole thing shuts down and re-starts and continues to stay limp. I have seen many posts about similar problems and people relate it to an update that was put in a few months back and they have un installed it and gone to a previous firmware and this has worked, i tried this but i wouldn't let me go back on my updates. Obviously i know i can contact DJI Repair and they can have a look for me but i am from the UK and the time it will take to send and them to review it just to tell me that i have to pay to get it fixed seemed a bit silly if i can find another way to do it myself or find anyone who had similar problems.


I feel like i may try and sell it for spares and purchase the new DJI Osmo Mobile 2 as i will make more use out of it, does anyone know of a good place to sell it for spares or even a way of DJI buying it back and exchanging it for the Osmo Mobile 2 as it does cost a lot less than my Osmo.

Thanks for any help

Andrew
2018-6-28
Use props
DJI Wanda
Administrator
Offline

Hello there. We apologize for the inconvenience. Can you give me a sample video showing the problem so that we can isolate the issue?
2018-6-28
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules