Please select Into the mobile phone version | Continue to access the computer ver.
DJI Assistant 2 for Phantom V2.02 Compatability
Uploading and Loding Picture ...(0/1)
o(^-^)o
bjr981s
First Officer
Flight distance : 110154 ft
  • >>>
Australia
Offline

Hi,

Can anyone advise if they have updated their Assistant 2 to the latest release 2.02 and used it on Sparks, Mavic Air and Mavic pro? ( and Goggles)

I got badly bitten by the first Assistant 2 update for the Mavic Air that bricked my Sparks.

Spark, Mavic Pro and Air still show the earlier months version and not the 2.02 version. But you can have only one.

I need a consistent Assistant 2 version for all my Drone models. Do I upgrade to Assistant 2.02 or not?

Any advice please.


2018-7-17
Use props
DJI Natalia
Administrator

Offline

Hi there. Thanks for reaching out DJI Forum. I do apologize but the DJI Assistant 2 for Phantom V2.02 is only compatible with other Phantom 4 series such as Phantom 4, Phantom 4 Pro, and Phantom 4 Advanced. If you have other concern, please let us know. Thank you.
2018-7-17
Use props
bjr981s
First Officer
Flight distance : 110154 ft
  • >>>
Australia
Offline

DJI Natalia Posted at 2018-7-17 07:40
Hi there. Thanks for reaching out DJI Forum. I do apologize but the DJI Assistant 2 for Phantom V2.02 is only compatible with other Phantom 4 series such as Phantom 4, Phantom 4 Pro, and Phantom 4 Advanced. If you have other concern, please let us know. Thank you.

That means I need to buy 5 Macs and have different versions of Assistant 2 on them?

Can you  please check with your technical support staff as this makes no sense.

Cheers Brian
2018-7-20
Use props
DJI Natalia
Administrator

Offline

bjr981s Posted at 2018-7-20 07:44
That means I need to buy 5 Macs and have different versions of Assistant 2 on them?

Can you  please check with your technical support staff as this makes no sense.

No. You don't need to purchase another Macbook to download the DJI Assistant 2. All you have to do is to download the firmware of the DJI Assistant 2 of Phantom 4 Pro V2 on your Macbook and download the DJI Assistant 2 that is compatible to your other drone at the same time. It's just that you have two DJI Assistant 2 but the other one is only compatible with the Phantom 4 series.
2018-7-20
Use props
bjr981s
First Officer
Flight distance : 110154 ft
  • >>>
Australia
Offline

DJI Natalia Posted at 2018-7-20 07:58
No. You don't need to purchase another Macbook to download the DJI Assistant 2. All you have to do is to download the firmware of the DJI Assistant 2 of Phantom 4 Pro V2 on your Macbook and download the DJI Assistant 2 that is compatible to your other drone at the same time. It's just that you have two DJI Assistant 2 but the other one is only compatible with the Phantom 4 series.

Sorry that does not work. The DJI Install package .DMG overwrites the current Assistant version. There is no way to change that, that I am aware of?

You can only have one version on a Mac.
2018-7-20
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules