Please select Into the mobile phone version | Continue to access the computer ver.
Battery Charging Issue
428 3 2018-7-31
Uploading and Loding Picture ...(0/1)
o(^-^)o
alpbird
lvl.4
Flight distance : 779281 ft
Turkey
Offline

Hello,
I experienced a very strange situation with one of my MA batteries yesterday. I flew in the late afternoon, everything was normal, and I landed with 23% of battery charge. It was a hot day, around 32 degree C. I put the battery in its case and travelled around 10 kms. I arrived at home and I noticed that the battery was still a little too hot to be charged. I waited 8-10 minutes to bring the battery to the room temperature and I plugged it in the charging hub. Interestingly, the fourth green led was flashing. I got surprised since the fourth green led is the last one as you know.  

I waited a little longer to see if it will go back to the first led. It did not. I removed the battery from the charger and put it in the AC. It was still 23%. I removed the battery from the AC and plug it in again the charging hub. It started to get charged as normally as it does before.

Have you experienced such an issue with your batteries. What might be the reason why the battery did not get charged and the fourth led flashed in my first attemp?

Thank you for your valuable feedback.




2018-7-31
Use props
alpbird
lvl.4
Flight distance : 779281 ft
Turkey
Offline

Any replies
2018-8-1
Use props
Henrijs
Second Officer
Flight distance : 4517064 ft
United States
Offline

The fourth led is flashing, when the battery temperature is to hight for charging. I experienced that issue when i put my batteries to charging hub strait after flying. It take some time to start charge. No wories.
2018-8-1
Use props
alpbird
lvl.4
Flight distance : 779281 ft
Turkey
Offline

Thank you very much Henrijs
2018-8-1
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules