Please select Into the mobile phone version | Continue to access the computer ver.
Warning for Andriod v1.0.10 users
1204 6 2015-5-25
Uploading and Loding Picture ...(0/1)
o(^-^)o
jaapotto
lvl.3

Netherlands
Offline

As I just found out:

The app version in the playstore (v1.0.10) is old. The app states it does not need to be updated.
However on this site there is a newer version (v1.1.0)

When you start the app (the one from the playstore v1.0.10) and see the "Aircraft Status" window at the top it says "Overall Status".
Do not trust this information because it does not seem to be actually checking the installed firmware/software versions of the Phantom, controller and app.

In my case it showed as "software is latest" with a green light. However after installing DJI Pilot app version 1.1.0 it suddenly states "updates required".

Also with the new app version (v1.1.0) it showed me I am on v1.1.5 (If this the controller or Phantom firmware version I do not know as it does not say. But im sure I have upgraded my Phantom to v1.1.9, so it must be the controller).

I am now in the position where I can't upgrade my controller because I need (I think) a previous version of the controller firmware before I can install the latest (v1.1.9). This is also stated in the release notes this may happen (not only for v1.1.9):

"Users are advised to update the firmware version to v1.1.9, otherwise future firmware will not be able to install."

However older software versions I can not find on the site.....

Any advice from DJI on this?  
2015-5-25
Use props
gil
Captain
Flight distance : 1379308 ft
United States
Offline

As I mentioned in your duplicate post, all the releases have that notice included in the notes.  Check the "About" section of your DJI Pilot App and see what it shows.


2015-5-25
Use props
jaapotto
lvl.3

Netherlands
Offline

gil Posted at 2015-5-25 23:11
As I mentioned in your duplicate post, all the releases have that notice included in the notes.  Che ...

And as I mentioned in those duplicate posts....it does not say the the firmware version when I had Andriod 1.0.10 . it simply said "N/A"
2015-5-25
Use props
Adamation
lvl.3

United States
Offline

jaapotto Posted at 2015-5-25 23:42
And as I mentioned in those duplicate posts....it does not say the the firmware version when I had ...

You could have just continued this discussion in this thread http://forum.dji.com/thread-16027-1-1.html to try keep fragmentation of information to a minimum - Adam
2015-5-25
Use props
MikeAngelo
lvl.3

United States
Offline

I only download my firmware directly from dji.com.   I would highly recommend you do the same.
2015-5-25
Use props
jaapotto
lvl.3

Netherlands
Offline

Adamation Posted at 2015-5-25 23:48
You could have just continued this discussion in this thread http://forum.dji.com/thread-16027-1-1 ...

Fair enough, apolagies.

I started my own thread cause I did not get a reply to my question by DJI and did not want to hijack someone elses thread for it.
2015-5-25
Use props
jaapotto
lvl.3

Netherlands
Offline

gil Posted at 2015-5-25 23:11
As I mentioned in your duplicate post, all the releases have that notice included in the notes.  Che ...


You asked in another thread:

"What does it say in the "About" section of your DJI Pilot App?"

At this moment it says:

App version: 1.1.0
Firmware: 1.1.5

I am 100% sure my Phantom is on version 1.1.9 as it did the update succesfull and I checked the .txt file to confirm that. So I think it's my controller that is on 1.1.5

(Both the controller and Phantom were turned on and were connected at that time.)
2015-5-25
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules