Please select Into the mobile phone version | Continue to access the computer ver.
Motors Not Engaging[Solved]
1065 3 2018-8-14
Uploading and Loding Picture ...(0/1)
o(^-^)o
Hey everyone,

So I just received my Ronin S and was able to set it up and balance it but then I turned it on after the battery was fully charged and nothing is happening.
The grip is powered on and the top part is powered up as well. There is a blinking green light on in the mode 1 position. I have no clue what this means.
(I'm not sure if this is related to this issue but there is a blinking red light on as well from the Focus Wheel too.)

I updated the firmware and I made sure I set it up correctly but it's still not activating. I tried to connect with the mobile app and it wont find the Ronin S at all.

Any help would be ace.

Thank you in advance!
2018-8-14
Use props
StianGel
Captain
Flight distance : 686654 ft
Norway
Offline

You need to activate the Ronin with ther phone.
If you are using a android phone you should try to have location services (GPS) turned on.
2018-8-14
Use props
StianGel Posted at 2018-8-14 17:41
You need to activate the Ronin with ther phone.
If you are using a android phone you should try to have location services (GPS) turned on.

StianGel, thank you for the quick response.
I tried what you suggested and it worked with a newer phone.
2018-8-14
Use props
DJI Susan
Administrator

Offline

Garzonps05@gmail.com Posted at 2018-8-14 18:46
StianGel, thank you for the quick response.
I tried what you suggested and it worked with a newer phone.

Hi Garzonps05, thanks for keeping us updated. Glad to hear it works now. Should there is any further question, feel free to contact us.
BTW, the issue has been figured out, I'll edit the title as solved to avoid further confusion, thanks for your understanding.
2018-8-15
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules