Please select Into the mobile phone version | Continue to access the computer ver.
MP: Which firmware - DJI Go combo (android)?
451 10 2018-8-17
Uploading and Loding Picture ...(0/1)
o(^-^)o
Lambie
lvl.3

Netherlands
Offline

Hi all!
With an upcoming holiday, I'd really like to be able to fly my Mavic Pro using my Sony Xperia Z5c without problems. But after having read a lot about DJI screwing up MP-firmware and DJI Go versions lately, I was wondering what you think is the best firmware-DJI Go combo at the moment?
Regards, Lambie

2018-8-17
Use props
DH_Pilot
Captain
Flight distance : 3301621 ft
  • >>>
Slovakia
Offline

MP or MPP? I have good experience with MPP on 01.04.000 + DJI GO 4.2.16, recently upgraded to 01.04.0400 but had some issues with compass so downgraded to 01.04.0100 and it is fine since then. Also read on forums that 01.04.0100 is most stable since security changes which are preventing you rollback.

For MP I was using 01.03.0700 in past + DJI GO 4.1.5 absolutely without issues.
2018-8-17
Use props
DJI Gamora
Administrator

Offline

Hi, thanks for reaching DJI Forum. We do apologize for having problems with your DJI Mavic Pro. Unfortunately, the Sony Xperia Z5c is not a fully compatible phone to run the app. I will be posting some of the supported phones below for your reference. Thank you.

mavic pro.PNG
2018-8-17
Use props
msinger
Captain
Flight distance : 183694 ft
  • >>>
United States
Offline

Does all work well for you right now? If so, then maybe keep everything as-is until you get back from the holiday and have sufficient time to install and test the latest updates.
2018-8-17
Use props
Aardvark
Captain
Flight distance : 384432 ft
  • >>>
Offline

I would agree with msinger, if what you have at the moment works then stick with that until after holiday when you will have time to play with any updates. The firmware can be rolled back to v01.04.0100 (Panoramic mode introduced) if needed from V01.04.0400.

My MP is fully up to date with no problems that I've noticed as yet, I also use iOS devices that seem to work OK with latest DJI Go 4.
2018-8-17
Use props
Merced69
lvl.4
Flight distance : 327096 ft
Canada
Offline

I am using app version 4.2.16 as it is working best on my older phone, while I am current on my new phone.  4.2.20 would crash often on my older phone.
2018-8-17
Use props
DJI Natalia
Administrator

Offline

Merced69 Posted at 2018-8-17 05:59
I am using app version 4.2.16 as it is working best on my older phone, while I am current on my new phone.  4.2.20 would crash often on my older phone.

Hello there, I do apologize for the inconvenience. I would like to clarify, may I know what's the make and model of the device you are currently using?
2018-8-17
Use props
Lambie
lvl.3

Netherlands
Offline

Okay, thanks for your replies. So I guess I'll stay with FW v01.04.0100, and roll back to DJI GO 4.2.16!
2018-8-18
Use props
Brad Bilger
Captain
Flight distance : 12317766 ft
Offline

Aardvark Posted at 2018-8-17 05:43
I would agree with msinger, if what you have at the moment works then stick with that until after holiday when you will have time to play with any updates. The firmware can be rolled back to v01.04.0100 (Panoramic mode introduced) if needed from V01.04.0400.

My MP is fully up to date with no problems that I've noticed as yet, I also use iOS devices that seem to work OK with latest DJI Go 4.

And I'll add to that one.  I am fully up to date on Firmware and App version on Android and I've never had a problem.  Works ok for me.  
2018-8-18
Use props
Merced69
lvl.4
Flight distance : 327096 ft
Canada
Offline

DJI Natalia Posted at 2018-8-17 14:24
Hello there, I do apologize for the inconvenience. I would like to clarify, may I know what's the make and model of the device you are currently using right now?

My old phone is a Note 4, and it kept crashing on the .20 app, multiple times per flight, so it wasn't usable at all.  I am sure processing power does have something to do with it, but last I checked, it was on the compatible list.

My current phone is a Note 8, and it was running .20 much better.

I fly almost always with my older phone, so I can completely dedicate it to flying, while leaving my current phone, for phone stuff.
2018-8-21
Use props
DJI Natalia
Administrator

Offline

Merced69 Posted at 2018-8-21 07:38
My old phone is a Note 4, and it kept crashing on the .20 app, multiple times per flight, so it wasn't usable at all.  I am sure processing power does have something to do with it, but last I checked, it was on the compatible list.

My current phone is a Note 8, and it was running .20 much better.

Hi, thanks for your reply. May I know if the operating system of your Samsung Note 4 is updated to the latest version?
2018-8-21
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules