Please select Into the mobile phone version | Continue to access the computer ver.
Mavic 2 is compatible with DJI Goggles series!
12345Next >
6179 190 8-31 03:09
Uploading and Loding Picture ...(0/1)
o(^-^)o
DJI Forum admin
Administrator
China
Offline

Is the Mavic 2 compatible with DJI Goggles series?

Yes. The Mavic 2 is compatible with DJI Goggles (firmware version 01.04.0500 or above) and DJI Goggles RE (firmware version 01.00.0600 or above). Please first activate DJI Goggles or DJI Goggles RE and update their firmware to the latest one on your computer using DJI Assistant 2. Power on DJI Goggles or DJI Goggles RE, choose Linking in Settings, then choose Mavic 2. Press the link button on the Mavic 2 and wait for a few seconds to connect DJI Goggles or DJI Goggles RE to the aircraft. DJI Goggles only support the 2.4 GHz signal frequency, while DJI Goggles RE support 2.4/5.8GHz dual signal frequency for more powerful performance.
  

  
* To download the version of DJI Assistant 2 that is compatible with DJI Goggles RE, please visit https://www.dji.com/dji-goggles-re/info#downloads.
* To download the version of DJI Assistant 2 that is compatible with DJI Goggles, please visit: https://www.dji.com/dji-goggles/info#downloads.

8-31 03:09
Use props
Ulysses Paiva
Second Officer
Flight distance : 152030
Offline

Its not showing in the DJI Assistant
8-31 03:37
Use props
Thriller
Second Officer
Flight distance : 92343
Italy
Offline

Good news... I am thinking to buy them.
8-31 04:26
Use props
Rblomqvist
Second Officer
Flight distance : 171228
United States
Offline

Ulysses Paiva Posted at 2018-8-31 03:37
Its not showing in the DJI Assistant

You need the 1.2.4 DJI Assistant. Mavic will use 2.0.0, so you need both versions installed.
8-31 06:00
Use props
DennisMurry08
First Officer
Flight distance : 895015
  • >>>
Offline

Not sure I understand this...your saying both downloads are for the RE....????
8-31 06:18
Use props
mberry72
lvl.2
Flight distance : 38662
United States
Offline

I can't seem to get the RE googles to work more than a couple of blocks with current firmware and I get video signal loss every time.     When I call DJI I get mixed messages.  Some tell me the firmware isn't out.  Others tell me that it's a known issue and to wait for a update.  Others don't seem to have a clue.

Any one else having these issue?  I within my return window and if these aren't going to work they need to go back.
8-31 07:14
Use props
Nelsonlee
First Officer
Flight distance : 549854
  • >>>
Offline

I didn't see there have newest firmware for my DJI Goggles!



8-31 08:05
Use props
Gadget Guy
lvl.4
  • >>>
United States
Offline

I updated my RE googles last night with Assistant (not Phantom/Mavic version) and they updated.  I linked them today to Mavic 2 zoom and they worked well.  

Suggestion for DGI - Bundle the sub versions of  Assistant2, Mavic, Phantom, together into a top level menu start screen selection.   Just a thought!
8-31 08:07
Use props
DennisMurry08
First Officer
Flight distance : 895015
  • >>>
Offline

Umm...I see the Standard Goggles in Assistant 1.2.4....they do not show in Assistant 2.0. In Assistant 1.2.4 it says the Goggle version is 1.04.04. There is NOT an option to upgrade to V 1.04.0500. I uninstalled both assistants and reinstalled...same thing. Sooo did DJI pull the update for the Standard?
8-31 08:37
Use props
Ulysses Paiva
Second Officer
Flight distance : 152030
Offline

Rblomqvist Posted at 2018-8-31 06:00
You need the 1.2.4 DJI Assistant. Mavic will use 2.0.0, so you need both versions installed.

I am on 1.2.4 and as other have said above, its not showing any fw newer than .400
8-31 09:09
Use props
Sennastien
lvl.1
Flight distance : 15507
France
Offline

Hi,
Same here, form DJI Assistant 1.2.4, I can only see firmware v1.04.0400

Thus, not working with my Mavic 2 Zoom (no pairing capable)
8-31 10:36
Use props
Glenn Goodlett
Second Officer
Flight distance : 6667017
  • >>>
Offline

mberry72 Posted at 2018-8-31 07:14
I can't seem to get the RE googles to work more than a couple of blocks with current firmware and I get video signal loss every time.     When I call DJI I get mixed messages.  Some tell me the firmware isn't out.  Others tell me that it's a known issue and to wait for a update.  Others don't seem to have a clue.

Any one else having these issue?  I within my return window and if these aren't going to work they need to go back.

I get exactly the same. Everything is updated and goggles RE is on .0600.
8-31 10:36
Use props
mberry72
lvl.2
Flight distance : 38662
United States
Offline

Glenn Goodlett Posted at 2018-8-31 10:36
I get exactly the same. Everything is updated and goggles RE is on .0600.

Thanks for replying.  Glad to know I'm not alone.
8-31 10:57
Use props
Glenn Goodlett
Second Officer
Flight distance : 6667017
  • >>>
Offline

I just discovered the Mavic 2 works much better with the goggles RE if you have an antenna screwed in. Still not perfect but much better. I can get a mile of range now.
8-31 13:11
Use props
John Hennesey
lvl.2
Flight distance : 153237
United States
Offline

Just upgraded the firmware in the goggles, transmitter and mavic 2.  Goggles work - hooray!  Range went from ~1,500 feet down to 300.  Thank goodness for return to home!

You guys aren't alone.   Please DJI, fix 'em on up.  My son and I are so excited about our new toy!
8-31 14:42
Use props
djiuser_tX9EOW9wxm61
lvl.2
United States
Offline

Firmware 01.04.0500 isn’t showing up in DJI Assistant 2. Is there something users can do to get the new firmware pushed to their accounts?
8-31 15:25
Use props
djiuser_tX9EOW9wxm61
lvl.2
United States
Offline

DJI’s website says the firmware update will come by the end of August. Well, here we are August 31.
8-31 15:29
Use props
John Hennesey
lvl.2
Flight distance : 153237
United States
Offline

djiuser_tX9EOW9wxm61 Posted at 2018-8-31 15:29
DJI’s website says the firmware update will come by the end of August. Well, here we are August 31.

DJI assistant 2 - it showed up on my screen without issue.  BUT, be warned...  we figured out why the reception went from 1,500 ft to 300 ft...  the goggles.  When they are on and I am 5 feet away from my son while he flies it - the range is poor.  We turned off the goggles and the range was better with the upgraded firmware.

Kind of a bummer if you want to fly and goggle at the same time.
8-31 16:10
Use props
HFI
Second Officer
Flight distance : 248808
Offline

Nelsonlee Posted at 2018-8-31 08:05
I didn't see there have newest firmware for my DJI Goggles!

[view_image]

Same here
9-1 00:28
Use props
Dirty Bird
Captain
Flight distance : 1433611
  • >>>
United States
Offline

DennisMurry08 Posted at 2018-8-31 06:18
Not sure I understand this...your saying both downloads are for the RE....????

It is the same Assistant software (v1.2.4) for both.   The links take you to the respective product support page.

I am not seeing the standard goggle update being available yet either.

9-1 01:13
Use props
DennisMurry08
First Officer
Flight distance : 895015
  • >>>
Offline

Dirty Bird Posted at 2018-9-1 01:13
It is the same Assistant software (v1.2.4) for both.   The links take you to the respective product support page.

I am not seeing the standard goggle update being available yet either.

Yea I know...was trying to figure out why both links take you to the same goggles...I.e. the RE....just stupid me thinking one link would have been RE and the other the STD since the headline made it sound like both updates were available..especially going into a 3 Day weekend.....but oh well.... I’m going to try not thinking, maybe that will work....
9-1 07:08
Use props
RAONE
lvl.2
Offline

Same here
9-1 07:42
Use props
RAONE
lvl.2
Offline

wow that's great
9-1 07:52
Use props
RichJ53
Captain
Flight distance : 404365
  • >>>
United States
Offline

DennisMurry08 Posted at 2018-8-31 08:37
Umm...I see the Standard Goggles in Assistant 1.2.4....they do not show in Assistant 2.0. In Assistant 1.2.4 it says the Goggle version is 1.04.04. There is NOT an option to upgrade to V 1.04.0500. I uninstalled both assistants and reinstalled...same thing. Sooo did DJI pull the update for the Standard?

I already updated my standard goggles and did not get a screen shot.. My RE version of the goggles also worked fine



Make sure you download the DJI Assistant 2 software link v 1.2.4 that is located on the goggles RE page. This will insure you have the correct one screenshots to show the FW list

Rich

Link for version 1.2.4





Capture 1.JPG Capture 2.JPG


9-1 09:59
Use props
Lucskywlkr 8
lvl.1
Flight distance : 18516
United States
Offline

Nothing new showing here on the goggles and they won’t link with 0400
9-1 11:08
Use props
DennisMurry08
First Officer
Flight distance : 895015
  • >>>
Offline

RichJ53 Posted at 2018-9-1 09:59
I already updated my standard goggles and did not get a screen shot.. My RE version of the goggles also worked fine

Yea..RE is fine...Standard doesn’t have the update yet...
9-1 12:57
Use props
fans9af54f79
lvl.2
  • >>>
Offline

For the white goggles, the firmware to work with Mavic 2 has NOT been released yet.

SHAME on the DJI admin and comms team for spreading this information and wasting a lot of people’s time trying to get a product to work that currently is impossible.
9-1 14:13
Use props
RichJ53
Captain
Flight distance : 404365
  • >>>
United States
Offline

DennisMurry08 Posted at 2018-9-1 12:57
Yea..RE is fine...Standard doesn’t have the update yet...

I actually  updated my std. Goggles to version .500 but I cannot share a screenshot because I sold them.  I even connected the goggles to my Mavic 2 Pro before letting the go.

I am not sure why you are not getting the FW listed. Please try connecting your goggles to the assistant 2 for Mavic series. I bet it works:  DJI+Assistant+2+For+Mavic+2.0.0.zip

https://www.dji.com/mavic-2/info#downloads

Rich



9-1 14:47
Use props
RichJ53
Captain
Flight distance : 404365
  • >>>
United States
Offline

fans9af54f79 Posted at 2018-9-1 14:13
For the white goggles, the firmware to work with Mavic 2 has NOT been released yet.

SHAME on the DJI admin and comms team for spreading this information and wasting a lot of people’s time trying to get a product to work that currently is impossible.

It is released. Please see my info in post #28 and see if you can get this to work

Rich
9-1 14:54
Use props
Jimmy Chu22
lvl.2
United States
Offline

fans9af54f79 Posted at 2018-9-1 14:13
For the white goggles, the firmware to work with Mavic 2 has NOT been released yet.

SHAME on the DJI admin and comms team for spreading this information and wasting a lot of people’s time trying to get a product to work that currently is impossible.

Perhaps its shame on you for not reading user posts.  Is this first DJI product?  Android issues will be fixed in late 2017, don't you know.  They are doing theyre job, and the company is making boucoup dollars.  cry elsewhere..

God Bress,

Jimmy
9-1 16:39
Use props
Jimmy Chu22
lvl.2
United States
Offline

I got new drone and racing goggles work very good with external antenna installed, and a couple hours updating firmware and settings.   Too easy.
9-1 16:40
Use props
RAONE
lvl.2
Offline

yeah...I also tried, its not showing in the DJI assistant
9-1 17:56
Use props
zorz
lvl.1
United States
Offline

RichJ53 Posted at 2018-9-1 09:59
I already updated my standard goggles and did not get a screen shot.. My RE version of the goggles also worked fine

It looks like your results are not consistent for all of us. I’ve tested it downloading, re-downloading and even downloading 1.2.4 from different pages (including the one you linked) and I still only see 0400 as the most recent.
9-1 18:29
Use props
DennisMurry08
First Officer
Flight distance : 895015
  • >>>
Offline

RichJ53 Posted at 2018-9-1 14:54
It is released. Please see my info in post #28 and see if you can get this to work

Rich

Only those with RE have been able to update to the supported RE version. Those of us who have tried to update the Standard version can't get V.0500 because its not an option in Assistant 2 nor Assistant 2 for Mavic....and unistalling/reinstalling hasn't worked either....Curious when you updated because if it was available it was only for a short time.....?
9-1 19:53
Use props
RichJ53
Captain
Flight distance : 404365
  • >>>
United States
Offline

DennisMurry08 Posted at 2018-9-1 19:53
Only those with RE have been able to update to the supported RE version. Those of us who have tried to update the Standard version can't get V.0500 because its not an option in Assistant 2 nor Assistant 2 for Mavic....and unistalling/reinstalling hasn't worked either....Curious when you updated because if it was available it was only for a short time.....?

So sorry you cannot get the .500 FW update. I updated my goggles on Wednesday  Aug 29 and should be getting together with my friend that picked up my old goggles tomorrow.  If he can lone them back to me for a day, I will take the screenshot of the FW for you.

Hope this is resolved soon.

Rich
9-1 20:26
Use props
RichJ53
Captain
Flight distance : 404365
  • >>>
United States
Offline

zorz Posted at 2018-9-1 18:29
It looks like your results are not consistent for all of us. I’ve tested it downloading, re-downloading and even downloading 1.2.4 from different pages (including the one you linked) and I still only see 0400 as the most recent.

Sorry, I do not understand why this is happening. Hope DJI gets this resolved very soon

Hang in there

Rich
9-1 20:27
Use props
DennisMurry08
First Officer
Flight distance : 895015
  • >>>
Offline

RichJ53 Posted at 2018-9-1 20:26
So sorry you cannot get the .500 FW update. I updated my goggles on Wednesday  Aug 29 and should be getting together with my friend that picked up my old goggles tomorrow.  If he can lone them back to me for a day, I will take the screenshot of the FW for you.

Hope this is resolved soon.

Well...that would be interesting...cause the published update was yesterday the 31st...so maybe it was available prior...which would be a bummer.....
9-1 20:29
Use props
RichJ53
Captain
Flight distance : 404365
  • >>>
United States
Offline

DennisMurry08 Posted at 2018-9-1 20:29
Well...that would be interesting...cause the published update was yesterday the 31st...so maybe it was available prior...which would be a bummer.....


actually DJI Susan posted the FW   on Aug 28  see the post #48
linked

Rich

https://forum.dji.com/thread-163058-2-1.html

9-1 21:16
Use props
DennisMurry08
First Officer
Flight distance : 895015
  • >>>
Offline

RichJ53 Posted at 2018-9-1 21:16
actually DJI Susan posted the FW   on Aug 28  see the post #48
linked

There’s confusion..you’ve been talking about RE goggles, that’s .0600 and yes it will update...the Standard goggles, white, need .0500 which is not out yet...Susan says that in page 2 of your link...soo who knows, maybe it was available then pulled ..it is DJI after all....
9-1 21:33
Use props
RichJ53
Captain
Flight distance : 404365
  • >>>
United States
Offline

DennisMurry08 Posted at 2018-9-1 21:33
There’s confusion..you’ve been talking about RE goggles, that’s .0600 and yes it will update...the Standard goggles, white, need .0500 which is not out yet...Susan says that in page 2 of your link...soo who knows, maybe it was available then pulled ..it is DJI after all....

I am sorry for the confusion and do not want to add anymore. I will post my findings tomorrow after looking at my old goggles.

Once I know want is going on, I will report back to everyone.

Again sorry in advance for making this a possible messy situation

Rich
9-1 21:46
Use props
12345Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules