Please select Into the mobile phone version | Continue to access the computer ver.
P3Pro Remote Controller not updating
1577 5 2015-5-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
djricaric
lvl.2

United States
Offline

What's going on everyone!

I'm new to the forum and needed a little help.  I just received the P3Pro last night.  I was able to download the new firmware upgrade, 1.1.9, I think it was.... but was able to successfully upgrade the Drone, but not the controller.  When I put the Micro SD along with a reader into the controller and turn it on, the LED just stays red.  No turn to blue.  I waited a full 10 minutes before turning off the controller and trying again, but still nothing.

I went ahead and connected it by a cable to the drone with the Micro SD inserted into the camera, but it never took the update and the controller LED went straight to Green.  

Then connecting it to the app, it says that the latest firmware is installed.  Should I worry about this or is it really installed?  The only .txt I saw was from the Drone updated communicating "Success".  Let me know if you can help!! Thank you so much and very much excited to be a part of the Phantom Community!

Have a great weekend!
-Mo
2015-5-29
Use props
JtrJr-Droner
Captain
Flight distance : 4341 ft
United States
Offline

Djr,

There is no new update for the controller, just the 1.1.9 for the bird. If you got the txt file with "succeeded" in it, you should be good to go. Delete the txt file from the SD card and restart from scratch. reinsert the SD card with the txt file removed, Pull the battery, reinsert it, turn the RC on, turn the bird on and see what happens. You should be good to fly. Report back if a no go.

Jerry
2015-5-29
Use props
djricaric
lvl.2

United States
Offline

JtrJr-Droner Posted at 2015-5-30 00:33
Djr,

There is no new update for the controller, just the 1.1.9 for the bird. If you got the txt fil ...

You sir, CORRECT!!

Got the P3Pro up in the air tonight... loved every minute of it!!  Now to figure out this Jello Effect. It's baaaaad! Thank you so much!

If you have any ideas on how to fix the effect, I'm all ears!
2015-5-29
Use props
Total
First Officer
Flight distance : 336480 ft
Canada
Offline

Did you make sure to remove the white foam piece from behind the camera ?  
2015-5-29
Use props
djricaric
lvl.2

United States
Offline

Total Posted at 2015-5-30 11:29
Did you make sure to remove the white foam piece from behind the camera ?

Yeah, I was reading some other threads.  The foam white piece is gone.  Seems pretty bad when decending more than anything else.
2015-5-29
Use props
JtrJr-Droner
Captain
Flight distance : 4341 ft
United States
Offline

djricaric Posted at 2015-5-30 11:26
You sir, CORRECT!!

Got the P3Pro up in the air tonight... loved every minute of it!!  Now to figu ...

Djr,

I think it's all in the camera settings. There are quite a few posts on it in this forum. I'm not even an amateur when it comes to this stuff so I'm not comfortable telling you how to fix it. I do know I had similar issues at first but after f'ng with the settings quite a bit I got rid of it. Read some of the other threads but in the meantime, if you're in a hurry to see if it's a problem, set the camera to auto at 1080 or 720 even just to see the difference.

Jerry
2015-5-29
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules