Please select Into the mobile phone version | Continue to access the computer ver.
Trouble connecting Osmo DJIGO with Android
485 6 1-5 15:28
Uploading and Loding Picture ...(0/1)
o(^-^)o
oscarhmeza
lvl.1

United States
Offline

I just bought a second hand OSMO in working condition, but I am having trouble to connect it to my Android phone (Google Pixel 3 XL).

I downloaded and installed DJI GO for Products before P4. After turnning on the gimbal and connecting wifi to the osmo_xxxxx wifi connection, and lauching the app, by default it's connecting me to an Inspire 1 drone. I don't see any option to change equipment, nor I understand why it connects my device as a drone and not a camera. BTW, I don't own or have used a drone with my phone.

Am I using the wrong app?
1-5 15:28
Use props
DJI Gamora
Super Moderator

Offline

Hi there, thank you for reaching out and we're sorry to hear about the trouble, with regards to that may I ask have you try to swipe left/right when you are on the homepage of the App and try to look for the Osmo.
1-5 15:57
Use props
oscarhmeza
lvl.1

United States
Offline

DJI Gamora Posted at 1-5 15:57
Hi there, thank you for reaching out and we're sorry to hear about the trouble, with regards to that may I ask have you try to swipe left/right when you are on the homepage of the App and try to look for the Osmo.

I can't swipe in any direction. See attached picture.
Screenshot_20190105-161221.png
1-5 16:18
Use props
Jhon turner
lvl.1
Panama
Offline


The same thing happens to me and my equipment is absolutely new. I only use it twice and I do not know what to do. It happens to me exactly. I think it was an update of the same application. I do not know what to do, please.
1-22 02:20
Use props
adcom
lvl.2
Italy
Offline

Hi, everyone, I have the same trouble. But no one have a solution?
1-31 09:48
Use props
djiuser_cAIcWgxRLL3Z
lvl.1

Portugal
Offline

Hi there,
I found a simple solution for that problem (that i was also facing with Android 9)
Just put your Android Phone into Airplane Mode then, turn on wifi and connect to you Osmo.
Next, open your DJI Go App and... voilá...

It worked for me
2-12 08:36
Use props
DJI Tony
Super Moderator

Offline

adcom Posted at 1-31 09:48
Hi, everyone, I have the same trouble. But no one have a solution?

Hi, thanks for the inquiry. May we know what is the model of your device? Are you running Android 9 as well? Please provide the current firmware and the application version for further assistance. Thank you for continued support.
2-12 16:37
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules