Please select Into the mobile phone version | Continue to access the computer ver.
Mavic 2 zoom won't update
629 0 2019-1-13
Uploading and Loding Picture ...(0/1)
United States

Hi, I am new here and purchased a Mavic 2 zoom. I unboxed and set up the DJI Go 4 app on iphone and DJI assistant 2 on Windows 10 computer. RC updated to newest firmware fine but AC keeps saying update failed at 20% on computer and 63% on phone. I have deleted and installed both apps many times and probably tried over 50 times with the same failure. On the computer it updates to 20% reboots a few times and then fails. I have also tried on a Macbook Pro with the same 20% failure, Windows 7 computer with same 20% fail, Ipad fail and Android phone and tablet just keeps saying network disconnected when it is connected. When I open the app up, it states no image transmission signal, Gimbal disconnected, Internal storage not found, also does not recognize SD card when I put it in. Not sure if this is caused by the firmware not updating or if there is a problem. Called DJI customer support and they could not really suggest anything other than the DJI assistant, just said file a report and send it in to take a look at. I have not even flown it and now have to send it in for what could take weeks to get back. Just wondering if anyone has any suggestions or experienced this problem and fixed?

Use props
You need to log in before you can reply Login | Register now

Credit Rules