Please select Into the mobile phone version | Continue to access the computer ver.
OSMO Pocket Wireless Module doesn't work with Android
123
13926 88 2019-1-18
Uploading and Loding Picture ...(0/1)
o(^-^)o
RSW
Second Officer
Flight distance : 116736 ft
United States
Offline

psitech Posted at 1-31 23:16
Another Pixel 3 XL user here.  As stated above, the only way I can get mine to work is Airplane mode and turn wifi on as djiuser_8KtvvEYJGrej posted.  I've wasted over 2 hours fighting with this thing.  I can't fathom that DJI wouldn't test with pixel 3's.  This is beyond frustrating.

I have a Pixel 3XL too. I just turn off Mobile Network and it works. Once Mobile Network is turned on again it fails to communicate. It's a minor inconvenience.
2019-6-4
Use props
djiuser_yCSqdOxiSANi
New

France
Offline

kmer Posted at 1-18 23:53
After testing a lot of different ways to have it work with my Moto Z2 Force I have finally found a solution. But improvements is needed from DJI.

1. Don't pair the wireless module over Blutooth (Remove it from the Bluetooth settings if already paired).

THANK YOU!
I was so frustrated with this issue, it being one day before our long anticipated 3 week trip around spain. Having to connect via usb would have been a dealbreaker for me, not knowing that the android app is simply dji's ugly stepchild, and obviously has been for months and months.
I would prefer Bluetooth over Wi-Fi, but prioritize a working product.
Are android users 2nd class citizens to DJi? I refuse to believe that a simple software issue is that hard to fix for one of the biggest tech companies around.
2019-6-14
Use props
Amor Schmidt
New

Japan
Offline

I hope this gets fixed soon I am having the same issue. I have a note 8. I dont want to have to go through a 10 step process just to use this function of the pocket. I will not get a new device just so I can use this function and I wish I knew this before purchasing. This makes me want to sell it and get a insta 360 instead
2019-7-12
Use props
Hirsti99
lvl.4
United Kingdom
Offline

Same problem with my Huawei Honor 8X

I fixed it by setting the OP to be 2.4Ghz then connected and all worked ok.
5.8 is not compatible.
2019-7-15
Use props
fans28d9273c
lvl.1

Offline

Johneem Posted at 1-31 07:03
HUAWEI P20 PRO

Open Settings menu on Osmo Pocket (swipe down)

Life saver it worked
2019-10-9
Use props
Stephanie1976
lvl.1
Flight distance : 55505 ft
France
Offline

Si je résume, pas de connectic micro USB, pas de possibilité de brancher mon tel sur le module WiFi que j'ai acheté 59€.... Que dois-je faire ? Dji nous donne un bon d'achat pour changer nos téléphones qui coûte un bras ?
2019-11-18
Use props
djiuser_BSZzT5vMVWLZ
lvl.1
United States
Offline

I'd love to have an osmo pocket. So much so that I bought one. My S8 plus would not connect via USB c. So me being stupid I bought another expensive wireless module. Still wouldn't connect. Unbelievable. A company like dji completely ignoring 50%+ of mobile phone users. I now have an amazing S10 Plus and I'm not wasting another second with dji
2019-12-13
Use props
djiuser_Zybd5zLnnAPQ
New

United States
Offline

Can anyone tell me, Samsung Galaxy S10 plus 5G is compatible with Osmo Pocket or not? I tried Note 10+ 5G and doesn't connect. Seems OP users must not use a 5G phone. So weird. Firstly it doesn't have a built in wireless and now the module isn't compatible with latest phones. The worst thing I'm scared off is getting wet in the rain ☔. Cause it's not water
1-1 22:13
Use props
djiuser_uxoOgJO5EX8F
New
Australia
Offline

Just reporting that it connected without any issues to my Samsung S10.
7-18 21:42
Use props
123
Advanced
You need to log in before you can reply Login | Register now

Credit Rules