Please select Into the mobile phone version | Continue to access the computer ver.
Spark - Can't switch to 2.4GHz
562 2 2-8 00:47
Uploading and Loding Picture ...(0/1)
o(^-^)o
de-Stefan
lvl.1
Germany
Offline

Hi,

my name is Stefan and i live and fly with my spark in germany. I have the problem, that i cant switch to 2.4GHz between spark and controller. I want to use it, to expand the range and to be CE-conform.
Thats my configuration:

Spark-Firmware.jpg
The DJI GO 4 app is the version: 4.3.12 and im using a Samsung Galaxy J6 (2018) Smartphone with Android 8.0.

You can see, that i have no rssi-bars on display:
Spark-No-Bars.jpg
and i can't switch the communication between spark and controller to 2.4GHz. Im also using a USB-OTG cable between controller and smartphone.


Can anyone help me? I want to fly on 2.4GHz.

Greetz Stefan from germany.


2-8 00:47
Use props
DJI Stephen
Super Moderator

Online

Hello and good day Stefan.  I am sorry to know that you are having issues with the mobile device that you are using on your DJI Spark.  Have you tried using a different mobile device for us to check if the issue still persist? Upon checking  the mobile device that you are using ( Samsung Galaxy J6 ). I am sorry to say that the mobile devices that you are using is still not recommended for your DJI Spark. Actually, there is a  possibility that the Samsung Galaxy J6 will work, however, since it's not yet optimized with the DJI Go 4 application we cannot guaranteed the stability of the DJI Go 4 application if this will work all the time while using the specific device.  We highly suggest you use the compatible device that was listed on the recommended mobile device list below to avoid any problem. Thank you.

2-8 11:28
Use props
djiuser_aPpCBisdPPEq
lvl.1

Italy
Offline

I have this very same issue:

Galaxy S6
Android 7.0
DJI GO 4 latest version
DJI Spark + Remote

No 2.4ghz option in my app
5-6 12:48
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules