Please select Into the mobile phone version | Continue to access the computer ver.
GS Pro not triggering Zen X5
381 1 2-9 01:14
Uploading and Loding Picture ...(0/1)
o(^-^)o
Skyline-UAV
lvl.1
Flight distance : 7500 ft
United Kingdom
Offline

Hi all
My current role is as a sub-contractor pilot flying a clients S900 + A3 + Lightbridge 2 + X5 + Micasense RedEdge (Multi-spectral camera) for crop growth analysis.

Some background/history:

The aircraft when received was assessed as being a house brick balanced on top of a broom handle when flown. I did a test flight and my fears were confirmed ....... So I opted to strip and rebulid her as if a new bird and do a full update of all FW and a fresh set-up and repair some old crash damage as well.

The outcome of all this is the slave shutter trigger (F3 Port) being enabled by the latest A3 FW update which now fires the RedEdge camera rather than it being run in timelapse mode independant of the aircraft and the mission profile being set to give the required overlap for mapping with the RedEdge FOV and the GS Pro app firing the X5 for the RGB imaging.

The Problem to solve is this:

When flying a map mission with GS Pro the X5 appears to be controlled by the app as the X5 moves from horizontal to Nadir view but does not record images on the memory card, while the RedEdge triggered by the A3 via the F3 port does take and record images on it's memory card????? so the trigger pulse is there


However when I bench test using the Dji GO app and the shutter button on the remote controller both cameras fire and record images???

All ideas/suggestions welcome.

Regards
Graham


2-9 01:14
Use props
Skyline-UAV
lvl.1
Flight distance : 7500 ft
United Kingdom
Offline

So after some further testing it seems that the new feature of a trigger pulse on an F Port has in reality no use whats so ever when it comes to mapping missions .............

The option to simultaniously fire the X5 and a slave camera is only available when using the Dji GO App!

When I use a mapping app ( I tried GS Pro, Precision Hawk and Pix4D apps) only 1 camera will fire either the slave camera if F3 is enabled or the Zen X5 if the F3 shutter port is disabled.

A rediculous state of affairs.

My only thoughts on this is when using the controller with Dji Go there is a more direct hardware control link whereas autominus flight/mapping apps are built on SDK??????

I need a solution urgently please as the "New" slave shutter pulse is the basis of a new hardware project now which has stopped before it even started!!!!!!!!!!!!!!!

Graham
2-11 09:03
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules