Please select Into the mobile phone version | Continue to access the computer ver.
No live feed on DJI inspire with x5
987 5 2019-2-19
Uploading and Loding Picture ...(0/1)

Hello users

I recently upgraded my camera to the x5. Changed the mounting plate and was ready to go. However I do not get a video feed on live view. The camera sees everything (according to histogram) but wont show a videofeed. Put the x3 on, everything fine. tried to update the camera and it gives me an error.
I have attached the logfile. Maybe someone can provide me with some more informationen.
It seems 2x device not detected and 1x it wants to 'lower the version' in row 00020396.

[00006651]========== 2019.02.19 21:28:03. boot(15) ============
[00006711]Packet [C:\WM610_FC550_FW_V01.11.01.50.bin] detected, card sn [0xfbf42655].
[00006774]Packet upgrade start...

[00006842]Packet checking...
[00006908]Packet vlink 01.11.0150 <-> 01.11.0150.
[00006971]Record vlink 01.08.0100 <-> 01.04.0070 (flow = 0).

[00007108]Version checking[1]...
[00007182][04 00][00] v1.31.1.67 -> v1.31.1.67
[00019750][08 00][00] device not detected.
[00019805][01 00][00] v1.29.5379 -> v1.29.5379
[00019864][01 01][00] v1.29.5379 -> v1.29.5379
[00019935][01 04][00] v0.5.5085 -> v0.5.5085
[00020034][03 05][00] v34.1.0.5 -> v34.1.0.5
[00020116][03 06][00] v2.4.20.50 -> v2.4.20.50
[00020215][05 00][00] v3.0.6.2 -> v3.0.6.2
[00020283][09 00][00] v5.0.0.0 -> v5.0.0.0
[00020396][11 00][00] v3.10.0.0 -> v3.9.0.0
[00020494][12 00][00] v1.11.0.0 -> v1.11.0.0
[00020615][12 01][00] v1.11.0.0 -> v1.11.0.0
[00020715][12 02][00] v1.11.0.0 -> v1.11.0.0
[00020834][12 03][00] v1.11.0.0 -> v1.11.0.0
[00033394][15 00][00] device not detected.
[00033474][17 00][00] v1.1.0.8 -> v1.1.0.8
[00033595][17 01][00] v2.0.1.6 -> v2.0.1.6
[00033663][19 00][00] v1.0.8.96 -> v1.0.8.96
[00035718]Packet upgrade failed at version checking.

Use props

Some more info.
I have checked all cables, the are attached and look good (no issues yet and cant imagine since x3 gives me a feed.
Tried various locations today. Even with low channel usage still nothing.
Using the latest app update as well as an Iphone Xs Max and an Iphone 7 plus. Same both are fine with the x3.
I assume it an update issue but it fails every time I try so what are the lines that seems to fail?
Use props
DJI Tony


Hi, we're sorry for the troubles that it caused. May we know if you successfully upgraded the firmware of your Zenmuse X5? If yes, would it be possible if you could provide us with a screenshot of this situation for further assistance? Please keep us posted on the latest progress. Thank you for continued support.
Use props

Thank you for the fast response.
As you can see in the update log it fails every time.
I get the normal update noise for about 20 - 30 secs and than a constant long beep for the update failing.
I tried several times but I wont go through.
The log always says the same.
Is there any other way I can update the x5 than using the inspire drone?
Use props
DJI Paladin
Super Moderator
Flight distance : 318 ft


Hi MartinB86, our apologies for the inconvenience. I would suggest you power off the aircraft and remount the gimbal and camera, then power on and then check whether the issue is fixed. Also, you can try to power off the drone, wipe the gimbal port and contact pins with anhydrous ethanol, then mount the gimbal and camera again, and restart the drone. You can also remount the gimbal mounting plate and make sure to gently reconnect the gimbal cable. Kindly make sure you do not pull or damage the gimbal cable when you remove the gimbal mounting plate. If the issue persists, please don't hesistate to contact us. Thanks for your support.

Gimbal cable.png
Use props
Henry M.Y.
First Officer
Flight distance : 10094199 ft
  • >>>
Hong Kong

Hi Martin,

The video encoding and transmission modules in your X5 were fried in the course of firmware updating, likely caused by not having switched off the remote controller BEFORE commencing firmware update of the Inspire 1 with X5. The descriptions "[08 00][00] device not detected." and "[15 00][00] device not detected." in log of subsequent unsuccessful firmware updates reflect this painful fact.

You have no choice but will have to send it in for repairing by DJI.

Use props
You need to log in before you can reply Login | Register now

Credit Rules