Please select Into the mobile phone version | Continue to access the computer ver.
Phantom 1 Drone 1Yellow 3Red Error
Uploading and Loding Picture ...(0/1)
o(^-^)o
Mahoney.Julia
lvl.1

United States
Offline

I have a Phantom 1 Drone that I am trying to repair for a school project. When I received the nonfunctioning drone, I was told that it was sold because the previous owner removed the propeller guards, but put the same screws back in(which were longer than the originals because of the guard) and screwed right into the motors. I have since replaced all four motors, and in doing so dealt with a plethora of error codes. The one the I'm stuck on is a flashing yellow and ten three red flashes. Although I guess it could be three red flashes and then one yellow. According to the Led Descriptions (see attached), it means GPA signal <5 Atti. What does this mean? How do I fix it?
I called the tech support line and they told me to recalibrated the compass. I did this, and nothing changed. I called back and they said to connected it to the NAZAM DJI Assistant on a computer and check the IMU Status and Reset the BTU info. I did this too and nothing changed. I also advanced calibrated it. I called the support line again, and they said there was nothing they could do. Please help me. I've never dealt with drones until now, and I just wanna pass this class.

LED DESCRIPTIONS.png
2019-2-21
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

Have you read the manual?  If not, that's the first thing you should do.

From your description, it sounds to me like the S1 switch is in the wrong position.  
2019-2-21
Use props
Mahoney.Julia
lvl.1

United States
Offline

Mark The Droner Posted at 2-21 13:21
Have you read the manual?  If not, that's the first thing you should do.

From your description, it sounds to me like the S1 switch is in the wrong position.

Yes, I have read the manual. If I change the position of the S1 switch, it changes the error code to 3red, 1 green. Its the same error just for the GPS mode instead of the ATTI mode.
2019-2-22
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

What makes you think it's an error code?  The rear lamps are how the AC communicates to the pilot.  

Both S switches should be all the way up when you are preparing to start the AC.

On my P2 series Phantoms (naza mode), a 3 red 1 green series of lamps would tell me the drone currently has 4 satellites or less locked into its system.  It also tells me the GPS system is working although I don't have GPS yet due to inadequate satellites.  It also tells me the AC senses the control signal.  So this is all good info.  

If the lamps change to 2 red and 1 green, I know I have 5 satellites locked.  Still not enough for GPS.  

If the lamps change to 1 red and 1 green, I can expect to see 20 quick green flashes next, indicating that the home point is set.  And I know I now have GPS working since I have the minimum six satellites needed for GPS.

If the lamps change to 1 green (pause), and repeats, I know I have seven or more satellites.  

If the 1 green above is ever 2 quick greens, it means the controller sticks are not centered.  So this is what it usually looks like when you're flying and you have 7 or more satellites locked.

If the 1 green above is ever yellow, your S switch is in ATTI mode, where it shouldn't be unless you're already in the air and you're deliberately trying to fly without the help of GPS.  

Everything above is for a P2 in Naza mode, but from your description, it sounds the same as a P1.  I have never owned a P1.  

Anyway, the flashing lamps are not showing errors.  They're just giving you info.  

Do the motors start?  Start them without props the first time.  

Have you calibrated the IMU and the compass?  I would do those two things next.   


Then fully charge your battery.  

Then it's time for a test flight.  


Good luck

2019-2-22
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules