Please select Into the mobile phone version | Continue to access the computer ver.
Help! Can't calibrate compass.
3957 11 2014-11-10
Uploading and Loding Picture ...(0/1)
o(^-^)o
JerEl
lvl.3

United States
Offline

I had an encounter with tree branches and the Phantom 2 hit the ground hard on one arm.  One arm was bent inward near the motor and I had to replace the complete case.  The Zenmuse gimbal was damaged so it was disconnected, removed, and sent off for repair.

Now the LEDs rapidly blink red and yellow after I start the copter.  When I flip the S1 switch back and forth to enter 'compass calibration' nothing happens, it just continues the red and yellow blinking of the LEDs.  Tried all other switch positions S1 & S2 and no response from any transmitter movement.

1)  I checked the binding of the transmitter with the copter and it showed as connected but reset it anyway per manual.
2)  Checked and re-checked all plugs and wiring on board, all seated well and seem okay including being in the right place.
3)  Checked and re-checked all solder joints (power, motors, ESCs, etc.), all okay.
4)  Connected it up to the assistant software and everything appears normal as before.
5)  Replaced the compass just in case

I've tried everything I could find from the manual, from some RC forums, and from YouTube videos and can't find any info on alternating red and yellow blinking of the LEDs except for compass calibration.

Any suggestions on what the problem may be?
2014-11-10
Use props
purefishing
lvl.1

United States
Offline

I have a similar issue, looking forward to reading any replies.
2014-11-10
Use props
Gerry1124
Captain

United States
Offline

purefishing@cap Posted at 2014-11-11 10:26
I have a similar issue, looking forward to reading any replies.

According to my card on my phantom 2 V+, a red/yellow flashing indicates the compass calibration failed.  Have you recalibrated everything?
2014-11-10
Use props
DJI-Sophie
lvl.3

China
Offline

Yes, please connect to the Assistant, check the compass value under Tools; also, please calibrate the U channel.
2014-11-11
Use props
JerEl
lvl.3

United States
Offline

purefishing@cap Posted at 2014-11-11 10:26
I have a similar issue, looking forward to reading any replies.

I'm  beginning to think it may be the receiver radio.  I installed a brand new Zenmuse yesterday and it is acting strange and the tilt on the transmitter has no effect on the gimbal.  It just stays pointed down about 45 degrees.  At least DJI or their dealer actually replaced the Zenmuse rather than repair mine even though it was my error.  Thanks DJI!
2014-11-11
Use props
JerEl
lvl.3

United States
Offline

DJI-Sophie Posted at 2014-11-11 17:09
Yes, please connect to the Assistant, check the compass value under Tools; also, please calibrate th ...


Sophie,  I did hook it up to Assistant/Compass and it appeared to be working as I moved the copter the numbers were changing.  I tried the 'hard' reset but it wouldn't let me do it.  As I said below in another message I put the Zenmuse back on it and it is not working properly either and isn't responding to the tranmitter's command to tilt..  It is a brand new replacement for the one damaged in a crash hard enough to bend one of the arms up and I had to replace the whole body.

UNLESS...Somehow I plugged the Naza cables into the wrong slots as I was re-arranging the cables for a fixed camera mount (which I never got to use but it worked).  I checked though and it appears from all the pictures I could gather on the Net that the plugs into Naza are in the original place.

Could the crash damage the 'innards' of the Naza?  Motors appearing to get power as they move a bit at boot up.  Then the LEDS blink red-yellow, red-yellow and no matter what I do with the S1 & S2 switches nothing happens.  So it is impossible to calibrate compass.  I will hook it back up to the Assistant and see if all the updates show to each item and what the compass page does and then report back.

I don't understand why the compass procedure doesn't work, i.e. flipping the S1 switch back and forth which I've done many times successfully before the crash.
2014-11-11
Use props
purefishing
lvl.1

United States
Offline

DJI-Sophie Posted at 2014-11-11 17:09
Yes, please connect to the Assistant, check the compass value under Tools; also, please calibrate th ...

What is the Assistant?
2014-11-11
Use props
DJI-Sophie
lvl.3

China
Offline


Assistant software which can be downloaded from www.dji.com.
2014-11-11
Use props
JerEl
lvl.3

United States
Offline

DJI-Sophie Posted at 2014-11-11 17:09
Yes, please connect to the Assistant, check the compass value under Tools; also, please calibrate th ...


Sophie, I just noticed when the transmitter (Controller) is turned on the green LED lights up on the Phantom 2's receiver so it is bound to the transmitter.

So I went to the Assistant and nothing shows with the transmitter turned on and plugged into the USB port.  The copter shows up okay though but it won't let me do a hard "boot" of the compass like the directions says to do.

But still, why doesn't the transmitter connect to the Assistant?  Maybe something is wrong with the transmitter but it was never "crashed," dropped, or misused in any way.  Even put new batteries in it and that didn't help.  I'm at a loss here on why I can't get the transmitter to tell the Phantom 2 I'm trying to calibrate the compass. In Assistant with the Phantom hooked up it shows the compass changing as I rotate the phantom and but won't hard boot the compass or what ever it's called.  When new, I was able to check the controls (stick movement, etc.) of the transmitter.

See original post.  Any suggestions would help.
2014-11-13
Use props
JerEl
lvl.3

United States
Offline

Sophie, where'd you go.  Still can't fly!  Read above message.
2014-11-16
Use props
DJI-Sophie
lvl.3

China
Offline

Hi Jerel, do you have another controller to have a try? Please try with a different controller, and choose the controller version on the Assistant software.
2014-11-16
Use props
adesmond2
lvl.2

Singapore
Offline

JerEl Posted at 2014-11-14 07:00
Sophie, I just noticed when the transmitter (Controller) is turned on the green LED lights up on t ...

hmmm, have you tried to calibrate with the application in Phone, it's inside setting ->  compass calibration.

Since you mentioned you can't check the controllers in Phantom application on PC, I'm suspecting that you have not pair your controller yet. (just my 2 cents)
2014-11-17
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules