Please select Into the mobile phone version | Continue to access the computer ver.
Problem with S900
2050 4 2014-11-11
Uploading and Loding Picture ...(0/1)
o(^-^)o
Winchester
lvl.1

Austria
Offline

Hi !

i got S900 new - in the moment only S900 with Lipos and GoPro, no heavy gimbal or heavy Camera - take off weight is 5,2 Kg.

i tried first with no wind - everything was fine.

next day it was a little windy - about 15 kmH, start was ok , but in the air the S900 was unstable, "dancing" i would say, landing was difficult with the "dancing" S900. i tried different Gain Settings but no big changes.

so now i dont know what to do - is there something wrong with the S900 or with the flight controller ?

there are some people fly with a light S900, but i dont know if they have problems in windy conditions - like i have.

any help is wellcome !

Thanks
2014-11-11
Use props
ebeez88
lvl.2

Canada
Offline

Hi,
What FC are you using? I have an S1000 and had issues with stability but once I updated my firmware on the A2  the issue was resolved.
2014-11-12
Use props
Blade_Strike
Super Moderator
Flight distance : 872694 ft
  • >>>
United States
Offline

You could try an IMU calibration on the controller if using an a2
2014-11-12
Use props
sandberg1976
lvl.1

Sweden
Offline

And make sure the craft is balanced
2014-11-29
Use props
DJI-nick
lvl.1

China
Offline

Try to use bigger Lipo battery if you use Gopro as a payload which is too light for S900. you should make the S900's takeoff weight to 6.0-7.2 kg at least to enable the motor to work at a high dynamic status, which mean it can response faster.
2014-12-2
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules