Please select Into the mobile phone version | Continue to access the computer ver.
Smart Controller Update Failure
1117 2 2019-7-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
northernlens
lvl.1
Flight distance : 404954 ft
United States
Offline

I completely failed on a major, time-sensitive (sunrise) assignment this morning. Unable to connect Smart Controller to Mavic Pro 2 after hours of trying to get Firmware to upgrade on the Smart Controller with multiple rounds of technical support from DJI. No current thread gets to the actual details needed to solve this problem.
Here is a new thread to get to the heart of the matter. Mavic 2 Pro with Smart Controller. Prompted to upgrade Smart Controller Firmware to V01.00.0530. Attempted via wireless (Verizon 4G Hotspot with 3 bars). Download was slow, but complete. Update stayed at 0% with no progress. Shut unit off and on and prompts for upgrade continue each time you enter DJI GO4, but controller still functional. Each attempt to upgrade greeted by pop-up "Network connection unavailable, check network connection" despite easy access to network on the Smart Controller using Lightning Browser. Subsequent attempt successful after downloading DJI Assistant 2 to laptop and performing tethered installation. Read on for lessons learned:

1. DO NOT try this update without a high-speed internet connection (probably need video streaming speeds). High speed internet is required throughout download and updtae on the Smart Controller through 100% of the process.

2. For tethered Firmware Upgrade, the tether connection is not intuitive. I have a MacBook Pro with USB-C connections only. This required using an adaptor at the MAcBook Pro end to convert the MacBook USB-C outlet to a standard USB. The adpter then connects to the USB-3.0 end of the DJI cable (USB 3.0 has blue plastic within the male connector end of the cable). The Smart Controller connects to the USB-C end of the cable. SInce there are at least 3 different ways to connect compuiter to Smart COntroller, there is no way to figure this out without some random experimentation of guidance).

3. DJI Assistant 2 will launch and do absolutely nothing if the cable connection is incorrect, which led me to uninstall and reinstall the program severl times.

Once the internet connection is decent and the USB-3.0 to USB-C cable is connected correctly, all went quickly and cleanly.


Good suggestions, but too vague from DJI:

1. Try different internet connection: I tried 3, but all were slower than needed to get the job done.
2. Try to plug the cable in to different ports or try different cables: Correct, but again too vague. For the MacBook Pro, the USB-3.0 end of the cable has to go in to an adapter that converts from USB-3.0 to USB-C on the computer itself. The USB-C end of the cable goed in to the bottam USB-C connection on the Smart Controller. As to different cables, all you need is USB-3.0 (blue plastic in the end of the male connector) to USB-C. There is no majic to having to use a DJI supplied cable.

I think this is all correct. Please correct anything my 24 hours of work and failed assignment did not capture. Feedback welcome.
2019-7-9
Use props
AntDX316
Captain
Flight distance : 2982907 ft
  • >>>
United States
Offline

I firmware updated through the PC but when it hits 16% you need to press the screen even though it's off otherwise it will go to sleep.  Pressing it will keep it awake allowing it to go from a red light to a blue light thus progressing to 23% and beyond.

It went to sleep on me on the refresh as I do with all my DJI equipment.  On the 3rd time I did what I did in the 1st and it was good.  The controller firmware updates After all the files have been sent so disconnecting it while it's transmitting doesn't matter as it extracts the package after to go through it's update.
2019-7-25
Use props
DCSmith
lvl.3
United States
Offline

I'm on a Windows 10 platform.  I had the correct cable, but the "DJI Assistant 2 For Mavic" app kept giving me a network error.  I even tried a USB-C to USB-C cable.  Same response.  It never starts.  The error is almost immediate.  I have a 10up/100down Internet connection.   I tried tuyrning off my firewall - nope.  And finally did a factory reset on the Smart Controller.  Same error.
2019-7-27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules