Please select Into the mobile phone version | Continue to access the computer ver.
Mavic Pro lost RC connection
294 4 7-9 17:46
Uploading and Loding Picture ...(0/1)
o(^-^)o
SgtDannySgt
Second Officer
Flight distance : 283904 ft
Canada
Offline

Hello everyone, I have been experiencing RC disconnects and trying to figure out why. It started about 2 months ago, taking a video of one of our hydro-electric dams. The weather was clear and about 14C. I flew towards the dam and I first got a warning that the RC and the aircraft were having difficulties communicating and I had to adjust the antennas. This was odd as I am to believe that the antennas should be perpendicular to the aircraft and this was clearly the case. I adjusted the antennas and lost connection. The loss lasted several seconds and got the reconnection and brought the bird back. I changed the battery and decided to try again and used an approach route different to see if it would change and the second flight had the same result.

Today, I was taking a video of a river estuary and the weather was clear and sunny, 28C, winds 10 gusting to 20KMH, a beautiful flying day. I flew the bird out and after a few minuted I detected that the video on my iPhone was shacky and jerky. I continued with the flight and after several minutes I again got a message stating that the RC and my bird were having issues connecting and I should re-position the antennas, again contrary to the perpendicular "rule". Changed the antenna orientation and put them back and got the message that the RC and my bird had disconnected... again. After several seconds they reconnected and I RTH the UAV back and I terminated my day of flying.

Any ideas? This drone is pretty new, it is 3 months old, is a replacement unit for my first Mavic Pro which was lost in the jungle of Costa Rica.

Both the drone and the RC have the latest firmware as I checked before writing this. I checked the 3 videos I took and all 3 are smooth so the jerking I was seeing on the App was probably due to the communication.


Thanks everyone, waiting for replies and a solution as am quite hesitant to fly again until I can figure out what the issue is.

Danny


7-9 17:46
Use props
Woe
Captain
Flight distance : 3538780 ft
  • >>>
United States
Offline

Have you tried to calibrate the IMU. With winds gusting to 20kmh I would expect some shaky footage.
7-9 19:10
Use props
SgtDannySgt
Second Officer
Flight distance : 283904 ft
Canada
Offline

Thanks for your reply mate. On playback the footage was smooth and with no issues. I will calibrate the IMU today. I will attempt to troubleshoot this connection loss issue but it can be caused for several reasons. Anyone use the parabolic antenna signal range booster by chance? Do they make a difference?
7-11 04:53
Use props
DJI Stephen
Super Moderator

Online

Hello and good day SgtDannySgt. I am sorry for the trouble and thank you for reaching out. Please try to calibrate the IMU of your DJI Mavic Pro as Woe suggested on post #2. To see if the issue will still persist. In addition I will be posting an official DJI tutorial video on how to calibrate DJI Mavic Pro's IMU. In addition I would suggest for you to use the recommended antenna to your DJI Mavic Pro for compatibility and reliability. Also, it is not advisable to use the third-party accessories since it is not tested by DJI and it can void your warranty. The ranges depend on many factors, especially the flight environment. Thank you.

7-13 13:41
Use props
SgtDannySgt
Second Officer
Flight distance : 283904 ft
Canada
Offline

Hello

IMU calibrated
Compass calibrated
Video cache cleared
Cables and connectors appear OK

Flew yesterday and it was flawless.
7-15 05:21
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules